aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-15 00:29:13 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-15 00:29:13 +0000
commite8390e6e3c7cf23c6546db19b823f8b4fc9763b2 (patch)
tree0f9d2255cdc2514c08af673efe768018c7601866 /math
parent653d6eb934c51460f3a70b764c488261192385cc (diff)
downloadports-e8390e6e3c7cf23c6546db19b823f8b4fc9763b2.tar.gz
ports-e8390e6e3c7cf23c6546db19b823f8b4fc9763b2.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/GiNaC/Makefile2
-rw-r--r--math/R/Makefile2
-rw-r--r--math/arpack/Makefile2
-rw-r--r--math/bihar/Makefile2
-rw-r--r--math/blas/Makefile2
-rw-r--r--math/cln/Makefile2
-rw-r--r--math/eispack/Makefile2
-rw-r--r--math/fftw/Makefile2
-rw-r--r--math/freefem/Makefile2
-rw-r--r--math/gambit/Makefile2
-rw-r--r--math/guppi/Makefile2
-rw-r--r--math/libRmath/Makefile2
-rw-r--r--math/libneural/Makefile2
-rw-r--r--math/linpack/Makefile2
-rw-r--r--math/plplot/Makefile2
-rw-r--r--math/qhull/Makefile2
-rw-r--r--math/qhull5/Makefile2
-rw-r--r--math/spar/Makefile2
18 files changed, 18 insertions, 18 deletions
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index f384633ef170..f301d8addb7a 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -25,7 +25,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
MAKEINFO="makeinfo --no-split"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= ginac-config.1 ginsh.1 viewgar.1
INFO= ginac
diff --git a/math/R/Makefile b/math/R/Makefile
index 3a415308e99e..e65281586944 100644
--- a/math/R/Makefile
+++ b/math/R/Makefile
@@ -45,7 +45,7 @@ OPTIONS= ATLAS "Use ATLAS instead of BLAS/LAPACK" off \
MAN1= R.1
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
INSTALL_TARGET= install install-libR
ALL_TARGET= all
GNU_CONFIGURE= yes
diff --git a/math/arpack/Makefile b/math/arpack/Makefile
index 344f78082b51..e7cc22f9ee19 100644
--- a/math/arpack/Makefile
+++ b/math/arpack/Makefile
@@ -30,7 +30,7 @@ ALL_TARGET= lib
BLAS_LIBS?= ${LOCALBASE}/lib/libblas.a
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
pre-patch:
@(cd ${WRKSRC}; ${TAR} -xzf ${DISTDIR}/${DIST_SUBDIR}/patch.tar.gz)
diff --git a/math/bihar/Makefile b/math/bihar/Makefile
index 71e6027ccc6f..521c9012d176 100644
--- a/math/bihar/Makefile
+++ b/math/bihar/Makefile
@@ -23,7 +23,7 @@ EXTRACT_CMD= ${TAR}
EXTRACT_BEFORE_ARGS= -xf
EXTRACT_AFTER_ARGS= # empty
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PORTDOCS= fft.doc.gz
diff --git a/math/blas/Makefile b/math/blas/Makefile
index 707b3bb9d43f..bbce4ae1c455 100644
--- a/math/blas/Makefile
+++ b/math/blas/Makefile
@@ -19,7 +19,7 @@ COMMENT= Basic Linear Algebra, level 1, 2, and 3
CONFLICTS= elmer-mathlibs-1*
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NO_WRKSUBDIR= yes
do-configure:
diff --git a/math/cln/Makefile b/math/cln/Makefile
index c000aaf3b38a..af5458d3d71a 100644
--- a/math/cln/Makefile
+++ b/math/cln/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --infodir=${PREFIX}/info --mandir=${MANPREFIX}/man \
--with-gmp
MAKE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= cln-config.1
INFO= cln
diff --git a/math/eispack/Makefile b/math/eispack/Makefile
index 4869f064b7ea..0e6bb8419b2f 100644
--- a/math/eispack/Makefile
+++ b/math/eispack/Makefile
@@ -18,7 +18,7 @@ COMMENT= Eigenvalue system package
LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas
DIST_SUBDIR= ${PORTNAME}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NO_WRKSUBDIR= yes
SRCS = csroot.f epslon.f pythag.f bakvec.f balanc.f balbak.f bandr.f \
diff --git a/math/fftw/Makefile b/math/fftw/Makefile
index 997c3fb2b330..15b0f5db68e8 100644
--- a/math/fftw/Makefile
+++ b/math/fftw/Makefile
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_ARGS= --enable-shared
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PLIST_SUB= FFTW_SUFX="${FFTW_SUFX}"
.include <bsd.port.pre.mk>
diff --git a/math/freefem/Makefile b/math/freefem/Makefile
index 301f600cbbca..151233785e34 100644
--- a/math/freefem/Makefile
+++ b/math/freefem/Makefile
@@ -18,7 +18,7 @@ USE_X_PREFIX= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-optimization
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= freefem.1
diff --git a/math/gambit/Makefile b/math/gambit/Makefile
index 2a5353590951..51d52b168a73 100644
--- a/math/gambit/Makefile
+++ b/math/gambit/Makefile
@@ -23,7 +23,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
WX_CONFIG="${X11BASE}/bin/wxgtk2-2.6-config"
MAKE_ENV= WX_CONFIG="${X11BASE}/bin/wxgtk2-2.6-config"
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CPPFLAGS= ${PTHREAD_CFLAGS}
LDFLAGS= ${PTHREAD_LIBS}
diff --git a/math/guppi/Makefile b/math/guppi/Makefile
index a78a0e29eccc..473550df3365 100644
--- a/math/guppi/Makefile
+++ b/math/guppi/Makefile
@@ -24,7 +24,7 @@ USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomelibs bonobo libglade gal gnometarget
USE_PYTHON= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gnumeric --enable-explicit-python-linking
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/libglade-1.0" \
diff --git a/math/libRmath/Makefile b/math/libRmath/Makefile
index 4ae05a873b68..f660a51f079c 100644
--- a/math/libRmath/Makefile
+++ b/math/libRmath/Makefile
@@ -33,7 +33,7 @@ MAINTAINER= eric+fbports@vangyzen.net
COMMENT= The standalone math library from R
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+=--without-x
diff --git a/math/libneural/Makefile b/math/libneural/Makefile
index 5adac8399931..56a82833bb6a 100644
--- a/math/libneural/Makefile
+++ b/math/libneural/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= C++ implementation of the classic 3-layer perceptron in library form
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
post-patch:
@${REINPLACE_CMD} -e 's|$${CONFIG_SHELL-/bin/sh} $$ac_aux_dir|$$ac_aux_dir|' \
diff --git a/math/linpack/Makefile b/math/linpack/Makefile
index 9ae2e2d4f004..ffc1430818e4 100644
--- a/math/linpack/Makefile
+++ b/math/linpack/Makefile
@@ -17,7 +17,7 @@ COMMENT= Linear Algebra package
LIB_DEPENDS= blas.1:${PORTSDIR}/math/blas
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
DIST_SUBDIR= ${PORTNAME}
NO_WRKSUBDIR= yes
diff --git a/math/plplot/Makefile b/math/plplot/Makefile
index 71b012779140..f25ad2d747c1 100644
--- a/math/plplot/Makefile
+++ b/math/plplot/Makefile
@@ -30,7 +30,7 @@ CONFIGURE_ARGS= --disable-cgm --disable-java --disable-octave \
--with-gd-incdir=${LOCALBASE}/include \
--with-gd-libdir=${LOCALBASE}/lib \
--with-freetype-font-dir=${LOCALBASE}
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
PLIST_SUB= VERSION="${PORTVERSION}"
MAN1= plm2gif.1 plplot_libtool.1 plpr.1 pltek.1 pstex2eps.1
diff --git a/math/qhull/Makefile b/math/qhull/Makefile
index 57702508fd27..a932c3db9b90 100644
--- a/math/qhull/Makefile
+++ b/math/qhull/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Qhull computes convex hulls, Delaunay triangulations and halfspaces
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/math/qhull5/Makefile b/math/qhull5/Makefile
index 57702508fd27..a932c3db9b90 100644
--- a/math/qhull5/Makefile
+++ b/math/qhull5/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Qhull computes convex hulls, Delaunay triangulations and halfspaces
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
diff --git a/math/spar/Makefile b/math/spar/Makefile
index c2532dc97772..ac542830081c 100644
--- a/math/spar/Makefile
+++ b/math/spar/Makefile
@@ -18,7 +18,7 @@ COMMENT= A modular math parser
USE_GETOPT_LONG=yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAN1= spar.1