aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2014-02-18 14:23:03 +0000
commite9c34f4c34b0640b3613f03cd96e9f19730b2a07 (patch)
treeef2b2b24dfacf6def95c54d3379c421565b1fe2b /math
parent4dc7ccc95d370549c7c9c7c9c253d64aa92881ae (diff)
downloadports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.tar.gz
ports-e9c34f4c34b0640b3613f03cd96e9f19730b2a07.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/analitza/Makefile6
-rw-r--r--math/analitza/distinfo4
-rw-r--r--math/analitza/pkg-plist9
-rw-r--r--math/cantor/Makefile51
-rw-r--r--math/cantor/distinfo4
-rw-r--r--math/cantor/files/patch-src__backends__python2__python2extensions.cpp22
-rw-r--r--math/cantor/pkg-plist11
-rw-r--r--math/kalgebra/Makefile8
-rw-r--r--math/kalgebra/distinfo4
-rw-r--r--math/kalgebra/pkg-plist1
-rw-r--r--math/kbruch/Makefile8
-rw-r--r--math/kbruch/distinfo4
-rw-r--r--math/kbruch/pkg-plist1
-rw-r--r--math/kcalc/Makefile10
-rw-r--r--math/kcalc/distinfo4
-rw-r--r--math/kig/Makefile18
-rw-r--r--math/kig/distinfo4
-rw-r--r--math/kig/pkg-plist5
-rw-r--r--math/kmplot/Makefile8
-rw-r--r--math/kmplot/distinfo4
-rw-r--r--math/kmplot/pkg-plist1
-rw-r--r--math/rocs/Makefile10
-rw-r--r--math/rocs/distinfo4
-rw-r--r--math/rocs/pkg-plist38
24 files changed, 131 insertions, 108 deletions
diff --git a/math/analitza/Makefile b/math/analitza/Makefile
index ab2dfefe4ab1..d515ffd67a6c 100644
--- a/math/analitza/Makefile
+++ b/math/analitza/Makefile
@@ -3,15 +3,12 @@
PORTNAME= analitza
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= math kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Library from KDE Education project
-CONFLICTS_INSTALL= kalgebra-4.7.* kdeedu-4.[0-6].*
-
USE_XZ= yes
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
@@ -20,5 +17,4 @@ USE_QT4= corelib gui opengl svg xml \
USE_GL= glu
USE_LDCONFIG= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/analitza/distinfo b/math/analitza/distinfo
index d87af4f39422..7fc012d49389 100644
--- a/math/analitza/distinfo
+++ b/math/analitza/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/analitza-4.10.5.tar.xz) = d9167aaabb9d505b38f3524be4d306bb93063572141a012f8dc6b4abea1e8851
-SIZE (KDE/4.10.5/analitza-4.10.5.tar.xz) = 179084
+SHA256 (KDE/4.12.2/analitza-4.12.2.tar.xz) = 985e6deb10ec6de74e54953b44560411d3cf5dd8bbc861c332d27a7968d73508
+SIZE (KDE/4.12.2/analitza-4.12.2.tar.xz) = 179844
diff --git a/math/analitza/pkg-plist b/math/analitza/pkg-plist
index d08f5130cc78..24a0bace4df5 100644
--- a/math/analitza/pkg-plist
+++ b/math/analitza/pkg-plist
@@ -39,14 +39,17 @@ lib/cmake/analitza/AnalitzaTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/analitza/AnalitzaTargets.cmake
lib/libanalitza.so
lib/libanalitza.so.5
-lib/libanalitza.so.5.0.1
+lib/libanalitza.so.5.0.0
lib/libanalitzagui.so
lib/libanalitzagui.so.5
-lib/libanalitzagui.so.5.0.1
+lib/libanalitzagui.so.5.0.0
lib/libanalitzaplot.so
lib/libanalitzaplot.so.5
-lib/libanalitzaplot.so.5.0.1
+lib/libanalitzaplot.so.5.0.0
+share/apps/libanalitza/plots/3Ds.plots
share/apps/libanalitza/plots/basic_curves.plots
+share/apps/libanalitza/plots/conics.plots
+share/apps/libanalitza/plots/polar.plots
@dirrm share/apps/libanalitza/plots
@dirrm share/apps/libanalitza
@dirrm lib/cmake/analitza
diff --git a/math/cantor/Makefile b/math/cantor/Makefile
index 6c4b41989bda..cc5250a9981c 100644
--- a/math/cantor/Makefile
+++ b/math/cantor/Makefile
@@ -3,51 +3,44 @@
PORTNAME= cantor
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= math kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 frontend to mathematical software
-LIB_DEPENDS= spectre.1:${PORTSDIR}/print/libspectre \
- qalculate.5:${PORTSDIR}/math/libqalculate \
- analitza.5:${PORTSDIR}/math/analitza
-
-CONFLICTS= kdeedu-4.[0-6].*
+LIB_DEPENDS= libspectre.so:${PORTSDIR}/print/libspectre \
+ libqalculate.so:${PORTSDIR}/math/libqalculate \
+ libanalitza.so:${PORTSDIR}/math/analitza
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource pkgconfig
USE_QT4= corelib qtestlib_build xml xmlpatterns \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
+USE_PYTHON= 2
USE_LDCONFIG= yes
-OPTIONS_DEFINE= MAXIMA OCTAVE R
-MAXIMA_DESC= Maxima backend
-OCTAVE_DESC= Octave backend
-R_DESC= R backend
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= MAXIMA OCTAVE R SAGE SCILAB
+OPTIONS_SUB= yes # R
-.if ${PORT_OPTIONS:MMAXIMA}
-RUN_DEPENDS+= maxima:${PORTSDIR}/math/maxima
-.endif
+MAXIMA_DESC= Install Maxima
+MAXIMA_RUN_DEPENDS= maxima:${PORTSDIR}/math/maxima
-.if ${PORT_OPTIONS:MOCTAVE}
-RUN_DEPENDS+= octave:${PORTSDIR}/math/octave
-.endif
+OCTAVE_DESC= Install Octave
+OCTAVE_RUN_DEPENDS= octave:${PORTSDIR}/math/octave
-.if ${PORT_OPTIONS:MR}
-BUILD_DEPENDS+= R:${PORTSDIR}/math/R
-RUN_DEPENDS+= R:${PORTSDIR}/math/R
+R_DESC= Build R backend and install R
+R_BUILD_DEPENDS= R:${PORTSDIR}/math/R
+R_RUN_DEPENDS= R:${PORTSDIR}/math/R
# Required to set CFLAGS for -lgfortran.
-USES+= fortran
-PLIST_SUB+= R=""
-.else
-CMAKE_ARGS+= -DWITH_R:BOOL=FALSE
-PLIST_SUB+= R="@comment "
-.endif
+R_USE= FORTRAN=yes
+R_CMAKE_OFF= -DWITH_R:BOOL=FALSE
+
+SAGE_DESC= Install Sage
+SAGE_RUN_DEPENDS= sage:${PORTSDIR}/math/sage
+
+SCILAB_DESC= Install Scilab
+SCILAB_RUN_DEPENDS= scilab:${PORTSDIR}/math/scilab
.include <bsd.port.mk>
diff --git a/math/cantor/distinfo b/math/cantor/distinfo
index c708c883d4f6..ea630a89f55a 100644
--- a/math/cantor/distinfo
+++ b/math/cantor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/cantor-4.10.5.tar.xz) = a63b2923c5b811473978e6d8c111d1fc150cb054a15d8a4c99f3f4d31ba10a1c
-SIZE (KDE/4.10.5/cantor-4.10.5.tar.xz) = 319440
+SHA256 (KDE/4.12.2/cantor-4.12.2.tar.xz) = 1ac7c16797b2265c48e36cc3eb52d8d5d92b8a865254d581d135d66cfac1c2f9
+SIZE (KDE/4.12.2/cantor-4.12.2.tar.xz) = 330476
diff --git a/math/cantor/files/patch-src__backends__python2__python2extensions.cpp b/math/cantor/files/patch-src__backends__python2__python2extensions.cpp
new file mode 100644
index 000000000000..9ca9683b7ff7
--- /dev/null
+++ b/math/cantor/files/patch-src__backends__python2__python2extensions.cpp
@@ -0,0 +1,22 @@
+--- ./src/backends/python2/python2extensions.cpp.orig 2013-12-22 06:37:50.000000000 +0000
++++ ./src/backends/python2/python2extensions.cpp 2014-01-29 22:46:16.542974457 +0000
+@@ -52,7 +52,7 @@
+ QString Python2VariableManagementExtension::clearVariables()
+ {
+ QString delVariablesPythonSession = "for keyPythonBackend in dir():\n" \
+- " if (not 'PythonBackend' in keyPythonBackend)\ " \
++ " if (not 'PythonBackend' in keyPythonBackend)\\ " \
+ "and (not '__' in keyPythonBackend):\n" \
+ " del(globals()[keyPythonBackend])\n" \
+ "del(keyPythonBackend)\n";
+@@ -64,8 +64,8 @@
+ QString classSavePythonSession = "import shelve\n" \
+ "shelvePythonBackend = shelve.open('%1', 'n')\n" \
+ "for keyPythonBackend in dir():\n" \
+- " if (not 'PythonBackend' in keyPythonBackend)\ " \
+- "and (not '__' in keyPythonBackend)\ " \
++ " if (not 'PythonBackend' in keyPythonBackend)\\ " \
++ "and (not '__' in keyPythonBackend)\\ " \
+ "and (not '<module ' in unicode(globals()[keyPythonBackend])):\n" \
+ " shelvePythonBackend[keyPythonBackend] = globals()[keyPythonBackend]\n" \
+ "shelvePythonBackend.close()\n" \
diff --git a/math/cantor/pkg-plist b/math/cantor/pkg-plist
index e1f809120c9d..459a340d1875 100644
--- a/math/cantor/pkg-plist
+++ b/math/cantor/pkg-plist
@@ -23,6 +23,7 @@ lib/kde4/cantor_differentiateassistant.so
lib/kde4/cantor_eigenvaluesassistant.so
lib/kde4/cantor_eigenvectorsassistant.so
lib/kde4/cantor_helppanelplugin.so
+lib/kde4/cantor_importpackageassistant.so
lib/kde4/cantor_integrateassistant.so
lib/kde4/cantor_invertmatrixassistant.so
lib/kde4/cantor_kalgebrabackend.so
@@ -31,6 +32,7 @@ lib/kde4/cantor_nullbackend.so
lib/kde4/cantor_octavebackend.so
lib/kde4/cantor_plot2dassistant.so
lib/kde4/cantor_plot3dassistant.so
+lib/kde4/cantor_python2backend.so
lib/kde4/cantor_qalculatebackend.so
lib/kde4/cantor_qalculateplotassistant.so
%%R%%lib/kde4/cantor_rbackend.so
@@ -50,6 +52,7 @@ share/apps/cantor/cantor_create_matrix_assistant.rc
share/apps/cantor/cantor_differentiate_assistant.rc
share/apps/cantor/cantor_eigenvalues_assistant.rc
share/apps/cantor/cantor_eigenvectors_assistant.rc
+share/apps/cantor/cantor_import_package_assistant.rc
share/apps/cantor/cantor_integrate_assistant.rc
share/apps/cantor/cantor_invert_matrix_assistant.rc
share/apps/cantor/cantor_part.rc
@@ -66,13 +69,14 @@ share/apps/cantor/octavebackend/cantor_eigenvectors.m
share/apps/cantor/octavebackend/cantor_plot2d.m
share/apps/cantor/octavebackend/cantor_plot3d.m
share/apps/cantor/octavebackend/cantor_print.m
+share/apps/cantor/python2backend/keywords.xml
share/apps/cantor/sagebackend/keywords.xml
-share/apps/cantor/scilabbackend/keywords.xml
share/apps/cantor/xslt/latex.xsl
share/config.kcfg/cantor.kcfg
share/config.kcfg/cantor_libs.kcfg
share/config.kcfg/maximabackend.kcfg
share/config.kcfg/octavebackend.kcfg
+share/config.kcfg/python2backend.kcfg
share/config.kcfg/qalculatebackend.kcfg
%%R%%share/config.kcfg/rserver.kcfg
share/config.kcfg/sagebackend.kcfg
@@ -92,6 +96,7 @@ share/icons/hicolor/32x32/apps/cantor.png
share/icons/hicolor/48x48/apps/cantor.png
share/icons/hicolor/48x48/apps/maximabackend.png
share/icons/hicolor/48x48/apps/octavebackend.png
+share/icons/hicolor/48x48/apps/pythonbackend.png
share/icons/hicolor/48x48/apps/qalculatebackend.png
share/icons/hicolor/48x48/apps/rbackend.png
share/icons/hicolor/48x48/apps/sagebackend.png
@@ -103,6 +108,7 @@ share/kde4/services/cantor/differentiateassistant.desktop
share/kde4/services/cantor/eigenvaluesassistant.desktop
share/kde4/services/cantor/eigenvectorsassistant.desktop
share/kde4/services/cantor/helppanelplugin.desktop
+share/kde4/services/cantor/importpackageassistant.desktop
share/kde4/services/cantor/integrateassistant.desktop
share/kde4/services/cantor/invertmatrixassistant.desktop
share/kde4/services/cantor/kalgebrabackend.desktop
@@ -111,6 +117,7 @@ share/kde4/services/cantor/nullbackend.desktop
share/kde4/services/cantor/octavebackend.desktop
share/kde4/services/cantor/plot2dassistant.desktop
share/kde4/services/cantor/plot3dassistant.desktop
+share/kde4/services/cantor/python2backend.desktop
share/kde4/services/cantor/qalculatebackend.desktop
share/kde4/services/cantor/qalculateplotassistant.desktop
%%R%%share/kde4/services/cantor/rbackend.desktop
@@ -125,8 +132,8 @@ share/kde4/servicetypes/cantor_panelplugin.desktop
@dirrm share/kde4/services/cantor
@dirrm share/doc/HTML/en/cantor
@dirrm share/apps/cantor/xslt
-@dirrm share/apps/cantor/scilabbackend
@dirrm share/apps/cantor/sagebackend
+@dirrm share/apps/cantor/python2backend
@dirrm share/apps/cantor/octavebackend
@dirrm share/apps/cantor/maximabackend
@dirrm share/apps/cantor
diff --git a/math/kalgebra/Makefile b/math/kalgebra/Makefile
index c81134be2a97..4e52cda10216 100644
--- a/math/kalgebra/Makefile
+++ b/math/kalgebra/Makefile
@@ -3,16 +3,13 @@
PORTNAME= kalgebra
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= math kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE graph calculator
-LIB_DEPENDS= analitza.5:${PORTSDIR}/math/analitza
-
-CONFLICTS= kdeedu-4.[0-6].*
+LIB_DEPENDS= libanalitza.so:${PORTSDIR}/math/analitza
CMAKE_ARGS= -DBUILD_mobile:BOOL=FALSE
USE_GL= glu
@@ -22,5 +19,4 @@ USE_QT4= corelib declarative gui opengl \
moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/kalgebra/distinfo b/math/kalgebra/distinfo
index b218ddab0182..ae2e02432520 100644
--- a/math/kalgebra/distinfo
+++ b/math/kalgebra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/kalgebra-4.10.5.tar.xz) = 9615903560e50797a4d5c2b37dd1f1820df80e1d25baa96c59e2251b58989b6a
-SIZE (KDE/4.10.5/kalgebra-4.10.5.tar.xz) = 446648
+SHA256 (KDE/4.12.2/kalgebra-4.12.2.tar.xz) = 02b62f0cd2e12d352a6d764f529637ea4c517e9cb2fb102cfca378cf208a7ed5
+SIZE (KDE/4.12.2/kalgebra-4.12.2.tar.xz) = 271164
diff --git a/math/kalgebra/pkg-plist b/math/kalgebra/pkg-plist
index 6eefd4051345..81b8c500e873 100644
--- a/math/kalgebra/pkg-plist
+++ b/math/kalgebra/pkg-plist
@@ -14,6 +14,7 @@ share/doc/HTML/en/kalgebra/kalgebra-3dgraph-window.png
share/doc/HTML/en/kalgebra/kalgebra-console-window.png
share/doc/HTML/en/kalgebra/kalgebra-dictionary-window.png
share/doc/HTML/en/kalgebra/kalgebra-main-window.png
+share/doc/HTML/en/kalgebra/view-fullscreen.png
share/icons/hicolor/128x128/apps/kalgebra.png
share/icons/hicolor/16x16/apps/kalgebra.png
share/icons/hicolor/32x32/apps/kalgebra.png
diff --git a/math/kbruch/Makefile b/math/kbruch/Makefile
index 36227d93cc97..aa65c6d201f5 100644
--- a/math/kbruch/Makefile
+++ b/math/kbruch/Makefile
@@ -3,21 +3,15 @@
PORTNAME= kbruch
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= math kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 application to exercise fractions
-CONFLICTS= kdeedu-4.[0-6].*
-
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-MAN1= kbruch.1
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/kbruch/distinfo b/math/kbruch/distinfo
index 6f5a4c9c423f..b69bd871709e 100644
--- a/math/kbruch/distinfo
+++ b/math/kbruch/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/kbruch-4.10.5.tar.xz) = db84212f690deb60703572c26ec2ad696cf92a0c4bb5afbc2094d62cf3516298
-SIZE (KDE/4.10.5/kbruch-4.10.5.tar.xz) = 908572
+SHA256 (KDE/4.12.2/kbruch-4.12.2.tar.xz) = 66a9d8fcf98206907513e824dfd2026870f208b7d2e32f6070d09e8df7cf05ff
+SIZE (KDE/4.12.2/kbruch-4.12.2.tar.xz) = 897848
diff --git a/math/kbruch/pkg-plist b/math/kbruch/pkg-plist
index a42142b76500..5ed7c8abc6ce 100644
--- a/math/kbruch/pkg-plist
+++ b/math/kbruch/pkg-plist
@@ -1,4 +1,5 @@
bin/kbruch
+man/man1/kbruch.1.gz
share/applications/kde4/kbruch.desktop
share/apps/kbruch/AppMenuWidgetui.rc
share/apps/kbruch/FractionRingWidgetui.rc
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index 597087e4dec7..f002aeee91e6 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -3,22 +3,18 @@
PORTNAME= kcalc
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= math kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Scientific calculator for KDE
-LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
- mpfr:${PORTSDIR}/math/mpfr
-
-CONFLICTS_INSTALL= kdeutils-4.[0-7].*
+LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+ libmpfr.so:${PORTSDIR}/math/mpfr
USE_XZ= yes
USE_KDE4= kdeprefix kdehier automoc4 kdelibs
USES= cmake:outsource
USE_QT4= xml qmake_build moc_build rcc_build uic_build
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/kcalc/distinfo b/math/kcalc/distinfo
index c1ce64295560..8945afe0d4af 100644
--- a/math/kcalc/distinfo
+++ b/math/kcalc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/kcalc-4.10.5.tar.xz) = ea66e750d50ab0035489cc4012c64848a4054e1765221abcd8068f835c21d7bf
-SIZE (KDE/4.10.5/kcalc-4.10.5.tar.xz) = 94220
+SHA256 (KDE/4.12.2/kcalc-4.12.2.tar.xz) = c8069e1b60494ea6cb28d78a293af24c586d6fcd921ad56873d9e5a82ceb403d
+SIZE (KDE/4.12.2/kcalc-4.12.2.tar.xz) = 80632
diff --git a/math/kig/Makefile b/math/kig/Makefile
index 194da979e3df..f31780bc953f 100644
--- a/math/kig/Makefile
+++ b/math/kig/Makefile
@@ -2,33 +2,23 @@
PORTNAME= kig
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= math kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE 4 interactive geometry application
-CONFLICTS= kdeedu-4.[0-6].*
-
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= gui xml moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-MAN1= kig.1
-
OPTIONS_DEFINE= PYTHON
OPTIONS_DEFAULT= PYTHON
-PYTHON_DESC= Support for Python scripting (requires Boost)
+OPTIONS_SUB= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYTHON}
-LIB_DEPENDS+= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
-.endif
+PYTHON_DESC= Support for Python scripting (requires Boost)
+PYTHON_LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
.include <bsd.port.mk>
diff --git a/math/kig/distinfo b/math/kig/distinfo
index 24a16f73aa78..7ef8fd9eb6cf 100644
--- a/math/kig/distinfo
+++ b/math/kig/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/kig-4.10.5.tar.xz) = 92b93e7d1c4052884f983d223427a279d9aff0c40d378307bafdedf9c89ca8f1
-SIZE (KDE/4.10.5/kig-4.10.5.tar.xz) = 1530312
+SHA256 (KDE/4.12.2/kig-4.12.2.tar.xz) = 256c7cd42a07352dd865100509cc4323379d27a2873bda7494868f86646b298e
+SIZE (KDE/4.12.2/kig-4.12.2.tar.xz) = 1502868
diff --git a/math/kig/pkg-plist b/math/kig/pkg-plist
index 57636d5181be..fcee4f22ec6e 100644
--- a/math/kig/pkg-plist
+++ b/math/kig/pkg-plist
@@ -1,7 +1,9 @@
bin/kig
bin/pykig.py
lib/kde4/kigpart.so
+man/man1/kig.1.gz
share/applications/kde4/kig.desktop
+%%PYTHON%%share/apps/katepart/syntax/python-kig.xml
share/apps/kig/builtin-macros/circle_by_center_and_line.kigt
share/apps/kig/builtin-macros/circle_by_point_and_diameter.kigt
share/apps/kig/builtin-macros/equitriangle.kigt
@@ -71,6 +73,7 @@ share/apps/kig/icons/hicolor/22x22/actions/pointOnLine.png
share/apps/kig/icons/hicolor/22x22/actions/pointxy.png
share/apps/kig/icons/hicolor/22x22/actions/polygonsides.png
share/apps/kig/icons/hicolor/22x22/actions/polygonvertices.png
+share/apps/kig/icons/hicolor/22x22/actions/projection.png
share/apps/kig/icons/hicolor/22x22/actions/python.png
share/apps/kig/icons/hicolor/22x22/actions/radicalline.png
share/apps/kig/icons/hicolor/22x22/actions/ray.png
@@ -162,6 +165,7 @@ share/apps/kig/icons/hicolor/32x32/actions/pointOnLine.png
share/apps/kig/icons/hicolor/32x32/actions/pointxy.png
share/apps/kig/icons/hicolor/32x32/actions/polygonsides.png
share/apps/kig/icons/hicolor/32x32/actions/polygonvertices.png
+share/apps/kig/icons/hicolor/32x32/actions/projection.png
share/apps/kig/icons/hicolor/32x32/actions/python.png
share/apps/kig/icons/hicolor/32x32/actions/radicalline.png
share/apps/kig/icons/hicolor/32x32/actions/ray.png
@@ -252,6 +256,7 @@ share/apps/kig/icons/hicolor/scalable/actions/pointOnLine.svgz
share/apps/kig/icons/hicolor/scalable/actions/pointxy.svgz
share/apps/kig/icons/hicolor/scalable/actions/polygonsides.svgz
share/apps/kig/icons/hicolor/scalable/actions/polygonvertices.svgz
+share/apps/kig/icons/hicolor/scalable/actions/projection.svgz
share/apps/kig/icons/hicolor/scalable/actions/python.svgz
share/apps/kig/icons/hicolor/scalable/actions/radicalline.svgz
share/apps/kig/icons/hicolor/scalable/actions/ray.svgz
diff --git a/math/kmplot/Makefile b/math/kmplot/Makefile
index 5fb1edfa09c5..6a81ee639eb2 100644
--- a/math/kmplot/Makefile
+++ b/math/kmplot/Makefile
@@ -3,21 +3,15 @@
PORTNAME= kmplot
PORTVERSION= ${KDE4_VERSION}
CATEGORIES= math kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= Mathematical function plotter for KDE 4
-CONFLICTS= kdeedu-4.[0-6].*
-
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
USE_QT4= xml moc_build qmake_build rcc_build uic_build
USE_XZ= yes
-MAN1= kmplot.1
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/kmplot/distinfo b/math/kmplot/distinfo
index 6cabbe3b93e2..beb8441b506e 100644
--- a/math/kmplot/distinfo
+++ b/math/kmplot/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/kmplot-4.10.5.tar.xz) = dd71296c28e087856c9ec7ef7a23c747f1f9e2b74f18042879855ad143b1479f
-SIZE (KDE/4.10.5/kmplot-4.10.5.tar.xz) = 681252
+SHA256 (KDE/4.12.2/kmplot-4.12.2.tar.xz) = 904ab90c2800e0cfa391fb2a60b4346d33f047d92d7220e0d27926e88d4048a3
+SIZE (KDE/4.12.2/kmplot-4.12.2.tar.xz) = 654872
diff --git a/math/kmplot/pkg-plist b/math/kmplot/pkg-plist
index 4466dd60d0ad..7a662c7ef98b 100644
--- a/math/kmplot/pkg-plist
+++ b/math/kmplot/pkg-plist
@@ -1,5 +1,6 @@
bin/kmplot
lib/kde4/libkmplotpart.so
+man/man1/kmplot.1.gz
share/applications/kde4/kmplot.desktop
share/apps/kmplot/kmplot_part.rc
share/apps/kmplot/kmplot_part_readonly.rc
diff --git a/math/rocs/Makefile b/math/rocs/Makefile
index 01d59adb1e75..6bf11360fe9b 100644
--- a/math/rocs/Makefile
+++ b/math/rocs/Makefile
@@ -2,18 +2,15 @@
PORTNAME= rocs
PORTVERSION= ${KDE4_VERSION}
-PORTREVISION= 1
CATEGORIES= math kde
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
+MASTER_SITES= KDE/${KDE4_BRANCH}/${PORTVERSION}/src
DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Graph theory IDE
-LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
-
-CONFLICTS= kdeedu-4.[0-6].*
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libgrantlee_gui.so:${PORTSDIR}/devel/grantlee
USE_KDE4= kdehier kdelibs kdeprefix automoc4
USES= cmake:outsource
@@ -22,5 +19,4 @@ USE_QT4= gui qtestlib script scripttools webkit xml \
USE_XZ= yes
USE_LDCONFIG= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/rocs/distinfo b/math/rocs/distinfo
index 597891e81f93..442367d219f2 100644
--- a/math/rocs/distinfo
+++ b/math/rocs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (KDE/4.10.5/rocs-4.10.5.tar.xz) = f2b8a53de2225b593e71caaff0a489be68343d90bc46df921994bc242036ab83
-SIZE (KDE/4.10.5/rocs-4.10.5.tar.xz) = 1146192
+SHA256 (KDE/4.12.2/rocs-4.12.2.tar.xz) = dff25b78300312c2ee52698ce5a8e34b6bbd55e0a755b2c7d1faec47b53837a8
+SIZE (KDE/4.12.2/rocs-4.12.2.tar.xz) = 1143096
diff --git a/math/rocs/pkg-plist b/math/rocs/pkg-plist
index 01af7ac9346a..1b944ab09f7c 100644
--- a/math/rocs/pkg-plist
+++ b/math/rocs/pkg-plist
@@ -1,10 +1,11 @@
bin/rocs
+include/rocs/ConsoleModule.h
include/rocs/CoreTypes.h
include/rocs/Data.h
include/rocs/DataItem.h
include/rocs/DataStructure.h
+include/rocs/DataStructureBackendInterface.h
include/rocs/DataStructureBackendManager.h
-include/rocs/DataStructurePluginInterface.h
include/rocs/Document.h
include/rocs/GraphFileBackendManager.h
include/rocs/GraphFilePluginInterface.h
@@ -25,12 +26,21 @@ lib/kde4/rocs_tgffileformat.so
lib/kde4/rocs_tikzfileformat.so
lib/kde4/rocs_transformedgesplugin.so
lib/librocscore.so
-lib/librocscore.so.5
-lib/librocscore.so.5.0.1
+lib/librocscore.so.4
+lib/librocscore.so.%%KDE4_GENERIC_LIB_VERSION%%
lib/librocsvisualeditor.so
-lib/librocsvisualeditor.so.5
-lib/librocsvisualeditor.so.5.0.1
+lib/librocsvisualeditor.so.4
+lib/librocsvisualeditor.so.%%KDE4_GENERIC_LIB_VERSION%%
share/applications/kde4/rocs.desktop
+share/apps/rocs/engineapi/Console.xml
+share/apps/rocs/engineapi/Data.xml
+share/apps/rocs/engineapi/DataStructure.xml
+share/apps/rocs/engineapi/GraphEdge.xml
+share/apps/rocs/engineapi/GraphNode.xml
+share/apps/rocs/engineapi/GraphStructure.xml
+share/apps/rocs/engineapi/ListNode.xml
+share/apps/rocs/engineapi/ListStructure.xml
+share/apps/rocs/engineapi/Pointer.xml
share/apps/rocs/examples/AdjustProjection.js
share/apps/rocs/examples/NameAndNodes.js
share/apps/rocs/examples/NamesValues.js
@@ -93,6 +103,7 @@ share/apps/rocs/icons/hicolor/64x64/actions/rocsalignvmiddle.png
share/apps/rocs/icons/hicolor/64x64/actions/rocsselect.png
share/apps/rocs/icons/hicolor/64x64/actions/rocsselectmove.png
share/apps/rocs/icons/hicolor/scalable/actions/rocsadddata.svgz
+share/apps/rocs/icons/hicolor/scalable/actions/rocsadvancedsetup.svgz
share/apps/rocs/icons/hicolor/scalable/actions/rocsdelete.svgz
share/apps/rocs/icons/hicolor/scalable/actions/rocsdeletedata.svgz
share/apps/rocs/icons/hicolor/scalable/actions/rocsdeletegrey.svgz
@@ -100,10 +111,21 @@ share/apps/rocs/icons/hicolor/scalable/actions/rocseyeblack.svgz
share/apps/rocs/icons/hicolor/scalable/actions/rocsnew.svgz
share/apps/rocs/icons/hicolor/scalable/actions/rocstexticon.svgz
share/apps/rocs/icons/hicolor/scalable/actions/rocsvalueicon.svgz
+share/apps/rocs/plugin/apidoc/bootstrap-apiview.css
+share/apps/rocs/plugin/apidoc/bootstrap.css
+share/apps/rocs/plugin/apidoc/objectApi.html
+share/apps/rocs/plugin/apidoc/overview.html
share/apps/rocs/rocsui.rc
+share/apps/rocs/schemes/engineApi.xsd
share/apps/rocs_rootedtree/RootedTreeui.rc
share/config.kcfg/rocs.kcfg
share/config/rocs.knsrc
+share/doc/HTML/en/rocs/apiConsole.docbook
+share/doc/HTML/en/rocs/apiDatastructure.docbook
+share/doc/HTML/en/rocs/apiGraphstructure.docbook
+share/doc/HTML/en/rocs/apiLinkedListstructure.docbook
+share/doc/HTML/en/rocs/apiRootedTreestructure.docbook
+share/doc/HTML/en/rocs/chapterImportExport.docbook
share/doc/HTML/en/rocs/common
share/doc/HTML/en/rocs/document-selector.png
share/doc/HTML/en/rocs/hi22-action-rocsadddata.png
@@ -135,6 +157,8 @@ share/doc/HTML/en/rocs/rocs-toolbar-main.png
share/icons/hicolor/16x16/apps/rocs.png
share/icons/hicolor/32x32/apps/rocs.png
share/icons/hicolor/48x48/apps/rocs.png
+share/icons/hicolor/64x64/apps/rocs.png
+share/icons/hicolor/scalable/apps/rocs.svgz
share/kde4/services/rocs_GraphStructure.desktop
share/kde4/services/rocs_ListStructure.desktop
share/kde4/services/rocs_RootedTreeStructure.desktop
@@ -151,6 +175,9 @@ share/kde4/servicetypes/RocsGraphFilePlugin.desktop
share/kde4/servicetypes/RocsToolsPlugin.desktop
@dirrm share/doc/HTML/en/rocs
@dirrm share/apps/rocs_rootedtree
+@dirrm share/apps/rocs/schemes
+@dirrm share/apps/rocs/plugin/apidoc
+@dirrm share/apps/rocs/plugin
@dirrm share/apps/rocs/icons/hicolor/scalable/actions
@dirrm share/apps/rocs/icons/hicolor/scalable
@dirrm share/apps/rocs/icons/hicolor/64x64/actions
@@ -167,5 +194,6 @@ share/kde4/servicetypes/RocsToolsPlugin.desktop
@dirrm share/apps/rocs/icons
@dirrm share/apps/rocs/iconpacks
@dirrm share/apps/rocs/examples
+@dirrm share/apps/rocs/engineapi
@dirrm share/apps/rocs
@dirrm include/rocs