aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 03:27:57 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-07 04:19:55 +0000
commite9c7d2b48706794ce8f5c582d0edd7913d20c3f3 (patch)
treea879af2670f1294f90dcd36bc9ade24125bc928e /math
parent31bf1886ed9164c5cb36f6717fdb9f0f841d5c84 (diff)
downloadports-e9c7d2b48706794ce8f5c582d0edd7913d20c3f3.tar.gz
ports-e9c7d2b48706794ce8f5c582d0edd7913d20c3f3.zip
math/ambit: Add explicit Python build dependency (D29353)
This unbreaks the build when using devel/samurai. It previously got it through ninja which has a run dependency on Python. CMake Error at /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:218 (message): Could NOT find PythonInterp (missing: PYTHON_EXECUTABLE) Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:582 (_FPHSA_FAILURE_MESSAGE) /usr/local/share/cmake/Modules/FindPythonInterp.cmake:169 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) cmake/FindPythonLibsNew.cmake:59 (find_package) CMakeLists.txt:96 (find_package) http://package18.nyi.freebsd.org/data/122amd64-default-foo/2021-04-04_07h37m38s/logs/errors/ambit-tensor-0.5.1.log PR: 254678
Diffstat (limited to 'math')
-rw-r--r--math/ambit/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/math/ambit/Makefile b/math/ambit/Makefile
index f83f931ccc56..183bb67044f4 100644
--- a/math/ambit/Makefile
+++ b/math/ambit/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libhdf5.so:science/hdf5 \
libopenblas.so:math/openblas \
libsz.so:science/szip
-USES= cmake compiler:c++11-lang
+USES= cmake compiler:c++11-lang python:build
USE_GITHUB= yes
GH_ACCOUNT= jturney
USE_LDCONFIG= yes