aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-03 18:17:23 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-06-03 18:17:23 +0000
commited557fde7b7cc69d32e8e33f5c855df4a1c9de69 (patch)
tree86d6ea4a6b9c7aa86b758d1dad46aaa2142b3b5e /math
parent7f48822aeb5e196983bb43bed55b406159a2a09c (diff)
downloadports-ed557fde7b7cc69d32e8e33f5c855df4a1c9de69.tar.gz
ports-ed557fde7b7cc69d32e8e33f5c855df4a1c9de69.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/py-pandas/Makefile34
-rw-r--r--math/py-pandas/distinfo6
-rw-r--r--math/py-pandas/files/patch-GH1871961
-rw-r--r--math/py-pandas/files/pkg-message.in3
-rw-r--r--math/py-pandas/pkg-descr2
5 files changed, 26 insertions, 80 deletions
diff --git a/math/py-pandas/Makefile b/math/py-pandas/Makefile
index 77ac63699a69..6994568c396d 100644
--- a/math/py-pandas/Makefile
+++ b/math/py-pandas/Makefile
@@ -1,8 +1,8 @@
# $FreeBSD$
PORTNAME= pandas
-DISTVERSION= 0.22.0
-PORTREVISION= 1
+DISTVERSION= 0.23.0
+PORTREVISION= 0
CATEGORIES= math devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -25,11 +25,13 @@ OPTIONS_GROUP_ACCEL= BTLNCK NUMEXPR
OPTIONS_GROUP_STORAGE= BOTO TABLES
OPTIONS_GROUP_HTML= LXML HTML5LIB JINJA2
OPTIONS_GROUP_EXCEL= XLRD XLWT OPENPYXL XLSX
-OPTIONS_RADIO_SQL= ALCHEMY10 ALCHEMY11
+OPTIONS_RADIO_SQL= ALCHEMY10 ALCHEMY11 ALCHEMY12
OPTIONS_DEFAULT= BTLNCK NUMEXPR
-# Note: we cannot include math/py-statsmodels in *_DEPENDS because it
-# depends upon us for BUILD and RUN.
+# Note: we cannot include the following ports in *_DEPENDS because they depend
+# on us for BUILD and RUN.
+# devel/py-xarray
+# math/py-statsmodels
MPL_DESC= Support graphical plotting output via math/py-matplotlib
SCIPY_DESC= Support various statistical functions via science/py-scipy
@@ -40,37 +42,41 @@ TABLES_DESC= Support HDF5-based storage via devel/py-tables
LXML_DESC= Parse HTML with devel/py-lxml and www/py-beautifulsoup
JINJA2_DESC= Support conditional HTML formatting with devel/py-Jinja2
HTML5LIB_DESC= Parse HTML with www/py-html5lib and www/py-beautifulsoup
-OPENPYXL_DESC= Read/write MS Excel 2007+ with textproc/py-openpyxl
+OPENPYXL_DESC= Write MS Excel 2007+ with textproc/py-openpyxl
XLRD_DESC= Read MS Excel with textproc/py-xlrd
XLWT_DESC= Write MS Excel with textproc/py-xlwt
XLSX_DESC= Write MS Excel with textproc/py-xlsxwriter
ALCHEMY10_DESC= Support SQL databases via databases/py-sqlalchemy10
ALCHEMY11_DESC= Support SQL databases via databases/py-sqlalchemy11
+ALCHEMY12_DESC= Support SQL databases via databases/py-sqlalchemy12
ACCEL_DESC= Computation Acceleration Add-ons
STORAGE_DESC= Data Storage Add-ons
SQL_DESC= SQLAlchemy ORM Add-ons
HTML_DESC= HTML Parsing/Generation Add-ons
EXCEL_DESC= MS Excel I/O Add-ons
-MPL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>1.4.3:math/py-matplotlib@${FLAVOR}
-SCIPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0.14.0:science/py-scipy@${FLAVOR}
-BTLNCK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bottleneck>1.0.0:math/py-bottleneck@${FLAVOR}
+MPL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.4.3:math/py-matplotlib@${FLAVOR}
+SCIPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>=0.14.0:science/py-scipy@${FLAVOR}
+BTLNCK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bottleneck>=1.0.0:math/py-bottleneck@${FLAVOR}
NUMEXPR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numexpr>=2.4.6:math/py-numexpr@${FLAVOR}
BOTO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto@${FLAVOR}
-TABLES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tables>=3.0.0:devel/py-tables@${FLAVOR}
+TABLES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tables>=3.2.1:devel/py-tables@${FLAVOR}
-LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${FLAVOR} \
+LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.2.1:www/py-beautifulsoup@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${FLAVOR}
-HTML5LIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${FLAVOR} \
+HTML5LIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.2.1:www/py-beautifulsoup@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib@${FLAVOR}
JINJA2_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${FLAVOR}
-OPENPYXL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openpyxl>=2.2.0:textproc/py-openpyxl@${FLAVOR}
-XLRD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlrd>0:textproc/py-xlrd@${FLAVOR}
+OPENPYXL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openpyxl>=2.4.0:textproc/py-openpyxl@${FLAVOR}
+XLRD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlrd>=0.9.0:textproc/py-xlrd@${FLAVOR}
XLWT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlwt>0:textproc/py-xlwt@${FLAVOR}
XLSX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}XlsxWriter>0:textproc/py-xlsxwriter@${FLAVOR}
ALCHEMY10_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10@${FLAVOR}
ALCHEMY11_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy11>0:databases/py-sqlalchemy11@${FLAVOR}
+ALCHEMY12_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy12>0:databases/py-sqlalchemy12@${FLAVOR}
+
+OPENPYXL_IMPLIES= XLRD
SUB_FILES= pkg-message
diff --git a/math/py-pandas/distinfo b/math/py-pandas/distinfo
index 5ed28223e3e7..91b7080d4577 100644
--- a/math/py-pandas/distinfo
+++ b/math/py-pandas/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1516038682
-SHA256 (pandas-0.22.0.tar.gz) = 44a94091dd71f05922eec661638ec1a35f26d573c119aa2fad964f10a2880e6c
-SIZE (pandas-0.22.0.tar.gz) = 11297071
+TIMESTAMP = 1527374327
+SHA256 (pandas-0.23.0.tar.gz) = 84ab1d50590cb2d9554211f164dc1b1a216bc94da2ba922aed2690c83f248fd9
+SIZE (pandas-0.23.0.tar.gz) = 13092442
diff --git a/math/py-pandas/files/patch-GH18719 b/math/py-pandas/files/patch-GH18719
deleted file mode 100644
index 5063af1d0fe6..000000000000
--- a/math/py-pandas/files/patch-GH18719
+++ /dev/null
@@ -1,61 +0,0 @@
-commit c753e1e08b01a438aaa252327de046109bf4bcfd
-Author: Joris Van den Bossche <jorisvandenbossche@gmail.com>
-Date: Mon Dec 11 11:57:00 2017 +0100
-
- TST: make it possible to run tests without moto installed (#18719)
-
-diff pandas/tests/io/conftest.py pandas/tests/io/conftest.py
---- pandas/tests/io/conftest.py.orig 2017-12-11 10:57:00 UTC
-+++ pandas/tests/io/conftest.py
-@@ -1,6 +1,5 @@
- import os
-
--import moto
- import pytest
- from pandas.io.parsers import read_table
-
-@@ -42,6 +41,7 @@ def s3_resource(tips_file, jsonl_file):
- is yielded by the fixture.
- """
- pytest.importorskip('s3fs')
-+ moto = pytest.importorskip('moto')
- moto.mock_s3().start()
-
- test_s3_files = [
-diff pandas/tests/io/json/test_compression.py pandas/tests/io/json/test_compression.py
---- pandas/tests/io/json/test_compression.py.orig 2017-12-11 10:57:00 UTC
-+++ pandas/tests/io/json/test_compression.py
-@@ -1,5 +1,4 @@
- import pytest
--import moto
-
- import pandas as pd
- from pandas import compat
-@@ -73,6 +72,8 @@ def test_read_zipped_json():
- def test_with_s3_url(compression):
- boto3 = pytest.importorskip('boto3')
- pytest.importorskip('s3fs')
-+ moto = pytest.importorskip('moto')
-+
- if compression == 'xz':
- tm._skip_if_no_lzma()
-
-diff pandas/tests/io/test_excel.py pandas/tests/io/test_excel.py
---- pandas/tests/io/test_excel.py.orig 2017-12-11 10:57:00 UTC
-+++ pandas/tests/io/test_excel.py
-@@ -10,7 +10,6 @@ from warnings import catch_warnings
- import numpy as np
- import pytest
- from numpy import nan
--import moto
-
- import pandas as pd
- import pandas.util.testing as tm
-@@ -616,6 +615,7 @@ class XlrdTests(ReadingTestsBase):
- def test_read_from_s3_url(self):
- boto3 = pytest.importorskip('boto3')
- pytest.importorskip('s3fs')
-+ moto = pytest.importorskip('moto')
-
- with moto.mock_s3():
- conn = boto3.resource("s3", region_name="us-east-1")
diff --git a/math/py-pandas/files/pkg-message.in b/math/py-pandas/files/pkg-message.in
index 1f97e49496c0..0781d0c3502f 100644
--- a/math/py-pandas/files/pkg-message.in
+++ b/math/py-pandas/files/pkg-message.in
@@ -1,3 +1,4 @@
===
-If you wish, install math/py-statsmodels to enable parts of pandas.stats.
+Install math/py-statsmodels to enable parts of pandas.stats.
+Install devel/py-xarray to enable the to_xarray() function.
===
diff --git a/math/py-pandas/pkg-descr b/math/py-pandas/pkg-descr
index 74a39fc7b308..22d9e7b08004 100644
--- a/math/py-pandas/pkg-descr
+++ b/math/py-pandas/pkg-descr
@@ -4,4 +4,4 @@ data structures designed to make working with "relational" or
fundamental high-level building block for doing practical, real
world data analysis in Python.
-WWW: http://pandas.pydata.org/
+WWW: https://pandas.pydata.org/