aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorPedro F. Giffuni <pfg@FreeBSD.org>2019-04-19 20:18:05 +0000
committerPedro F. Giffuni <pfg@FreeBSD.org>2019-04-19 20:18:05 +0000
commitf2ec78a53fa92c6cd355be274ce237c7041bd589 (patch)
tree2d0bee3d16a802f8f78183f5d69cf0fe68a424fd /math
parent4247eac53454b5a2697aab3d35d6a6cea8f41740 (diff)
math/taucs: change metis4 dependency to metis.
We don't ship metis4 due to license concerns. Use metis 5 instead as it is reported to work fine and it passes the same tests as the previous version. Use the BSD/darwin memory detection code although we still don't pass the corresponding test. Pet portlint while here. PR: 234141 Approved by: thierry (mentor)
Notes
Notes: svn path=/head/; revision=499388
Diffstat (limited to 'math')
-rw-r--r--math/taucs/Makefile9
-rw-r--r--math/taucs/files/patch-src_taucs__memory.c44
2 files changed, 49 insertions, 4 deletions
diff --git a/math/taucs/Makefile b/math/taucs/Makefile
index 61e58402fe62..f1b7b59b2acd 100644
--- a/math/taucs/Makefile
+++ b/math/taucs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= taucs
PORTVERSION= 2.2
-PORTREVISION= 19
+PORTREVISION= 20
CATEGORIES= math
MASTER_SITES= http://www.tau.ac.il/~stoledo/taucs/${PORTVERSION}/ \
LOCAL/bf
@@ -17,12 +17,13 @@ LICENSE_NAME= TAUCS License
LICENSE_FILE= ${FILESDIR}/TAUCS-license.txt
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-LIB_DEPENDS= libmetis.so:math/metis4
+LIB_DEPENDS= libmetis.so:math/metis
-HAS_CONFIGURE= yes
USES= blaslapack fortran tar:tgz
USE_LDCONFIG= yes
+
NO_WRKSUBDIR= yes
+HAS_CONFIGURE= yes
OPTIONS_DEFINE= DOCS
@@ -92,7 +93,7 @@ do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.pdf ${STAGEDIR}${DOCSDIR}
-do-test: # XXX: building tests fail
+do-test: # XXX: building tests fail
.for t in ${TESTS}
@${PRINTF} "\n%s\n" "Building test_${t}"
@cd ${WRKSRC}_SHARED ; ${FC} ${FFLAGS} -Llib/FreeBSD -L./ \
diff --git a/math/taucs/files/patch-src_taucs__memory.c b/math/taucs/files/patch-src_taucs__memory.c
new file mode 100644
index 000000000000..923a89ca169a
--- /dev/null
+++ b/math/taucs/files/patch-src_taucs__memory.c
@@ -0,0 +1,44 @@
+--- src/taucs_memory.c.orig 2003-09-01 06:16:13 UTC
++++ src/taucs_memory.c
+@@ -123,7 +123,6 @@ double taucs_system_memory_size()
+ }
+ #endif
+
+-#ifdef OSTYPE_darwin
+ #define TAUCS_SYSTEM_MEMORY_SIZE_DEFINED
+
+ /* This is a BSD4.4 interface, so it should work on other BSD systems */
+@@ -134,7 +133,7 @@ double taucs_system_memory_size()
+ double taucs_system_memory_size()
+ {
+ int mib[2] = { CTL_HW, HW_PHYSMEM };
+- int int_retval;
++ unsigned long int_retval;
+ size_t len = sizeof(int);
+
+ taucs_printf("taucs_system_memory_size: calling sysctl\n");
+@@ -142,7 +141,7 @@ double taucs_system_memory_size()
+ if ( sysctl(mib,2,
+ &int_retval,&len,
+ NULL, 0)) {
+- taucs_printf("taucs_system_memory_size: ERROR, sysctl failed (on darwin)\n");
++ taucs_printf("taucs_system_memory_size: ERROR, HW_PAGESIZE sysctl failed (on bsd)\n");
+ return -1.0;
+ }
+ taucs_printf(" sysctl pagesize %d bytes\n",int_retval);
+@@ -151,14 +150,13 @@ double taucs_system_memory_size()
+ if ( sysctl(mib,2,
+ &int_retval,&len,
+ NULL, 0)) {
+- taucs_printf("taucs_system_memory_size: ERROR, sysctl failed (on darwin)\n");
++ taucs_printf("taucs_system_memory_size: ERROR, HW_PHYSMEM sysctl failed (on bsd)\n");
+ return -1.0;
+ }
+ taucs_printf(" sysctl physmem %d bytes\n",int_retval);
+
+ return (double) int_retval;
+ }
+-#endif
+
+ #ifdef OSTYPE_aix
+ #define TAUCS_SYSTEM_MEMORY_SIZE_DEFINED