aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-04-13 21:12:26 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-04-13 21:12:26 +0000
commitfc77cd40105299c168d42a56745205c54f734704 (patch)
tree0a85fe8e51c04cad88aa4099e1acb9c58ba05a6a /math
parentdfe13a5e0a7bb668f1afe6ebb2299278ba213fdb (diff)
downloadports-fc77cd40105299c168d42a56745205c54f734704.tar.gz
ports-fc77cd40105299c168d42a56745205c54f734704.zip
- Fix builds when ENV is set and not executable by using proper SETENV for /usr/bin/env
This fixes all cases of incorrect ENV/SETENV usage. Approved by: portmgr (implicit) With hat: portmgr PR: ports/173559
Notes
Notes: svn path=/head/; revision=315798
Diffstat (limited to 'math')
-rw-r--r--math/libjbigi/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/math/libjbigi/Makefile b/math/libjbigi/Makefile
index a9794a224b25..0e5e216f0fea 100644
--- a/math/libjbigi/Makefile
+++ b/math/libjbigi/Makefile
@@ -52,12 +52,12 @@ do-build:
.ifdef(JBIGI_BUILD_JCPUID)
# jcpuid
cd ${BUILD_WRKSRC}/jcpuid && \
- ${ENV} ${JBIGI_BUILD_ENV} \
+ ${SETENV} ${JBIGI_BUILD_ENV} \
${SH} ./build.sh
.endif
# jbigi
cd ${BUILD_WRKSRC}/jbigi && \
- ${ENV} ${JBIGI_BUILD_ENV} \
+ ${SETENV} ${JBIGI_BUILD_ENV} \
${SH} ./build_jbigi.sh dynamic
## prepare jar
.ifdef(JBIGI_BUILD_JCPUID)