aboutsummaryrefslogtreecommitdiff
path: root/math
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-04-12 09:15:36 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2020-04-12 09:15:36 +0000
commitfff3beb47a5580971d11bb924ecd452c61fe70fb (patch)
tree863c11df22d876cb1dce9f517746663e367a26d0 /math
parent6c6dca02a1109f1ed7ba16cf6d99479c83257158 (diff)
downloadports-fff3beb47a5580971d11bb924ecd452c61fe70fb.tar.gz
ports-fff3beb47a5580971d11bb924ecd452c61fe70fb.zip
Notes
Diffstat (limited to 'math')
-rw-r--r--math/blacs/Makefile30
-rw-r--r--math/blacs/files/Bmake.inc-openmpi.diff24
-rw-r--r--math/blacs/files/pkg-message.in4
3 files changed, 30 insertions, 28 deletions
diff --git a/math/blacs/Makefile b/math/blacs/Makefile
index 8a7c3c91c33a..7e7c6a8554d8 100644
--- a/math/blacs/Makefile
+++ b/math/blacs/Makefile
@@ -3,7 +3,7 @@
PORTNAME= blacs
PORTVERSION= 1.7
-PORTREVISION= 35
+PORTREVISION= 36
CATEGORIES= math
MASTER_SITES= NETLIB/blacs
DISTNAME= BLACS
@@ -12,33 +12,27 @@ DIST_SUBDIR= blacs
EXTRACT_ONLY= mpiblacs.tgz blacstester.tgz mpiblacs-patch03.tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= The BLACS (Basic Linear Algebra Communication Subprograms)
+COMMENT= BLACS (Basic Linear Algebra Communication Subprograms)
SUB_FILES= pkg-message
USES= fortran gmake
USE_LDCONFIG= yes
OPTIONS_DEFINE= DOCS
+OPTIONS_RADIO= MPI
+OPTIONS_RADIO_MPI= MPICH OPENMPI
+OPTIONS_DEFAULT= DOCS MPICH
-.include <bsd.port.pre.mk>
-
-.if ! ${PORT_OPTIONS:MDOCS}
-DISTFILES+= blacs_install.ps f77blacsqref.ps lawn94.ps \
+DOCS_DISTFILES= blacs_install.ps f77blacsqref.ps lawn94.ps \
cblacsqref.ps mpi_prop.ps mpiblacs_issues.ps
-.endif
-.if exists(${LOCALBASE}/mpi/openmpi/bin/mpirun)
-WITH_OPENMPI= yes
-.endif
+OPENMPI_LIB_DEPENDS= libmpi.so:net/openmpi3
+OPENMPI_EXTRA_PATCHES= ${FILESDIR}/Bmake.inc-openmpi.diff
-.if defined(WITH_OPENMPI)
-BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/lib/libmpi.so:net/openmpi
-RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:net/openmpi
-EXTRA_PATCHES+= ${FILESDIR}/Bmake.inc-openmpi.diff
-.else
-LIB_DEPENDS+= libmpich.so:net/mpich2
-EXTRA_PATCHES+= ${FILESDIR}/Bmake.inc-mpich.diff
-.endif
+MPICH_LIB_DEPENDS= libmpich.so:net/mpich2
+MPICH_EXTRA_PATCHES= ${FILESDIR}/Bmake.inc-mpich.diff
+
+.include <bsd.port.pre.mk>
F77EXTRAFLAGS= #-w -fno-globals -fugly-complex
DEBUG_LEVEL= 0
diff --git a/math/blacs/files/Bmake.inc-openmpi.diff b/math/blacs/files/Bmake.inc-openmpi.diff
index 649e969ae216..2800f5c6b390 100644
--- a/math/blacs/files/Bmake.inc-openmpi.diff
+++ b/math/blacs/files/Bmake.inc-openmpi.diff
@@ -1,5 +1,5 @@
---- Bmake.inc.orig 2014-08-22 23:54:21.000000000 +0200
-+++ Bmake.inc 2014-08-22 23:55:10.000000000 +0200
+--- Bmake.inc.orig 2014-08-22 23:54:21.000000000 +0200
++++ Bmake.inc 2014-08-22 23:55:10.000000000 +0200
@@ -13,7 +13,7 @@
# -----------------------------
# The top level BLACS directory
@@ -32,7 +32,7 @@
# -------------------------------------
- MPIdir = /usr/local/mpich
- MPILIBdir = $(MPIdir)/lib/
-+ MPIdir = @LOCALBASE@/mpi/openmpi
++ MPIdir = @LOCALBASE@/mpi/openmpi3
+ MPILIBdir =
MPIINCdir = $(MPIdir)/include
- MPILIB = $(MPILIBdir)/libmpich.a
@@ -40,7 +40,7 @@
# -------------------------------------
# All libraries required by the tester.
-@@ -86,7 +86,7 @@
+@@ -86,14 +86,14 @@
# The directory to find the required communication library include files,
# if they are required by your system.
# -----------------------------------------------------------------------
@@ -49,6 +49,14 @@
# ---------------------------------------------------------------------------
# The Fortran 77 to C interface to be used. If you are unsure of the correct
+ # setting for your platform, compile and run BLACS/INSTALL/xintface.
+ # Choices are: Add_, NoChange, UpCase, or f77IsF2C.
+ # ---------------------------------------------------------------------------
+- INTFACE = -Df77IsF2C
++ INTFACE = -DAdd_
+
+ # ------------------------------------------------------------------------
+ # Allows the user to vary the topologies that the BLACS default topologies
@@ -140,7 +140,7 @@
# If you know that your MPI uses the same handles for fortran and C
# communicators, you can replace the empty macro definition below with
@@ -70,14 +78,14 @@
- CC = gcc
- CCFLAGS = -O4
- CCLOADER = $(CC)
-+ F77 = @LOCALBASE@/mpi/openmpi/bin/mpif77
++ F77 = @LOCALBASE@/mpi/openmpi3/bin/mpif77
+ F77NO_OPTFLAGS = @F77EXTRAFLAGS@
+ F77FLAGS = @FFLAGS@
-+ F77LOADER = @LOCALBASE@/mpi/openmpi/bin/mpif77
++ F77LOADER = @LOCALBASE@/mpi/openmpi3/bin/mpif77
+ F77LOADFLAGS = @FFLAGS@
-+ CC = @LOCALBASE@/mpi/openmpi/bin/mpicc
++ CC = @LOCALBASE@/mpi/openmpi3/bin/mpicc
+ CCFLAGS = @CFLAGS@
-+ CCLOADER = @LOCALBASE@/mpi/openmpi/bin/mpicc
++ CCLOADER = @LOCALBASE@/mpi/openmpi3/bin/mpicc
CCLOADFLAGS =
-
# --------------------------------------------------------------------------
diff --git a/math/blacs/files/pkg-message.in b/math/blacs/files/pkg-message.in
index e6590e8a1200..ad414e96fc55 100644
--- a/math/blacs/files/pkg-message.in
+++ b/math/blacs/files/pkg-message.in
@@ -13,8 +13,8 @@
Or, if you're using OpenMPI:
% cd %%PREFIX%%/share/BLACS/TESTING
- % LD_LIBRARY_PATH=%%LOCALBASE%%/mpi/openmpi/lib/ export LD_LIBRARY_PATH
- % PATH=$PATH:%%LOCALBASE%%/mpi/openmpi/bin/ export PATH
+ % LD_LIBRARY_PATH=%%LOCALBASE%%/mpi/openmpi3/lib/ export LD_LIBRARY_PATH
+ % PATH=$PATH:%%LOCALBASE%%/mpi/openmpi3/bin/ export PATH
% mpirun -np 4 ./xCbtest_MPI-FreeBSD
% mpirun -np 4 ./xFbtest_MPI-FreeBSD