aboutsummaryrefslogtreecommitdiff
path: root/misc/actiona
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-02 18:08:23 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-02 18:08:23 +0000
commit7bb43608f5a35f600bc01c4091388815131c03bc (patch)
treea21752a67015ab9b902f3be8ba14c8c08f3361af /misc/actiona
parent237c32d16da2b4f88dfc534ed78f4d15a3129f3f (diff)
downloadports-7bb43608f5a35f600bc01c4091388815131c03bc.tar.gz
ports-7bb43608f5a35f600bc01c4091388815131c03bc.zip
New port: misc/actiona: Cross-platform automation tool
Notes
Notes: svn path=/head/; revision=486474
Diffstat (limited to 'misc/actiona')
-rw-r--r--misc/actiona/Makefile40
-rw-r--r--misc/actiona/distinfo3
-rw-r--r--misc/actiona/files/patch-actexecuter_actexecuter.pro11
-rw-r--r--misc/actiona/files/patch-gui_gui.pro11
-rw-r--r--misc/actiona/pkg-descr9
-rw-r--r--misc/actiona/pkg-plist35
6 files changed, 109 insertions, 0 deletions
diff --git a/misc/actiona/Makefile b/misc/actiona/Makefile
new file mode 100644
index 000000000000..ed02aabda0c8
--- /dev/null
+++ b/misc/actiona/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= actiona
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.10.0-4
+DISTVERSIONSUFFIX= -gd8874a32
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Cross-platform automation tool
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/property_tree/ini_parser.hpp:devel/boost-libs
+LIB_DEPENDS= libnotify.so:devel/libnotify \
+ libopencv_core.so:graphics/opencv-core \
+ libopencv_video.so:graphics/opencv
+
+USES= desktop-file-utils gl pkgconfig qmake gnome qt:5 shared-mime-info
+USE_GITHUB= yes
+GH_ACCOUNT= Jmgr
+USE_QT= concurrent core dbus gui multimedia network script scripttools speech sql widgets x11extras xml xmlpatterns \
+ buildtools_build uitools_build
+USE_GNOME= gdkpixbuf2 glib20
+USE_GL= gl
+USE_XORG= x11 xtst
+
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+
+NLS_USE= QT=linguisttools_build
+
+pre-build-NLS-on: # this is a hackish way to turn NLS on/off, asked the upstream to have the NLS option
+ @cd ${WRKSRC} && ${MAKE_CMD} locale_release
+
+post-stage-NLS-off:
+ @${RM} -r ${STAGEDIR}${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/misc/actiona/distinfo b/misc/actiona/distinfo
new file mode 100644
index 000000000000..7c0b5996da31
--- /dev/null
+++ b/misc/actiona/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1543764947
+SHA256 (Jmgr-actiona-v3.10.0-4-gd8874a32_GH0.tar.gz) = df32434beb9aa313d2845c562ae9745e9d50ae5bb0ada6b393a79a190fe647fb
+SIZE (Jmgr-actiona-v3.10.0-4-gd8874a32_GH0.tar.gz) = 1287453
diff --git a/misc/actiona/files/patch-actexecuter_actexecuter.pro b/misc/actiona/files/patch-actexecuter_actexecuter.pro
new file mode 100644
index 000000000000..f39fcec1acf6
--- /dev/null
+++ b/misc/actiona/files/patch-actexecuter_actexecuter.pro
@@ -0,0 +1,11 @@
+--- actexecuter/actexecuter.pro.orig 2018-12-02 16:33:24 UTC
++++ actexecuter/actexecuter.pro
+@@ -54,7 +54,7 @@ unix {
+ locales.files = ../locale/actexecuter_fr_FR.qm
+ locales.CONFIG = no_check_exist
+
+- manfile.path = $${PREFIX}/share/man/man1
++ manfile.path = $${PREFIX}/man/man1
+ manfile.files = ../docs/actexec.1
+
+ INSTALLS += target locales manfile
diff --git a/misc/actiona/files/patch-gui_gui.pro b/misc/actiona/files/patch-gui_gui.pro
new file mode 100644
index 000000000000..7925ef74a2da
--- /dev/null
+++ b/misc/actiona/files/patch-gui_gui.pro
@@ -0,0 +1,11 @@
+--- gui/gui.pro.orig 2018-12-02 16:33:46 UTC
++++ gui/gui.pro
+@@ -138,7 +138,7 @@ unix {
+ desktopfile.path = $${PREFIX}/share/applications
+ desktopfile.files = ../actiona.desktop
+
+- manfile.path = $${PREFIX}/share/man/man1
++ manfile.path = $${PREFIX}/man/man1
+ manfile.files = ../docs/actiona.1
+
+ mimefile.path = $${PREFIX}/share/mime/packages/
diff --git a/misc/actiona/pkg-descr b/misc/actiona/pkg-descr
new file mode 100644
index 000000000000..ccb1b02be9c4
--- /dev/null
+++ b/misc/actiona/pkg-descr
@@ -0,0 +1,9 @@
+Actiona is a task automation tool. It allows you to create and execute action
+lists.
+
+Users don't need to know any programming language to use it: its intuitive
+interface allows to create action lists (scripts) using drag & drop.
+
+Advanced users can use JavaScript (EcmaScript) to extend its functionality.
+
+WWW: https://wiki.actiona.tools/doku.php
diff --git a/misc/actiona/pkg-plist b/misc/actiona/pkg-plist
new file mode 100644
index 000000000000..d089578d065a
--- /dev/null
+++ b/misc/actiona/pkg-plist
@@ -0,0 +1,35 @@
+bin/actexec
+bin/actiona
+lib/actiona/actions/libActionPackData.so
+lib/actiona/actions/libActionPackDevice.so
+lib/actiona/actions/libActionPackInternal.so
+lib/actiona/actions/libActionPackSystem.so
+lib/actiona/actions/libActionPackWindows.so
+lib/actiona/libactiontools.so
+lib/actiona/libactiontools.so.1
+lib/actiona/libactiontools.so.1.0
+lib/actiona/libactiontools.so.1.0.0
+lib/actiona/libexecuter.so
+lib/actiona/libexecuter.so.1
+lib/actiona/libexecuter.so.1.0
+lib/actiona/libexecuter.so.1.0.0
+lib/actiona/libtools.so
+lib/actiona/libtools.so.1
+lib/actiona/libtools.so.1.0
+lib/actiona/libtools.so.1.0.0
+man/man1/actexec.1.gz
+man/man1/actiona.1.gz
+%%NLS%%%%DATADIR%%/locale/actexecuter_fr_FR.qm
+%%NLS%%%%DATADIR%%/locale/actionpackdata_fr_FR.qm
+%%NLS%%%%DATADIR%%/locale/actionpackdevice_fr_FR.qm
+%%NLS%%%%DATADIR%%/locale/actionpackinternal_fr_FR.qm
+%%NLS%%%%DATADIR%%/locale/actionpacksystem_fr_FR.qm
+%%NLS%%%%DATADIR%%/locale/actionpackwindows_fr_FR.qm
+%%NLS%%%%DATADIR%%/locale/actiontools_fr_FR.qm
+%%NLS%%%%DATADIR%%/locale/executer_fr_FR.qm
+%%NLS%%%%DATADIR%%/locale/gui_fr_FR.qm
+%%NLS%%%%DATADIR%%/locale/tools_fr_FR.qm
+share/applications/actiona.desktop
+share/icons/hicolor/48x48/apps/actiona.png
+share/mime/packages/actiona.xml
+share/pixmaps/actiona.png