aboutsummaryrefslogtreecommitdiff
path: root/misc/afbackup
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2005-09-09 21:38:23 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2005-09-09 21:38:23 +0000
commita7f8a2ee0ad946f0ed85c75c9712d5815579a228 (patch)
treec93b2cbcc77079eaebccd59d14e2c23819002154 /misc/afbackup
parent3e79eb1f163a62f1cc5a59c7b6bd76dc8c782cd3 (diff)
downloadports-a7f8a2ee0ad946f0ed85c75c9712d5815579a228.tar.gz
ports-a7f8a2ee0ad946f0ed85c75c9712d5815579a228.zip
Notes
Diffstat (limited to 'misc/afbackup')
-rw-r--r--misc/afbackup/Makefile15
-rw-r--r--misc/afbackup/files/pkg-plist.autokey1
-rw-r--r--misc/afbackup/files/pkg-plist.fixedorder1
3 files changed, 12 insertions, 5 deletions
diff --git a/misc/afbackup/Makefile b/misc/afbackup/Makefile
index ec7141aa6c15..c76de78c2733 100644
--- a/misc/afbackup/Makefile
+++ b/misc/afbackup/Makefile
@@ -10,8 +10,7 @@ PORTVERSION= 3.3.5
PORTREVISION= 3
CATEGORIES?= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= afbackup
-DISTNAME= ${PORTNAME}-3.3.5
+MASTER_SITE_SUBDIR= ${PORTNAME}
# XXX Remember to remove the comment if the actual variable is needed by someone.
#SLAVEDIRS=misc/afbackup-client misc/afbackup-server
@@ -21,7 +20,12 @@ COMMENT= AF's backup system
WRKSRC= ${WRKDIR}/afbackup-3.3.5
PLIST= ${WRKSRC}/pkg-plist
+.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
+.else
+CONFIGURE_ARGS+= --disable-nls
+.endif
+
.if ! defined(NO_DES)
USE_OPENSSL= yes
CONFIG_WITH_DES= --with-des --with-des-header=openssl/des.h \
@@ -157,8 +161,9 @@ pre-configure:
@${CP} ${WRKSRC}/changer.conf.chio ${WRKSRC}/changer.conf
.if !defined(NO_AUTOKEY) && !defined(NO_DES)
+PLIST_SRC+= pkg-plist.autokey
pre-build:
- @perl -le 'print( ( "a".."z", "A".."Z", "0".."9")[ map { rand( 62)} 0..( rand( 10)+10)])' >${WRKSRC}/cryptkey
+ @${PERL} -le 'print( ( "a".."z", "A".."Z", "0".."9")[ map { rand( 62)} 0..( rand( 10)+10)])' >${WRKSRC}/cryptkey
.endif
pre-install:
@@ -168,7 +173,7 @@ pre-install:
@for docfile in $(AFBACKUP_DOCS:S/^/share\/doc\/${PORTNAME}\//); do ${ECHO_CMD} $$docfile >>${PLIST}; done
.endif
@for plistfile in ${PLIST_SRC}; do ${CAT} ${FILESDIR}/$$plistfile >>${PLIST}; done
- @${CAT} ${PLIST} | perl -nle 'print unless $$lines{$$_}++' >${PLIST}.tmp
+ @${CAT} ${PLIST} | ${PERL} -nle 'print unless $$lines{$$_}++' >${PLIST}.tmp
@${CAT} ${PLIST}.tmp ${FILESDIR}/pkg-plist.fixedorder >${PLIST}
.if !defined(NOPORTDOCS)
@${ECHO_CMD} @cwd ${PREFIX} >>${PLIST}
@@ -177,7 +182,7 @@ pre-install:
@${SETENV} ${PKGINSTALL_ENV} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
-.if !defined(NO_AUTOKEY)
+.if !defined(NO_AUTOKEY) && !defined(NO_DES)
${INSTALL} ${COPY} -o afbackup -g operator -m 0400 ${WRKSRC}/cryptkey ${PREFIX}/etc/afbackup
.endif
.if !defined(NOPORTDOCS)
diff --git a/misc/afbackup/files/pkg-plist.autokey b/misc/afbackup/files/pkg-plist.autokey
new file mode 100644
index 000000000000..5584daf6335c
--- /dev/null
+++ b/misc/afbackup/files/pkg-plist.autokey
@@ -0,0 +1 @@
+etc/afbackup/cryptkey
diff --git a/misc/afbackup/files/pkg-plist.fixedorder b/misc/afbackup/files/pkg-plist.fixedorder
index b43cdf021776..ea8acd32a5c3 100644
--- a/misc/afbackup/files/pkg-plist.fixedorder
+++ b/misc/afbackup/files/pkg-plist.fixedorder
@@ -6,3 +6,4 @@
@dirrm share/afbackup/locale/de
@dirrm share/afbackup/locale
@dirrm share/afbackup
+@dirrm etc/afbackup