aboutsummaryrefslogtreecommitdiff
path: root/misc/amanda-server
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-12-03 15:15:39 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-12-03 15:15:39 +0000
commit220a74e07d8135933ff11e3d296c43846402e2eb (patch)
tree6586ebe30281159b445094d7e284c7302ec05078 /misc/amanda-server
parentcf0d77dc9ba35699a5c47646337de2932aa5219a (diff)
downloadports-220a74e07d8135933ff11e3d296c43846402e2eb.tar.gz
ports-220a74e07d8135933ff11e3d296c43846402e2eb.zip
- Amanda/Constants.pm is installed by amanda-client, and it includes
constat variable as of client components only. When amanda-server installed, Constants.pm should include also server components. - To work around it, use pkg-install/pkg-deinstall script to tweak this variable by inplace updating. Reported by: Christian Gusenbauer <c47g@gmx.at>
Notes
Notes: svn path=/head/; revision=265629
Diffstat (limited to 'misc/amanda-server')
-rw-r--r--misc/amanda-server/Makefile8
-rw-r--r--misc/amanda-server/files/pkg-deinstall.in9
-rw-r--r--misc/amanda-server/files/pkg-install.in9
3 files changed, 24 insertions, 2 deletions
diff --git a/misc/amanda-server/Makefile b/misc/amanda-server/Makefile
index 2cef20aa58da..b2cf3119d38e 100644
--- a/misc/amanda-server/Makefile
+++ b/misc/amanda-server/Makefile
@@ -7,7 +7,7 @@
PORTNAME= amanda
PORTVERSION= 3.2.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= misc
MASTER_SITES= SF/amanda/amanda%20-%20stable/${PORTVERSION}
@@ -78,6 +78,9 @@ RUN_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
# amanda-server part
.if !defined(CLIENT_ONLY)
+SUB_FILES+= pkg-install pkg-deinstall
+SUB_LIST+= PERL=${PERL} SITE_PERL_REL=${SITE_PERL_REL}
+
pre-everything::
.if defined(AMANDA_TAPE)
@${ECHO} "Use of \$AMANDA_TAPE is deprecated. Specify it in amanda.conf."
@@ -158,7 +161,8 @@ PLIST_SUB+= S3DEVICE='@comment '
.endif
post-install:
- ${CAT} ${PKGMESSAGE}
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CAT} ${PKGMESSAGE}
# amanda-client part
.else
diff --git a/misc/amanda-server/files/pkg-deinstall.in b/misc/amanda-server/files/pkg-deinstall.in
new file mode 100644
index 000000000000..dc962ad302fc
--- /dev/null
+++ b/misc/amanda-server/files/pkg-deinstall.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+if [ "$2" != "DEINSTALL" ]; then
+ exit 0
+fi
+
+%%PERL%% -i -pe "s|\" server restore client amrecover ndmp\"|\" client amrecover ndmp\"|" ${PKG_PREFIX}/%%SITE_PERL_REL%%/Amanda/Constants.pm
diff --git a/misc/amanda-server/files/pkg-install.in b/misc/amanda-server/files/pkg-install.in
new file mode 100644
index 000000000000..6405b2dce989
--- /dev/null
+++ b/misc/amanda-server/files/pkg-install.in
@@ -0,0 +1,9 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+if [ "$2" != "POST-INSTALL" ]; then
+ exit 0
+fi
+
+%%PERL%% -i -pe "s|\" client amrecover ndmp\"|\" server restore client amrecover ndmp\"|" ${PKG_PREFIX}/%%SITE_PERL_REL%%/Amanda/Constants.pm