aboutsummaryrefslogtreecommitdiff
path: root/misc/asbutton
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-04-21 10:41:18 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-04-21 10:41:18 +0000
commit4a4866776ad39be741f61679729d2e4e6c2fed4f (patch)
tree4326c3920fc6619e67cb9b24ceebc89dd12d0106 /misc/asbutton
parent32fd349c35b37080959fa2d433c00e21815ff02a (diff)
downloadports-4a4866776ad39be741f61679729d2e4e6c2fed4f.tar.gz
ports-4a4866776ad39be741f61679729d2e4e6c2fed4f.zip
Use MAKE_ARGS
Notes
Notes: svn path=/head/; revision=133828
Diffstat (limited to 'misc/asbutton')
-rw-r--r--misc/asbutton/Makefile7
-rw-r--r--misc/asbutton/files/patch-aa33
2 files changed, 7 insertions, 33 deletions
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
index fbecde49c515..94ad8ec75c4c 100644
--- a/misc/asbutton/Makefile
+++ b/misc/asbutton/Makefile
@@ -13,9 +13,16 @@ MASTER_SITES= http://www.tigr.net/afterstep/download/asbutton/
MAINTAINER= ports@FreeBSD.org
COMMENT= A dockapp that displays 4 or 9 buttons to run apps of your choice
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_XPM= yes
ALL_TARGET= asbutton
+MAKE_ARGS= INCLUDES="-I${X11BASE}/include/X11 -I${X11BASE}/include" \
+ LIBINC="-L${X11BASE}/lib" LIBS="-lm -lX11 -lXpm -lXext" \
+ CCFLAGS="${CFLAGS}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's:gcc :${CC} :' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/asbutton ${PREFIX}/bin
diff --git a/misc/asbutton/files/patch-aa b/misc/asbutton/files/patch-aa
deleted file mode 100644
index 72fad3b2c948..000000000000
--- a/misc/asbutton/files/patch-aa
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.orig Sat Jul 17 07:16:39 1999
-+++ Makefile Wed Jun 21 02:54:42 2000
-@@ -1,12 +1,12 @@
--INCLUDES =-I/usr/X11R6/include/X11 -I/usr/local/include -I/usr/include/X11R6/X11 -I/usr/X11R6/include
--LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
-+INCLUDES =-I${X11BASE}/include/X11 -I${X11BASE}/include
-+LIBINC =-L${X11BASE}/lib
- LIBS = -lm -lX11 -lXpm -lXext
- #CCFLAGS = -O6 -mpentiumpro -march=pentiumpro
--CCFLAGS = -O2
-+CCFLAGS = ${CFLAGS}
- TARGET = asbutton
- OBJECTS = asbutton.o readline.o
--BINDIR = /usr/local/bin
--ICONDIR = /usr/share/afterstep/desktop/icons/16bpp
-+BINDIR = ${PREFIX}/bin
-+ICONDIR = ${PREFIX}/share/asbutton
-
- ICONS = asb4-1.xpm asb4-2.xpm asb4-3.xpm asb4-4.xpm asb4-blank.xpm asb4-bullethole.xpm \
- asb4-filingcabinet.xpm asb4-gear.xpm asb4-gnu-button-thang.xpm \
-@@ -23,10 +23,10 @@
- asb9-corel.xpm asb9-gqview.xpm asb9-vim.xpm asb9-xmms.xpm
-
- .c.o:
-- gcc ${CCFLAGS} -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
-+ ${CC} ${CCFLAGS} -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
-
- ${TARGET}: ${OBJECTS}
-- gcc ${CCFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
-+ ${CC} ${CCFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
-
- clean::
- for i in ${OBJECTS}; do if [ -e $$i ] ; then rm $$i; fi; done