aboutsummaryrefslogtreecommitdiff
path: root/misc/asbutton
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2007-05-26 20:39:02 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2007-05-26 20:39:02 +0000
commitd5f9a73cc03d65fe6c1674778c9c1301d9cf31d7 (patch)
tree5fb9798560eb154afcbe7c5c5bf471e58d77f932 /misc/asbutton
parentadd90dd319be1d4e500d5a1fc89f648ef45d6af8 (diff)
downloadports-d5f9a73cc03d65fe6c1674778c9c1301d9cf31d7.tar.gz
ports-d5f9a73cc03d65fe6c1674778c9c1301d9cf31d7.zip
Fix build with gcc4.2
Notes
Notes: svn path=/head/; revision=191938
Diffstat (limited to 'misc/asbutton')
-rw-r--r--misc/asbutton/Makefile4
-rw-r--r--misc/asbutton/files/patch-asbutton.c14
2 files changed, 14 insertions, 4 deletions
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
index 4a3ce1370954..e528e6efcf17 100644
--- a/misc/asbutton/Makefile
+++ b/misc/asbutton/Makefile
@@ -23,10 +23,6 @@ MAKE_ARGS= INCLUDES="-I${X11BASE}/include/X11 -I${X11BASE}/include" \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's:gcc :${CC} :' ${WRKSRC}/Makefile
diff --git a/misc/asbutton/files/patch-asbutton.c b/misc/asbutton/files/patch-asbutton.c
new file mode 100644
index 000000000000..caeeb866c5c9
--- /dev/null
+++ b/misc/asbutton/files/patch-asbutton.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- asbutton.c.orig
++++ asbutton.c
+@@ -605,7 +605,7 @@
+ continue;
+ }
+ if ( !strncasecmp(line, "button", 6))
+- if (atoi(&(char)line[6]) == position)
++ if (atoi((char)line[6]) == position)
+ break;
+ }
+ } while (1);