aboutsummaryrefslogtreecommitdiff
path: root/misc/asbutton
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-06-23 13:14:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-06-23 13:14:38 +0000
commitfb93fc598bb9a507e903e91a8cbb0f991b4067ba (patch)
tree3722933f165cbda64606a8f4478ca6fb1e915188 /misc/asbutton
parent1663b0c0b08eb995d9e11ae34e9e68f3fb78e0d0 (diff)
downloadports-fb93fc598bb9a507e903e91a8cbb0f991b4067ba.tar.gz
ports-fb93fc598bb9a507e903e91a8cbb0f991b4067ba.zip
- Use MASTER_SITE_AFTERSTEP to MASTER_SITES
PR: 19468 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=29807
Diffstat (limited to 'misc/asbutton')
-rw-r--r--misc/asbutton/Makefile14
-rw-r--r--misc/asbutton/distinfo2
-rw-r--r--misc/asbutton/files/patch-aa33
3 files changed, 40 insertions, 9 deletions
diff --git a/misc/asbutton/Makefile b/misc/asbutton/Makefile
index 372671efa77f..d7cbb4e28742 100644
--- a/misc/asbutton/Makefile
+++ b/misc/asbutton/Makefile
@@ -8,29 +8,27 @@
PORTNAME= asbutton
PORTVERSION= 0.3
CATEGORIES= misc windowmaker afterstep
-MASTER_SITES= http://www.tigr.net/afterstep/as-apps/download/asbutton/ \
- ftp://ftp.afterstep.org/apps/asbutton/
+MASTER_SITES= ${MASTER_SITE_AFTERSTEP}
+MASTER_SITE_SUBDIR= apps/asbutton
MAINTAINER= jim@FreeBSD.org
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
USE_X_PREFIX= yes
-
-do-build:
- (cd ${WRKSRC} && make)
+ALL_TARGET= asbutton
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/asbutton ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/asbutton ${PREFIX}/bin
@${ECHO} "===> Installing icons in ${PREFIX}/share/asbutton"
@${MKDIR} ${PREFIX}/share/asbutton && ${CHMOD} a+rx ${PREFIX}/share/asbutton
- @${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${PREFIX}/share/asbutton
+ ${INSTALL_DATA} ${WRKSRC}/icons/*.xpm ${PREFIX}/share/asbutton
post-install:
@${ECHO} "===> Installing sample asbuttonrc in ${PREFIX}/share/examples/asbutton"
@${ECHO} "===> Copy to ~/.asbuttonrc and modify to desired config."
@${MKDIR} ${PREFIX}/share/examples/asbutton && ${CHMOD} a+rx ${PREFIX}/share/examples/asbutton
- @${INSTALL_DATA} ${WRKSRC}/.asbuttonrc ${PREFIX}/share/examples/asbutton/asbuttonrc && ${CHMOD} u+rw ${PREFIX}/share/examples/asbutton/asbuttonrc
+ ${INSTALL_DATA} ${WRKSRC}/.asbuttonrc ${PREFIX}/share/examples/asbutton/asbuttonrc && ${CHMOD} u+rw ${PREFIX}/share/examples/asbutton/asbuttonrc
@${ECHO} "===> Use 'asbutton -h' for help."
.include <bsd.port.mk>
diff --git a/misc/asbutton/distinfo b/misc/asbutton/distinfo
index 679e98de0ca9..7bc72ed48709 100644
--- a/misc/asbutton/distinfo
+++ b/misc/asbutton/distinfo
@@ -1 +1 @@
-MD5 (asbutton-0.3.tar.gz) = febcc9db3eb615856bbebdc966ea4f27
+MD5 (asbutton-0.3.tar.gz) = bfb9445670946654814333d707e6cb86
diff --git a/misc/asbutton/files/patch-aa b/misc/asbutton/files/patch-aa
new file mode 100644
index 000000000000..72fad3b2c948
--- /dev/null
+++ b/misc/asbutton/files/patch-aa
@@ -0,0 +1,33 @@
+--- Makefile.orig Sat Jul 17 07:16:39 1999
++++ Makefile Wed Jun 21 02:54:42 2000
+@@ -1,12 +1,12 @@
+-INCLUDES =-I/usr/X11R6/include/X11 -I/usr/local/include -I/usr/include/X11R6/X11 -I/usr/X11R6/include
+-LIBINC =-L/usr/X11R6/lib -L/usr/include/lib
++INCLUDES =-I${X11BASE}/include/X11 -I${X11BASE}/include
++LIBINC =-L${X11BASE}/lib
+ LIBS = -lm -lX11 -lXpm -lXext
+ #CCFLAGS = -O6 -mpentiumpro -march=pentiumpro
+-CCFLAGS = -O2
++CCFLAGS = ${CFLAGS}
+ TARGET = asbutton
+ OBJECTS = asbutton.o readline.o
+-BINDIR = /usr/local/bin
+-ICONDIR = /usr/share/afterstep/desktop/icons/16bpp
++BINDIR = ${PREFIX}/bin
++ICONDIR = ${PREFIX}/share/asbutton
+
+ ICONS = asb4-1.xpm asb4-2.xpm asb4-3.xpm asb4-4.xpm asb4-blank.xpm asb4-bullethole.xpm \
+ asb4-filingcabinet.xpm asb4-gear.xpm asb4-gnu-button-thang.xpm \
+@@ -23,10 +23,10 @@
+ asb9-corel.xpm asb9-gqview.xpm asb9-vim.xpm asb9-xmms.xpm
+
+ .c.o:
+- gcc ${CCFLAGS} -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
++ ${CC} ${CCFLAGS} -c -Wall ${INCLUDES} ${FLAGS} $< -o $*.o
+
+ ${TARGET}: ${OBJECTS}
+- gcc ${CCFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
++ ${CC} ${CCFLAGS} -o ${TARGET} ${OBJECTS} ${LIBINC} ${LIBS}
+
+ clean::
+ for i in ${OBJECTS}; do if [ -e $$i ] ; then rm $$i; fi; done