aboutsummaryrefslogtreecommitdiff
path: root/misc/biblical-curse
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
committerMathieu Arnold <mat@FreeBSD.org>2015-12-17 17:19:48 +0000
commit7c47779cb9cc1f12908949c26b831e944047ed17 (patch)
treecc6e929ebf67eee2cc8ce1692ea0663387b3a559 /misc/biblical-curse
parentb4c4d6656e7b913544a3cbd1bea7f40f7cad2e74 (diff)
downloadports-7c47779cb9cc1f12908949c26b831e944047ed17.tar.gz
ports-7c47779cb9cc1f12908949c26b831e944047ed17.zip
Fix usage of ${PERL5}.
${PERL5} points to a specific version of perl, say, perl5.22.1, it is fine to use it in a ports Makefile to do Perly things, but ports using it must use ${PERL}, that points to /usr/local/bin/perl so that if the minor version is updated, the shebang keep working. While there, make some ports use shebangfix, regen a few patches, and bump PORTREVISION where a shebang went from PERL5 to PERL. PR: 205367 With hat: portmgr Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=403913
Diffstat (limited to 'misc/biblical-curse')
-rw-r--r--misc/biblical-curse/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/misc/biblical-curse/Makefile b/misc/biblical-curse/Makefile
index ec02adbb8a7a..42ccd864f25a 100644
--- a/misc/biblical-curse/Makefile
+++ b/misc/biblical-curse/Makefile
@@ -10,18 +10,15 @@ DISTFILES= # none
MAINTAINER= tobez@FreeBSD.org
COMMENT= Fake biblical curse generator
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
+SHEBANG_FILES= biblical-curse
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/src
SRC= ${.CURDIR}/src
-pre-patch:
- @${CP} -R ${SRC} ${WRKDIR}
-
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/perl|${PERL}|' ${WRKSRC}/biblical-curse
+do-extract:
+ @${CP} -R ${SRC}/ ${WRKSRC}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/biblical-curse ${STAGEDIR}${PREFIX}/bin/biblical-curse