aboutsummaryrefslogtreecommitdiff
path: root/misc/birthday
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-10-26 13:39:28 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-10-26 13:39:28 +0000
commit348847f667f3b33d1b61f5e7a127500abb60e074 (patch)
tree776537820cefe4ae23c7337666a1fd5f70a24230 /misc/birthday
parentea666e7bbe0c9fd5fad96b74eb0d25ed1aec7379 (diff)
downloadports-348847f667f3b33d1b61f5e7a127500abb60e074.tar.gz
ports-348847f667f3b33d1b61f5e7a127500abb60e074.zip
Drop patches
Notes
Notes: svn path=/head/; revision=146395
Diffstat (limited to 'misc/birthday')
-rw-r--r--misc/birthday/Makefile12
-rw-r--r--misc/birthday/files/patch-Makefile65
-rw-r--r--misc/birthday/files/patch-getopt.h29
3 files changed, 12 insertions, 94 deletions
diff --git a/misc/birthday/Makefile b/misc/birthday/Makefile
index 5a05e65af3bc..ec2b54219146 100644
--- a/misc/birthday/Makefile
+++ b/misc/birthday/Makefile
@@ -17,4 +17,16 @@ MAN1= birthday.1
MANCOMPRESSED= no
PLIST_FILES= bin/birthday
+USE_GMAKE= yes
+MAKEFILE= ${WRKSRC}/Makefile.gnu
+ALL_TARGET= birthday
+MAKE_ARGS= CFLAGS="${CFLAGS} -DUNIX"
+
+do-configure:
+ cd ${WRKSRC} && ${MAKE} Makefile.gnu
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/birthday ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/birthday.man ${MAN1PREFIX}/man/man1/birthday.1
+
.include <bsd.port.mk>
diff --git a/misc/birthday/files/patch-Makefile b/misc/birthday/files/patch-Makefile
deleted file mode 100644
index 93013d80f796..000000000000
--- a/misc/birthday/files/patch-Makefile
+++ /dev/null
@@ -1,65 +0,0 @@
---- Makefile Sat Jan 16 18:08:59 1999
-+++ Makefile Thu Apr 4 19:21:49 2002
-@@ -1,24 +1,39 @@
--# overall makefile for birthday, to get around the differing syntax of Borland and GNU makes.
-+######################################################################
-+# birthday. Reminder of birthdays and other events in the near future.
-+# $Id: Makefile.in,v 1.3 2000/01/02 19:17:33 andy Exp $
-
--# version for GNU make
--Makefile.gnu: makemake Makefile.in
-- ./makemake unix < Makefile.in > $@
--
--# version for Borland make
--Makefile.bor: makemake Makefile.in
-- makemake dos < Makefile.in > $@
--
--# I think -o for BCC sets the /object/ file name, rather than the executable ...
--makemake: makemake.c
-- $(CC) -o makemake makemake.c
--
--# targets to make directly, without having to make -f
--birthday install clean: Makefile.gnu
-- make -f Makefile.gnu $@
--
--birthday.exe bdwin.exe: Makefile.bor
-- make -f Makefile.bor $@
--
--# for UNIX only
--../birthday.tgz: *
-- tar --exclude=RCS/* --dereference -czf ../birthday.tgz *
-+all: birthday
-+
-+# NB note the different syntax for if
-+
-+# UNIX is replaced by name of OS by makemake
-+OS=UNIX
-+
-+# can override this on the commandline if req'd
-+DEBUG=
-+OSCFLAGS=-Wall -Wstrict-prototypes
-+CFLAGS+=-O2 $(DEBUG) -D$(OS) $(OSCFLAGS)
-+# engine
-+ENGSRC=bdengine.c xmalloc.c
-+
-+# OS-specific sources
-+OSSRC=
-+
-+CMDSRC=birthday.c bdcal.c $(ENGSRC) $(OSSRC)
-+
-+CMDOBJ=$(CMDSRC:.c=.o)
-+
-+birthday: $(CMDOBJ)
-+ $(CC) $(LDFLAGS) $(CMDOBJ) -o $@
-+
-+# you can override this to use the new FHS locations.
-+SHARE=
-+#SHARE=/share
-+
-+install: birthday birthday.man
-+ # Installation of dirs bin and man/man1 removed
-+ install -s birthday $(PREFIX)/bin/birthday
-+ install -m 0644 birthday.man $(PREFIX)/man/man1/birthday.1
-+
-+clean:
-+ rm -f birthday *.o
diff --git a/misc/birthday/files/patch-getopt.h b/misc/birthday/files/patch-getopt.h
deleted file mode 100644
index b6f814d98c83..000000000000
--- a/misc/birthday/files/patch-getopt.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- getopt.h Thu Apr 4 19:15:06 2002
-+++ getopt.h Thu Apr 4 19:15:32 2002
-@@ -93,15 +93,22 @@
- optional_argument
- };
-
-+
-+// Note: FreeBSD does follow the normal GNU definition for getopt, but
-+// the checks below would cause it to use a new --conflicting-- definition.
-+// Therefore, the checks have been commented out.
-+//
-+// Niek Bergboer, 04-Apr-2002
-+
- #if __STDC__
--#if defined(__GNU_LIBRARY__)
-+//#if defined(__GNU_LIBRARY__)
- /* Many other libraries have conflicting prototypes for getopt, with
- differences in the consts, in stdlib.h. To avoid compilation
- errors, only prototype getopt for the GNU C library. */
- extern int getopt (int argc, char *const *argv, const char *shortopts);
--#else /* not __GNU_LIBRARY__ */
--extern int getopt ();
--#endif /* not __GNU_LIBRARY__ */
-+//#else /* not __GNU_LIBRARY__ */
-+//extern int getopt ();
-+//#endif /* not __GNU_LIBRARY__ */
- extern int getopt_long (int argc, char *const *argv, const char *shortopts,
- const struct option *longopts, int *longind);
- extern int getopt_long_only (int argc, char *const *argv,