aboutsummaryrefslogtreecommitdiff
path: root/misc/birthday
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-09 13:05:45 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-09 13:05:45 +0000
commita93d01320c3e684602d46a0b34e5485e9c5c8573 (patch)
tree2472ea94a8c4cf7c4e11ad7e31bc0e0bb69e8f98 /misc/birthday
parentf9a45a28bb7910799fd387722b32a7fca8548637 (diff)
downloadports-a93d01320c3e684602d46a0b34e5485e9c5c8573.tar.gz
ports-a93d01320c3e684602d46a0b34e5485e9c5c8573.zip
- Add stage support
- Convert USE_GMAKE to USES - Add LICENSE
Notes
Notes: svn path=/head/; revision=335978
Diffstat (limited to 'misc/birthday')
-rw-r--r--misc/birthday/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/misc/birthday/Makefile b/misc/birthday/Makefile
index 88d5c23b2b99..fce988c9c58f 100644
--- a/misc/birthday/Makefile
+++ b/misc/birthday/Makefile
@@ -9,21 +9,21 @@ MASTER_SITES= http://users.zetnet.co.uk/mortia/source/
MAINTAINER= ports@FreeBSD.org
COMMENT= Outputs reminders for upcoming events (e.g. birthdays)
-MAN1= birthday.1
-MANCOMPRESSED= no
-PLIST_FILES= bin/birthday
+LICENSE= ART10 GPLv2
+LICENSE_COMB= dual
-USE_GMAKE= yes
+PLIST_FILES= bin/birthday man/man1/birthday.1.gz
+
+USES= gmake
MAKEFILE= ${WRKSRC}/Makefile.gnu
ALL_TARGET= birthday
MAKE_ARGS= CFLAGS="${CFLAGS} -DUNIX"
-NO_STAGE= yes
do-configure:
cd ${WRKSRC} && ${MAKE} Makefile.gnu
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/birthday ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/birthday.man ${MAN1PREFIX}/man/man1/birthday.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/birthday ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/birthday.man ${STAGEDIR}${MAN1PREFIX}/man/man1/birthday.1
.include <bsd.port.mk>