aboutsummaryrefslogtreecommitdiff
path: root/misc/birthday
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-06-11 03:48:34 +0000
committerWill Andrews <will@FreeBSD.org>2001-06-11 03:48:34 +0000
commitb10246bb6da7177b73c634d5c438f7fef2ececec (patch)
tree718170661d936eae25912bd275295f76be36eb05 /misc/birthday
parentb8786aafeaa5ada6b321e02768c56b89adf88a7d (diff)
downloadports-b10246bb6da7177b73c634d5c438f7fef2ececec.tar.gz
ports-b10246bb6da7177b73c634d5c438f7fef2ececec.zip
Add birthday 1.4, a program that outputs reminders for upcoming
events (e.g. birthdays). PR: 27723 Submitted by: Niek Bergboer <niek@bergboer.net>
Notes
Notes: svn path=/head/; revision=43801
Diffstat (limited to 'misc/birthday')
-rw-r--r--misc/birthday/Makefile21
-rw-r--r--misc/birthday/distinfo1
-rw-r--r--misc/birthday/files/patch-Makefile81
-rw-r--r--misc/birthday/pkg-comment1
-rw-r--r--misc/birthday/pkg-descr7
-rw-r--r--misc/birthday/pkg-plist1
6 files changed, 112 insertions, 0 deletions
diff --git a/misc/birthday/Makefile b/misc/birthday/Makefile
new file mode 100644
index 000000000000..a8476d886f50
--- /dev/null
+++ b/misc/birthday/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: birthday
+# Date created: 21 May 2001
+# Whom: Niek Bergboer <niek@bergboer.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= birthday
+PORTVERSION= 1.4
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.nl.debian.org/debian/pool/main/b/birthday/
+DISTNAME= birthday_1.4
+
+MAINTAINER= niek@bergboer.net
+
+MAN1= birthday.1
+MANCOMPRESSED= no
+
+WRKSRC= ${WRKDIR}/birthday-1.4
+
+.include <bsd.port.mk>
diff --git a/misc/birthday/distinfo b/misc/birthday/distinfo
new file mode 100644
index 000000000000..dd1abb999050
--- /dev/null
+++ b/misc/birthday/distinfo
@@ -0,0 +1 @@
+MD5 (birthday_1.4.tar.gz) = 43a3fb421c4221a61719b61fd47055b2
diff --git a/misc/birthday/files/patch-Makefile b/misc/birthday/files/patch-Makefile
new file mode 100644
index 000000000000..749125497af5
--- /dev/null
+++ b/misc/birthday/files/patch-Makefile
@@ -0,0 +1,81 @@
+--- Makefile-- Sat Jan 16 18:08:59 1999
++++ Makefile Thu May 24 21:49:08 2001
+@@ -1,24 +1,27 @@
+-# overall makefile for birthday, to get around the differing syntax of Borland and GNU makes.
++######################################################################
++# birthday. Reminder of birthdays and other events in the near future.
++# CVS/RCS string removed
++# Edited by Niek Bergboer <niek@bergboer.net> for FreeBSD ports
+
+-# version for GNU make
+-Makefile.gnu: makemake Makefile.in
+- ./makemake unix < Makefile.in > $@
+-
+-# version for Borland make
+-Makefile.bor: makemake Makefile.in
+- makemake dos < Makefile.in > $@
+-
+-# I think -o for BCC sets the /object/ file name, rather than the executable ...
+-makemake: makemake.c
+- $(CC) -o makemake makemake.c
+-
+-# targets to make directly, without having to make -f
+-birthday install clean: Makefile.gnu
+- make -f Makefile.gnu $@
+-
+-birthday.exe bdwin.exe: Makefile.bor
+- make -f Makefile.bor $@
+-
+-# for UNIX only
+-../birthday.tgz: *
+- tar --exclude=RCS/* --dereference -czf ../birthday.tgz *
++all: birthday
++
++OS=UNIX
++OSCFLAGS=-Wall -Wstrict-prototypes
++CFLAGS+=-D$(OS) $(OSCFLAGS)
++
++# engine
++ENGSRC=bdengine.c xmalloc.c
++CMDSRC=birthday.c bdcal.c $(ENGSRC)
++
++CMDOBJ=$(CMDSRC:.c=.o)
++
++birthday: $(CMDOBJ)
++ $(CC) $(LDFLAGS) $(CMDOBJ) -o $@
++
++install: birthday birthday.man
++ # Installation of dirs bin and man/man1 removed
++ install -c -s birthday $(PREFIX)/bin/birthday
++ install -c -m 0644 birthday.man $(PREFIX)/man/man1/birthday.1
++
++clean:
++ rm -f birthday *.o
+--- bdengine.c-- Thu May 10 20:03:34 2001
++++ bdengine.c Thu May 24 21:43:51 2001
+@@ -186,9 +186,10 @@
+ if (n > 0) { \
+ ptr+=sprintf(ptr, "%d " txt "%s", n, (n == 1 ? "" : "s")); \
+ terms--; \
+- if (orgterms > 1) \
+- if (terms == 1) ptr += sprintf(ptr, " and "); \
+- else if (terms > 1) ptr += sprintf(ptr, ", "); \
++ if (orgterms > 1) { \
++ if (terms == 1) { ptr += sprintf(ptr, " and "); } \
++ else { if (terms > 1) ptr += sprintf(ptr, ", "); } \
++ } \
+ }
+ #endif /* NUMS_AS_WORDS */
+
+--- getopt.h-- Fri Aug 9 11:53:20 1996
++++ getopt.h Thu May 24 21:43:51 2001
+@@ -100,7 +100,8 @@
+ errors, only prototype getopt for the GNU C library. */
+ extern int getopt (int argc, char *const *argv, const char *shortopts);
+ #else /* not __GNU_LIBRARY__ */
+-extern int getopt ();
++/* But FreeBSD STDC does have the GNU syntax */
++extern int getopt (int argc, char *const *argv, const char *shortopts);
+ #endif /* not __GNU_LIBRARY__ */
+ extern int getopt_long (int argc, char *const *argv, const char *shortopts,
+ const struct option *longopts, int *longind);
diff --git a/misc/birthday/pkg-comment b/misc/birthday/pkg-comment
new file mode 100644
index 000000000000..69cbc3745b7c
--- /dev/null
+++ b/misc/birthday/pkg-comment
@@ -0,0 +1 @@
+A program that outputs reminders for upcoming events (e.g. birthdays)
diff --git a/misc/birthday/pkg-descr b/misc/birthday/pkg-descr
new file mode 100644
index 000000000000..fe4dd052a33a
--- /dev/null
+++ b/misc/birthday/pkg-descr
@@ -0,0 +1,7 @@
+Birthday displays a list of events which are coming up in the near future,
+based on a config file (~/.birthdays) in the user's home directory.
+Used in a user's .profile or crontab it can save the day for many
+a terminally disorganised soul...
+
+Originally by Andy Mortimer <andy.mortimer@zetnet.co.uk>
+Ported by Niek Bergboer <niek@bergboer.net>
diff --git a/misc/birthday/pkg-plist b/misc/birthday/pkg-plist
new file mode 100644
index 000000000000..b36fd20152bf
--- /dev/null
+++ b/misc/birthday/pkg-plist
@@ -0,0 +1 @@
+bin/birthday