aboutsummaryrefslogtreecommitdiff
path: root/misc/bsod
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-08 16:32:59 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-11-08 16:32:59 +0000
commit91eaf1876b3c03a8e1aab46ae5e5e616abaa4f3b (patch)
tree4e24ff5c793bb57be3f6955f7e754978177cd780 /misc/bsod
parent21e018c19c70abfa3cac8702763132f18aeee935 (diff)
downloadports-91eaf1876b3c03a8e1aab46ae5e5e616abaa4f3b.tar.gz
ports-91eaf1876b3c03a8e1aab46ae5e5e616abaa4f3b.zip
- Add misc/bsod
This program will let you UNIX user experience the authentic Microsoft Windows experience. Bsod displays the famous windows xp blue screen of death on the console. Errors and drivers causing the error are selected randomly from a large set of examples. WWW: https://www.vanheusden.com/bsod/
Notes
Notes: svn path=/head/; revision=425752
Diffstat (limited to 'misc/bsod')
-rw-r--r--misc/bsod/Makefile33
-rw-r--r--misc/bsod/distinfo3
-rw-r--r--misc/bsod/pkg-descr6
3 files changed, 42 insertions, 0 deletions
diff --git a/misc/bsod/Makefile b/misc/bsod/Makefile
new file mode 100644
index 000000000000..89d5536e3a6b
--- /dev/null
+++ b/misc/bsod/Makefile
@@ -0,0 +1,33 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= bsod
+PORTVERSION= 0.1
+CATEGORIES= misc
+MASTER_SITES= https://www.vanheusden.com/bsod/ \
+ http://mirror.amdmi3.ru/distfiles/
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Experience the authentic Microsoft Windows experience
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/license.txt
+
+USES= ncurses tar:tgz
+
+PORTDOCS= *
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= DOCS
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} -I${NCURSESINC} -L${NCURSESLIB} -lcurses -o ${PORTNAME} ${PORTNAME}.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/misc/bsod/distinfo b/misc/bsod/distinfo
new file mode 100644
index 000000000000..a0055c061f3d
--- /dev/null
+++ b/misc/bsod/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1478620643
+SHA256 (bsod-0.1.tgz) = ad6eb83637d1eb655ca7891933916266bd0624e08823490083b960ff15531c43
+SIZE (bsod-0.1.tgz) = 10128
diff --git a/misc/bsod/pkg-descr b/misc/bsod/pkg-descr
new file mode 100644
index 000000000000..487f8f56dd0d
--- /dev/null
+++ b/misc/bsod/pkg-descr
@@ -0,0 +1,6 @@
+This program will let you UNIX user experience the authentic Microsoft
+Windows experience. Bsod displays the famous windows xp blue screen
+of death on the console. Errors and drivers causing the error are
+selected randomly from a large set of examples.
+
+WWW: https://www.vanheusden.com/bsod/