aboutsummaryrefslogtreecommitdiff
path: root/misc/clex/Makefile
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2008-02-04 20:24:04 +0000
committerMichael Landin <mich@FreeBSD.org>2008-02-04 20:24:04 +0000
commit28c0c1ed2e10864666dbf0e7aa7e82ba17163402 (patch)
tree7b0e474a3e9fd087568babb4469aab03807c1a59 /misc/clex/Makefile
parent4273708f0daf295d22353a1ab69dcbdea6b89160 (diff)
downloadports-28c0c1ed2e10864666dbf0e7aa7e82ba17163402.tar.gz
ports-28c0c1ed2e10864666dbf0e7aa7e82ba17163402.zip
- Updated to 3.17;
- Updated MASTER_SITES; - Now using pkg-plist; - Now respect PORTDOCS. Submitted by: Felippe de Meirelles Motta <lippemail@gmail.com> PR: ports/120139
Notes
Notes: svn path=/head/; revision=206727
Diffstat (limited to 'misc/clex/Makefile')
-rw-r--r--misc/clex/Makefile25
1 files changed, 20 insertions, 5 deletions
diff --git a/misc/clex/Makefile b/misc/clex/Makefile
index 011156f4281c..50706291fa17 100644
--- a/misc/clex/Makefile
+++ b/misc/clex/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= clex
-PORTVERSION= 3.16
+PORTVERSION= 3.17
CATEGORIES= misc
-MASTER_SITES= http://www.clex.sk/download/ \
- http://freebsdcluster.org/~mich/software/
+MASTER_SITES= http://www.clex.sk/download/
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mich@FreeBSD.org
@@ -18,7 +17,23 @@ COMMENT= A commandline file manager
GNU_CONFIGURE= yes
USE_GMAKE= yes
+DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
MAN1= clex.1
-PLIST_FILES= bin/clex
-.include <bsd.port.mk>
+OPTIONS= LARGE_FILES "Enable support for large files" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITH_LARGE_FILES)
+CONFIGURE_ARGS+= --disable-largefile
+.endif
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+ @${INSTALL_MAN} ${WRKSRC}/src/${MAN1} ${MAN1PREFIX}/man/man1
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>