aboutsummaryrefslogtreecommitdiff
path: root/misc/cloc/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-05-02 17:46:47 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-05-02 17:46:47 +0000
commit9df2f491d87958a2687ebbe400b38021eb1741fd (patch)
tree8c585125f9599efe925e7b832ecd014bf8a075f8 /misc/cloc/Makefile
parent573e3a6f5867743bf941ca3fbecf7738db66cfa2 (diff)
downloadports-9df2f491d87958a2687ebbe400b38021eb1741fd.tar.gz
ports-9df2f491d87958a2687ebbe400b38021eb1741fd.zip
Notes
Diffstat (limited to 'misc/cloc/Makefile')
-rw-r--r--misc/cloc/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/misc/cloc/Makefile b/misc/cloc/Makefile
new file mode 100644
index 000000000000..c4f14cd688fd
--- /dev/null
+++ b/misc/cloc/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cloc
+# Date created: 2 May 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cloc
+PORTVERSION= 0.80
+CATEGORIES= misc
+MASTER_SITES= SF
+EXTRACT_SUFX= .pl
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Counts lines of code
+
+USE_PERL5_RUN= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= ./${PORTNAME}
+PLIST_FILES= bin/${PORTNAME}
+NO_BUILD= yes
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>