aboutsummaryrefslogtreecommitdiff
path: root/misc/colortail
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-23 19:25:09 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-23 19:25:09 +0000
commit5cce72600ec881897bc8f75c52444c5dac5f6483 (patch)
treef50066ff7952fb7a0c0dce3d6eac3329432ff8f2 /misc/colortail
parent5ab552f542f38d7bc613928e3e46ea68e91159d3 (diff)
downloadports-5cce72600ec881897bc8f75c52444c5dac5f6483.tar.gz
ports-5cce72600ec881897bc8f75c52444c5dac5f6483.zip
Change MASTER_SITES to GitHub
- Convert to options target helper - Regenerate patch files with makepatch: - Update pkg-descr - Update WWW - Take maintainership
Notes
Notes: svn path=/head/; revision=462730
Diffstat (limited to 'misc/colortail')
-rw-r--r--misc/colortail/Makefile8
-rw-r--r--misc/colortail/distinfo5
-rw-r--r--misc/colortail/files/patch-CfgFileParser.h4
-rw-r--r--misc/colortail/files/patch-TailFile.cc10
-rw-r--r--misc/colortail/files/patch-configure11
-rw-r--r--misc/colortail/files/patch-configure.in11
-rw-r--r--misc/colortail/pkg-descr12
7 files changed, 34 insertions, 27 deletions
diff --git a/misc/colortail/Makefile b/misc/colortail/Makefile
index d1a439fd675c..cdea7873545f 100644
--- a/misc/colortail/Makefile
+++ b/misc/colortail/Makefile
@@ -4,21 +4,25 @@
PORTNAME= colortail
PORTVERSION= 0.3.3
CATEGORIES= misc
-MASTER_SITES= http://joakimandersson.se/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= tail(1) replacement with color support
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= autoreconf
GNU_CONFIGURE= yes
+GH_ACCOUNT= joakim666
+USE_GITHUB= yes
+
OPTIONS_DEFINE= EXAMPLES
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/colortail ${STAGEDIR}${PREFIX}/bin
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/example-conf/conf* ${STAGEDIR}${EXAMPLESDIR}
diff --git a/misc/colortail/distinfo b/misc/colortail/distinfo
index 11ce41d038d2..9e5682affebb 100644
--- a/misc/colortail/distinfo
+++ b/misc/colortail/distinfo
@@ -1,2 +1,3 @@
-SHA256 (colortail-0.3.3.tar.gz) = 0fabf424c3cc1aa030315d76490dbae64546a236abd8958bb3a99f8bdc322ae9
-SIZE (colortail-0.3.3.tar.gz) = 97399
+TIMESTAMP = 1519396123
+SHA256 (joakim666-colortail-0.3.3_GH0.tar.gz) = 03eb2158ad3a89f8040ef78662c5faabd503c598de10ca0461cbcd09a0a0c7ce
+SIZE (joakim666-colortail-0.3.3_GH0.tar.gz) = 51661
diff --git a/misc/colortail/files/patch-CfgFileParser.h b/misc/colortail/files/patch-CfgFileParser.h
index d9928fc38e8c..1b35d1b6792c 100644
--- a/misc/colortail/files/patch-CfgFileParser.h
+++ b/misc/colortail/files/patch-CfgFileParser.h
@@ -1,5 +1,5 @@
---- CfgFileParser.h.bak 2010-07-31 14:18:50.529980803 +0200
-+++ CfgFileParser.h 2010-07-31 14:18:59.977448567 +0200
+--- CfgFileParser.h.orig 2010-06-02 20:41:36 UTC
++++ CfgFileParser.h
@@ -24,7 +24,6 @@
#include "config.h"
diff --git a/misc/colortail/files/patch-TailFile.cc b/misc/colortail/files/patch-TailFile.cc
index a7681d0ac203..e61952a6f8b2 100644
--- a/misc/colortail/files/patch-TailFile.cc
+++ b/misc/colortail/files/patch-TailFile.cc
@@ -1,14 +1,16 @@
---- TailFile.cc.bak 2010-07-31 14:12:15.145254811 +0200
-+++ TailFile.cc 2010-07-31 14:13:31.996950208 +0200
-@@ -352,7 +352,10 @@
+--- TailFile.cc.orig 2010-06-02 20:41:36 UTC
++++ TailFile.cc
+@@ -352,8 +352,11 @@ void TailFile::follow_print(int n, int v
int ch = fgetc(m_file);
// add the character to the string
- m_follow_buffer->put(ch);
+-
+ if (ch == EOF)
+ clearerr(m_file); // required by POSIX and ANSI
+ else
+ m_follow_buffer->put(ch);
-
++
// check if return
if (ch == '\n')
+ {
diff --git a/misc/colortail/files/patch-configure b/misc/colortail/files/patch-configure
deleted file mode 100644
index 6323e638a68f..000000000000
--- a/misc/colortail/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.bak 2010-07-31 13:58:20.150270253 +0200
-+++ configure 2010-07-31 13:58:29.487410308 +0200
-@@ -4528,7 +4528,7 @@
-
-
-
--for ac_header in malloc.h unistd.h regex.h gnuregex.h
-+for ac_header in malloc.h unistd.h regex.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
diff --git a/misc/colortail/files/patch-configure.in b/misc/colortail/files/patch-configure.in
new file mode 100644
index 000000000000..23fa9311286f
--- /dev/null
+++ b/misc/colortail/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig 2010-06-02 20:41:36 UTC
++++ configure.in
+@@ -26,7 +26,7 @@ dnl Checks for libraries.
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(malloc.h unistd.h regex.h gnuregex.h)
++AC_CHECK_HEADERS(malloc.h unistd.h regex.h)
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
diff --git a/misc/colortail/pkg-descr b/misc/colortail/pkg-descr
index e5bc493bc82e..c97a462b5a1f 100644
--- a/misc/colortail/pkg-descr
+++ b/misc/colortail/pkg-descr
@@ -1,7 +1,7 @@
-Colortail works like the standard tail but it can optionally read
-a color config file where it's specified expressions that results
-in colors. It can be used to quickly get an overview of interesting
-activity by ie. colorize those brightred or some other color of
-your choose.
+Colortail works like tail but can optionally read one or more config files where
+it's specified which patterns results in which colors.
-WWW: http://pjek.se/projects/colortail/
+Colortail uses regular expressions (see re_format(7)) to determine which lines
+and parts of lines to print in which colors.
+
+WWW: https://github.com/joakim666/colortail