aboutsummaryrefslogtreecommitdiff
path: root/misc/compat4x
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-10-29 09:30:14 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-10-29 09:30:14 +0000
commitd7df3c0f7de12132e3e2a20ae560e4e36c25a2e5 (patch)
tree206391c49d2d2e1ae3b991e829e691c2a24541ce /misc/compat4x
parentdb5f7b6cf1398ed5620a303804068469c49673fc (diff)
downloadports-d7df3c0f7de12132e3e2a20ae560e4e36c25a2e5.tar.gz
ports-d7df3c0f7de12132e3e2a20ae560e4e36c25a2e5.zip
Fix file modes after extracting.
Some port's archives contains files modes that are a bit too restrictive for some usage. For example: BUILD_DEPENDS= ${NONEXISTENT}:foo/bar:configure When building as a regular user, dependencies are installed/built as root, so if the archive contains files that have a mode of, say, 600, they will not be readable by the port requesting the dependency. This will also fix broken distribution files where directories don't have the executable bit on. OSVERSION 1100077 is after base r283997: Change directory permissions in pre-order. In this order, it won't try to recurse into a directory for which it doesn't have permission, before changing that permission. This follows an existing behavior in other BSDs, linux, OS X. PR: 213574 Submitted by: mat Exp-run by: antoine Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=424898
Diffstat (limited to 'misc/compat4x')
-rw-r--r--misc/compat4x/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/misc/compat4x/Makefile b/misc/compat4x/Makefile
index 16413be46b48..f9ec6f4ef12f 100644
--- a/misc/compat4x/Makefile
+++ b/misc/compat4x/Makefile
@@ -74,7 +74,7 @@ COMPAT4X_MASTER_SITES= LOCAL/kris/${COMPAT4X_ARCH}
do-extract:
@${MKDIR} ${WRKDIR}
- @(cd ${DISTDIR}/${DIST_SUBDIR} && ${CAT} ${DISTFILES} | ${TAR} -xzf - -C ${WRKDIR} )
+ @(cd ${DISTDIR}/${DIST_SUBDIR} && ${CAT} ${DISTFILES} | ${TAR} -xzf - -C ${WRKDIR} usr/lib/compat )
.if !defined(FORCE_VULNERABLE_OPENSSL)
.for lib in ${OPENSSL_LIBS}
@${RM} ${WRKSRC}/${lib}