aboutsummaryrefslogtreecommitdiff
path: root/misc/compat5x
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2005-12-20 20:03:56 +0000
committerDoug Barton <dougb@FreeBSD.org>2005-12-20 20:03:56 +0000
commit40a70a81c24f07c73ba7bb3e78f689c4a9588226 (patch)
tree84df8ca5405209bee48f81769f90a995e223d266 /misc/compat5x
parent3b1ec7b41c92d84f0b57ffd1fddf1fca71e5d62b (diff)
downloadports-40a70a81c24f07c73ba7bb3e78f689c4a9588226.tar.gz
ports-40a70a81c24f07c73ba7bb3e78f689c4a9588226.zip
Reduce POLA violation for users who didn't expect to have to enable
this feature. Prodded by: pav
Notes
Notes: svn path=/head/; revision=151670
Diffstat (limited to 'misc/compat5x')
-rw-r--r--misc/compat5x/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index b6912b646c3b..65a7be4da2e7 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -11,7 +11,7 @@
PORTNAME= compat5x
PORTVERSION= 5.4.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=lesi/compat5x
@@ -67,6 +67,17 @@ PLIST_SUB+= SPARC64=""
PLIST_SUB+= SPARC64="@comment "
.endif
+post-extract:
+ @( ${ECHO} ""; \
+ ${ECHO} "******************************************************"; \
+ ${ECHO} "To enable the ldconfig of these libraries at boot time"; \
+ ${ECHO} "you need to add compat5x_enable=\"yes\" to either"; \
+ ${ECHO} "/etc/rc.conf.local or /etc/rc.conf"; \
+ ${ECHO} "******************************************************"; \
+ ${ECHO} ""; ) > ${WRKDIR}/pkg-message
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
NO_BUILD= yes
do-install:
@@ -78,4 +89,7 @@ do-install:
${LDCONFIG} -32 -m ${TARGET32_DIR}
.endif
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>