aboutsummaryrefslogtreecommitdiff
path: root/misc/compat5x
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-26 04:45:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-26 04:45:49 +0000
commit48832a763dfc267f11b1256cfc76fdf35883326b (patch)
treee31d7ab11944e89c8aa7a0f9622c06253022e0fc /misc/compat5x
parentcaf94d0106e9cb05b69d55c80d7a518d2f5cd678 (diff)
downloadports-48832a763dfc267f11b1256cfc76fdf35883326b.tar.gz
ports-48832a763dfc267f11b1256cfc76fdf35883326b.zip
- Stage support
Notes
Notes: svn path=/head/; revision=346096
Diffstat (limited to 'misc/compat5x')
-rw-r--r--misc/compat5x/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index 05c55322a22c..4735cb491032 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -28,7 +28,6 @@ TARGET_DIR= ${PREFIX}/lib/compat
TARGET32_DIR= ${PREFIX}/lib32/compat
USE_LDCONFIG= ${TARGET_DIR}
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
@@ -56,15 +55,15 @@ PLIST_SUB+= SPARC64="@comment "
.endif
do-install:
- @${MKDIR} -m 0755 ${TARGET_DIR}
+ @${MKDIR} -m 0755 ${STAGEDIR}${TARGET_DIR}
${RM} -f ${WRKSRC}/libpthread.so.1
- (cd ${TARGET_DIR} && ${LN} -sf libthr.so.1 libpthread.so.1)
- (cd ${WRKSRC} && ${INSTALL_DATA} *.so.* ${TARGET_DIR})
+ (cd ${STAGEDIR}${TARGET_DIR} && ${LN} -sf libthr.so.1 libpthread.so.1)
+ (cd ${WRKSRC} && ${INSTALL_DATA} *.so.* ${STAGEDIR}${TARGET_DIR})
.if ${ARCH} == amd64
- @${MKDIR} ${TARGET32_DIR}
+ @${MKDIR} ${STAGEDIR}${TARGET32_DIR}
${RM} -f ${WRKSRC}/lib32/libpthread.so.1
- (cd ${TARGET32_DIR} && ${LN} -sf libthr.so.1 libpthread.so.1)
- (cd ${WRKSRC}/lib32 && ${INSTALL_DATA} *.so.* ${TARGET32_DIR})
+ (cd ${STAGEDIR}${TARGET32_DIR} && ${LN} -sf libthr.so.1 libpthread.so.1)
+ (cd ${WRKSRC}/lib32 && ${INSTALL_DATA} *.so.* ${STAGEDIR}${TARGET32_DIR})
.endif
.include <bsd.port.post.mk>