aboutsummaryrefslogtreecommitdiff
path: root/misc/compat5x
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2006-01-08 10:41:48 +0000
committerDoug Barton <dougb@FreeBSD.org>2006-01-08 10:41:48 +0000
commitea6a5da318760c33fd7b2889193b84ecb90e61dc (patch)
tree3993227af96a946270addd68d2c19ecce29153aa /misc/compat5x
parente48c722005624a7f0397958a5387162acca31638 (diff)
downloadports-ea6a5da318760c33fd7b2889193b84ecb90e61dc.tar.gz
ports-ea6a5da318760c33fd7b2889193b84ecb90e61dc.zip
Make use of the ldconfig_local_dirs mechanism just committed to
7-CURRENT. flz has plans to develop the USE_LDCONFIG code in bsd.port.mk, but this will serve as a POC for now.
Notes
Notes: svn path=/head/; revision=153045
Diffstat (limited to 'misc/compat5x')
-rw-r--r--misc/compat5x/Makefile30
-rw-r--r--misc/compat5x/pkg-plist2
2 files changed, 26 insertions, 6 deletions
diff --git a/misc/compat5x/Makefile b/misc/compat5x/Makefile
index 87ae8f42cda4..d105d186957f 100644
--- a/misc/compat5x/Makefile
+++ b/misc/compat5x/Makefile
@@ -11,7 +11,7 @@
PORTNAME= compat5x
PORTVERSION= 5.4.0.8
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=lesi/compat5x
@@ -23,13 +23,11 @@ COMMENT= A convenience package to install the compat5x libraries
ONLY_FOR_ARCHS= alpha amd64 i386 sparc64
USE_BZIP2= yes
-NO_MTREE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib/compat
TARGET_DIR= ${PREFIX}/lib/compat
TARGET32_DIR= ${PREFIX}/lib32/compat
-USE_RC_SUBR= 000.${PORTNAME}.sh
.include <bsd.port.pre.mk>
@@ -37,12 +35,20 @@ USE_RC_SUBR= 000.${PORTNAME}.sh
IGNORE= is for FreeBSD 6.x and newer
.endif
+.if ${OSVERSION} > 700011
+USE_LDCONFIG= ${TARGET_DIR}
+PLIST_SUB+= USE_LDCONFIG=""
+.else
+NO_MTREE= yes
+USE_RC_SUBR= 000.${PORTNAME}.sh
+SUB_LIST+= LDCONFIG="${LDCONFIG}"
+PLIST_SUB+= USE_LDCONFIG="@comment "
+.endif
+
.if ${OSVERSION} >= 600016
RUN_DEPENDS= ${LOCALBASE}/share/compat/locale/UTF-8/LC_CTYPE:${PORTSDIR}/misc/localedata
.endif
-SUB_LIST+= LDCONFIG="${LDCONFIG}"
-
.if ${ARCH} == alpha
PLIST_SUB+= ALPHA=""
.else
@@ -51,11 +57,15 @@ PLIST_SUB+= ALPHA="@comment "
.if ${ARCH} == amd64
PLIST_SUB+= AMD64=""
PLIST_SUB+= LDCONFIG_LIB32="${LDCONFIG} -32"
+.if defined(USE_RC_SUBR)
SUB_LIST+= AMD64="" TARGET32_DIR="${TARGET32_DIR}"
+.endif
.else
PLIST_SUB+= AMD64="@comment "
+.if defined(USE_RC_SUBR)
SUB_LIST+= AMD64="@comment "
.endif
+.endif
.if ${ARCH} == i386
PLIST_SUB+= I386=""
.else
@@ -68,6 +78,7 @@ PLIST_SUB+= SPARC64="@comment "
.endif
post-extract:
+.if defined(USE_RC_SUBR)
@( ${ECHO} ""; \
${ECHO} "******************************************************"; \
${ECHO} "To enable the ldconfig of these libraries at boot time"; \
@@ -75,8 +86,8 @@ post-extract:
${ECHO} "/etc/rc.conf.local or /etc/rc.conf"; \
${ECHO} "******************************************************"; \
${ECHO} ""; ) > ${WRKDIR}/pkg-message
-
PKGMESSAGE= ${WRKDIR}/pkg-message
+.endif
NO_BUILD= yes
@@ -90,6 +101,13 @@ do-install:
.endif
post-install:
+.if defined(USE_LDCONFIG)
+ @${ECHO} ${USE_LDCONFIG} > ${PREFIX}/libdata/ldconfig/${UNIQUENAME}
+.if ${ARCH} == amd64
+ @${ECHO} ${TARGET32_DIR} > ${PREFIX}/libdata/ldconfig32/${UNIQUENAME}
+.endif
+.else
@${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.post.mk>
diff --git a/misc/compat5x/pkg-plist b/misc/compat5x/pkg-plist
index f33d3d3e7d8b..6fbca14168d8 100644
--- a/misc/compat5x/pkg-plist
+++ b/misc/compat5x/pkg-plist
@@ -107,6 +107,8 @@ lib/compat/pam_unix.so.2
lib/compat/snmp_atm.so.2
lib/compat/snmp_mibII.so.2
lib/compat/snmp_netgraph.so.2
+%%USE_LDCONFIG%%libdata/ldconfig/compat5x
+%%USE_LDCONFIG%%%%AMD64%%libdata/ldconfig32/compat5x
%%AMD64%%lib32/compat/libalias.so.4
%%AMD64%%lib32/compat/libarchive.so.1
%%AMD64%%lib32/compat/libatm.so.2