aboutsummaryrefslogtreecommitdiff
path: root/misc/cpuid
diff options
context:
space:
mode:
authorYaroslav Tykhiy <ytykhiy@gmail.com>2006-02-07 16:47:57 +0000
committerYaroslav Tykhiy <ytykhiy@gmail.com>2006-02-07 16:47:57 +0000
commitf353783dfa5a8aedc58d2316a0bad9c8e4823c0e (patch)
tree89e5246356c99481332d205521526c61b884009b /misc/cpuid
parentf99dba79e02c18654c1abc8cd54bdb642775c944 (diff)
downloadports-f353783dfa5a8aedc58d2316a0bad9c8e4823c0e.tar.gz
ports-f353783dfa5a8aedc58d2316a0bad9c8e4823c0e.zip
This software has quite broken original Makefile, at least for us.
Instead of trying to patch it, just supply a BSD-specific Makefile using <bsd.prog.mk>. This removes the build-time dependency of this tiny port on USE_REINPLACE and the heavy-weight gmake at once.
Notes
Notes: svn path=/head/; revision=155426
Diffstat (limited to 'misc/cpuid')
-rw-r--r--misc/cpuid/Makefile9
-rw-r--r--misc/cpuid/files/Makefile.bsd4
2 files changed, 6 insertions, 7 deletions
diff --git a/misc/cpuid/Makefile b/misc/cpuid/Makefile
index abb2c1761d02..01c3005ed100 100644
--- a/misc/cpuid/Makefile
+++ b/misc/cpuid/Makefile
@@ -16,15 +16,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= CPU identification utility
PLIST_FILES= bin/cpuid
-USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386 amd64
-USE_GMAKE= yes
-ALL_TARGET= # empty
post-patch:
- @${REINPLACE_CMD} -e "s,gcc,${CC},g ; s,^CFLAGS,#CFLAGS,g" ${WRKSRC}/Makefile
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cpuid ${PREFIX}/bin
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.bak && \
+ ${CP} ${FILESDIR}/Makefile.bsd ${WRKSRC}/Makefile
.include <bsd.port.mk>
diff --git a/misc/cpuid/files/Makefile.bsd b/misc/cpuid/files/Makefile.bsd
new file mode 100644
index 000000000000..71bc5d85d80c
--- /dev/null
+++ b/misc/cpuid/files/Makefile.bsd
@@ -0,0 +1,4 @@
+PROG=cpuid
+NOMAN=
+BINDIR=${PREFIX}/bin
+.include <bsd.prog.mk>"