aboutsummaryrefslogtreecommitdiff
path: root/misc/cs
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-07-01 14:11:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-07-01 14:11:59 +0000
commit0e67993886af11726c61116c954924ac8d0d8dc8 (patch)
treed6e09c868405dc6caf0b7bcc735c67205c592ec8 /misc/cs
parent6164cca4a2f6cf8baa4bf1167c832e5f4e80bc0d (diff)
downloadports-0e67993886af11726c61116c954924ac8d0d8dc8.tar.gz
ports-0e67993886af11726c61116c954924ac8d0d8dc8.zip
New port: cross stitching patterns generator
PR: ports/82807 Submitted by: Ying-Chieh Liao <ijliao@csie.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=138297
Diffstat (limited to 'misc/cs')
-rw-r--r--misc/cs/Makefile32
-rw-r--r--misc/cs/distinfo2
-rw-r--r--misc/cs/pkg-descr3
3 files changed, 37 insertions, 0 deletions
diff --git a/misc/cs/Makefile b/misc/cs/Makefile
new file mode 100644
index 000000000000..f7eaa74bb7f6
--- /dev/null
+++ b/misc/cs/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: cs
+# Date created: Jun 30, 2005
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= cs
+PORTVERSION= 0.9.5
+CATEGORIES= misc
+MASTER_SITES= http://njhurst.org/programming/cross-stitch/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Cross Stitch software
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/PIL/Image.py:${PORTSDIR}/graphics/py-imaging
+
+USE_REINPLACE= yes
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/xs
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/usr/bin/python,${SETENV} python," ${WRKSRC}/xs.py
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/xs.py ${PREFIX}/bin/xs
+
+.include <bsd.port.mk>
diff --git a/misc/cs/distinfo b/misc/cs/distinfo
new file mode 100644
index 000000000000..be5504fbc52b
--- /dev/null
+++ b/misc/cs/distinfo
@@ -0,0 +1,2 @@
+MD5 (cs-0.9.5.tgz) = f21ab196fd1ba9b997a0b3ed42178793
+SIZE (cs-0.9.5.tgz) = 73206
diff --git a/misc/cs/pkg-descr b/misc/cs/pkg-descr
new file mode 100644
index 000000000000..788bcd6557d6
--- /dev/null
+++ b/misc/cs/pkg-descr
@@ -0,0 +1,3 @@
+Cross Stitch software.
+
+WWW: http://njhurst.org/programming/cross-stitch/