aboutsummaryrefslogtreecommitdiff
path: root/misc/dahdi-kmod
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-01-26 18:35:10 +0000
committerRene Ladan <rene@FreeBSD.org>2014-01-26 18:35:10 +0000
commit484191d812485cdd71119ba1cfebf1990a4c2ca5 (patch)
tree02b688b415e01f84d41833e112be31fb5e47236a /misc/dahdi-kmod
parent0a2a1d6311055fbca1ddaa077151b246f0fe5138 (diff)
downloadports-484191d812485cdd71119ba1cfebf1990a4c2ca5.tar.gz
ports-484191d812485cdd71119ba1cfebf1990a4c2ca5.zip
- Stage support
- Remove obsolete NO_PACKAGE - Remove IGNORE check for obsolete versions of FreeBSD - Fix typo introduced in converting this port to USES=kmod Approved by: portmgr (infrastructure blanket)
Notes
Notes: svn path=/head/; revision=341256
Diffstat (limited to 'misc/dahdi-kmod')
-rw-r--r--misc/dahdi-kmod/Makefile9
-rw-r--r--misc/dahdi-kmod/files/patch-freebsd__freebsd__Makefile.inc8
2 files changed, 9 insertions, 8 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index ed928376da77..fbd854ef1109 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -36,7 +36,6 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/freebsd
EXTRA_PATCHES= ${WRKDIR}/zaphfc-${ZAPHFC_VERSION}
PATCH_STRIP= -p1
MAKEFILE= BSDmakefile
-NO_PACKAGE= Should be in sync with the kernel to work correctly
USE_RC_SUBR= dahdi
MAKE_ARGS= ADDITIONAL_DRIVERS="wcb1xxp" NO_FETCH=yes
GROUPS= dahdi
@@ -44,18 +43,12 @@ GROUPS= dahdi
ONLY_FOR_ARCHS= i386 amd64 sparc64
CONFLICTS= zaptel-[0-9]* dahdi-kmod26-*
-NO_STAGE= yes
-
USES= kmod
-KMODDDIR= ${PREFIX}/lib/dahdi
+KMODDIR= ${PREFIX}/lib/dahdi
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 703000 || (${OSVERSION} >= 800000 && ${OSVERSION} < 800108)
-IGNORE= requires firmware(9) support for kernel modules with hyphens
-.endif
-
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
PLIST_SUB+= X86=""
_vpmadt032= VPMADT032
diff --git a/misc/dahdi-kmod/files/patch-freebsd__freebsd__Makefile.inc b/misc/dahdi-kmod/files/patch-freebsd__freebsd__Makefile.inc
new file mode 100644
index 000000000000..824581e6322e
--- /dev/null
+++ b/misc/dahdi-kmod/files/patch-freebsd__freebsd__Makefile.inc
@@ -0,0 +1,8 @@
+--- freebsd/freebsd/Makefile.inc.orig 2010-09-01 08:54:06.000000000 +0200
++++ freebsd/freebsd/Makefile.inc 2014-01-26 19:12:09.000000000 +0100
+@@ -19,4 +19,4 @@
+ TOUCH?= touch
+
+ beforeinstall:
+- ${MKDIR} ${KMODDIR}
++ ${MKDIR} ${DESTDIR}${KMODDIR}