aboutsummaryrefslogtreecommitdiff
path: root/misc/dahdi-kmod
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
committerRene Ladan <rene@FreeBSD.org>2013-11-09 19:13:27 +0000
commitbfc52e710421bd92466b329f6fbb9be930eb4755 (patch)
tree7436338612f22a81def9ee6c2d2e3826c1504ea4 /misc/dahdi-kmod
parent16a624cb31062d141fd07c5dc3f7794ed7fe74cd (diff)
downloadports-bfc52e710421bd92466b329f6fbb9be930eb4755.tar.gz
ports-bfc52e710421bd92466b329f6fbb9be930eb4755.zip
Convert to USES=kmod, which removes duplicated code and ensures that all
required steps are followed. There are no user-visible changes. The exception is multimedia/ptx-kmod, which now installs the kernel module into /boot/modules instead of ${PREFIX}/libexec/${PORTNAME}, this was something USES=kmod cannot handle. PR: ports/183625 Submitted by: myself Approved by: portmgr (bdrewery) Exp-run by: bdrewery
Notes
Notes: svn path=/head/; revision=333329
Diffstat (limited to 'misc/dahdi-kmod')
-rw-r--r--misc/dahdi-kmod/Makefile19
-rw-r--r--misc/dahdi-kmod/pkg-plist2
2 files changed, 6 insertions, 15 deletions
diff --git a/misc/dahdi-kmod/Makefile b/misc/dahdi-kmod/Makefile
index d9d39f5785b5..ed928376da77 100644
--- a/misc/dahdi-kmod/Makefile
+++ b/misc/dahdi-kmod/Makefile
@@ -4,7 +4,7 @@
PORTNAME= dahdi-kmod
PORTVERSION= ${DAHDI_VERSION:S/-//g}
PORTREVISION= 6
-CATEGORIES= misc kld
+CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_LOCAL}\
http://downloads.digium.com/pub/telephony/firmware/releases/:firmware
MASTER_SITE_SUBDIR= fjoe
@@ -18,8 +18,6 @@ COMMENT= Digium/Asterisk Hardware Device Interface
RUN_DEPENDS= ${LOCALBASE}/sbin/dahdi_cfg:${PORTSDIR}/misc/dahdi
-SSP_UNSAFE= kernel module does not support ssp
-
DAHDI_VERSION= 2.4.0-rc5
DAHDI_TOOLS_VERSION= 2.4.0-rc1
OSLEC_VERSION= 2.6.35.4
@@ -47,16 +45,17 @@ ONLY_FOR_ARCHS= i386 amd64 sparc64
CONFLICTS= zaptel-[0-9]* dahdi-kmod26-*
NO_STAGE= yes
+
+USES= kmod
+
+KMODDDIR= ${PREFIX}/lib/dahdi
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 703000 || (${OSVERSION} >= 800000 && ${OSVERSION} < 800108)
IGNORE= requires firmware(9) support for kernel modules with hyphens
.endif
-.if !exists(${SRC_BASE}/sys/Makefile)
-IGNORE= requires kernel source present in ${SRC_BASE}/sys
-.endif
-
.if ${ARCH} == "i386" || ${ARCH} == "amd64"
PLIST_SUB+= X86=""
_vpmadt032= VPMADT032
@@ -77,12 +76,6 @@ post-extract:
${CP} ${DISTDIR}/${${_f}_DISTFILE} ${WRKSRC}/freebsd/${${_f}_DIR}
.endfor
-pre-su-install:
- @${MKDIR} ${PREFIX}/lib/dahdi
-
-post-install:
- @${TOUCH} ${PREFIX}/lib/dahdi/linker.hints
-
fw-versions: extract
.for _v in ${FIRMWARES:=_VERSION}
@${ECHO_CMD} "${_v}=`${MAKE} -V ${_v} -f ${WRKSRC}/firmware.mk`"
diff --git a/misc/dahdi-kmod/pkg-plist b/misc/dahdi-kmod/pkg-plist
index 9c95ae1806c2..4dc776341d4f 100644
--- a/misc/dahdi-kmod/pkg-plist
+++ b/misc/dahdi-kmod/pkg-plist
@@ -16,7 +16,6 @@ lib/dahdi/dahdi_echocan_sec2.ko
lib/dahdi/dahdi_transcode.ko
lib/dahdi/dahdi_voicebus.ko
%%X86%%lib/dahdi/dahdi_vpmadt032_loader.ko
-lib/dahdi/linker.hints
lib/dahdi/ng_dahdi_netdev.ko
lib/dahdi/wcb1xxp.ko
lib/dahdi/wcb4xxp.ko
@@ -27,4 +26,3 @@ lib/dahdi/wctdm.ko
lib/dahdi/wctdm24xxp.ko
lib/dahdi/wcte11xp.ko
lib/dahdi/wcte12xp.ko
-@dirrm lib/dahdi