aboutsummaryrefslogtreecommitdiff
path: root/misc/dahdi
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2010-10-05 16:44:43 +0000
committerMax Khon <fjoe@FreeBSD.org>2010-10-05 16:44:43 +0000
commit7f32b10cef3e3d568861d8a123c0a84bb02bf1cf (patch)
tree38e6d06718d1b55790d5a8c6050004d41cc68eb0 /misc/dahdi
parent11688d6f33c7aea9079d9c01c09bf425c7138bdc (diff)
downloadports-7f32b10cef3e3d568861d8a123c0a84bb02bf1cf.tar.gz
ports-7f32b10cef3e3d568861d8a123c0a84bb02bf1cf.zip
Add patch to define __BIG_ENDIAN and __LITTLE_ENDIAN properly.
May fix wctdm on sparc64.
Notes
Notes: svn path=/head/; revision=262448
Diffstat (limited to 'misc/dahdi')
-rw-r--r--misc/dahdi/Makefile2
-rw-r--r--misc/dahdi/files/patch-freebsd-include-dahdi-compat-bsd.h14
2 files changed, 15 insertions, 1 deletions
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index 369cc5e09031..9bf67ad19be4 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}\
http://downloads.digium.com/pub/telephony/firmware/releases/:firmware
diff --git a/misc/dahdi/files/patch-freebsd-include-dahdi-compat-bsd.h b/misc/dahdi/files/patch-freebsd-include-dahdi-compat-bsd.h
new file mode 100644
index 000000000000..0f95e4444217
--- /dev/null
+++ b/misc/dahdi/files/patch-freebsd-include-dahdi-compat-bsd.h
@@ -0,0 +1,14 @@
+--- freebsd/include/dahdi/compat/bsd.h.orig 2010-10-05 23:41:23.000000000 +0700
++++ freebsd/include/dahdi/compat/bsd.h 2010-10-05 23:42:01.000000000 +0700
+@@ -66,9 +66,11 @@
+ #define __be32 u_int32_t
+
+ #if _BYTE_ORDER == _LITTLE_ENDIAN
++#define __LITTLE_ENDIAN
+ #define __LITTLE_ENDIAN_BITFIELD
+ #define __constant_htons(x) ((uint16_t) (((uint16_t) (x)) << 8 | ((uint16_t) (x)) >> 8))
+ #elif _BYTE_ORDER == _BIG_ENDIAN
++#define __BIG_ENDIAN
+ #define __BIG_ENDIAN_BITFIELD
+ #define __constant_htons(x) (x)
+ #endif