aboutsummaryrefslogtreecommitdiff
path: root/misc/dahdi
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2010-03-06 05:11:59 +0000
committerMax Khon <fjoe@FreeBSD.org>2010-03-06 05:11:59 +0000
commitbeef1ab75f02e9975661e0e7bc7d66968a48dd89 (patch)
treeb1e0b798e59b39fc3404f32925a7bd56aeec1167 /misc/dahdi
parentb12e3e1c723b8027e5055b54f0127cd476e687df (diff)
downloadports-beef1ab75f02e9975661e0e7bc7d66968a48dd89.tar.gz
ports-beef1ab75f02e9975661e0e7bc7d66968a48dd89.zip
Add ${LOCALBASE}/lib/dahdi to the KLD search path, so that autoloading
of echo cancellation modules or Octasic firmware modules works as expected. Feature safe: yes
Notes
Notes: svn path=/head/; revision=250615
Diffstat (limited to 'misc/dahdi')
-rw-r--r--misc/dahdi/Makefile2
-rw-r--r--misc/dahdi/files/dahdi.in3
2 files changed, 3 insertions, 2 deletions
diff --git a/misc/dahdi/Makefile b/misc/dahdi/Makefile
index bde17b751bb6..1179a73b8765 100644
--- a/misc/dahdi/Makefile
+++ b/misc/dahdi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dahdi
PORTVERSION= ${DAHDI_VERSION:S/-//g}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= misc kld
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= fjoe
diff --git a/misc/dahdi/files/dahdi.in b/misc/dahdi/files/dahdi.in
index 15f6d43e741c..7bbcece0f891 100644
--- a/misc/dahdi/files/dahdi.in
+++ b/misc/dahdi/files/dahdi.in
@@ -39,8 +39,9 @@ dahdi_start()
{
echo -n " ${name}"
+ kldconfig -mf ${kmod_dir}
for m in ${dahdi_modules}; do
- kldload ${kmod_dir}/$m.ko || exit 1
+ kldload $m || exit 1
done
%%PREFIX%%/sbin/dahdi_cfg
}