aboutsummaryrefslogtreecommitdiff
path: root/misc/deco
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-08-16 13:51:31 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-08-16 13:51:31 +0000
commit306fed238a2b56a269e601892afbd05a309c21dd (patch)
tree10aa812fc9d09691e7da31d2b2e9e707fed22110 /misc/deco
parenta91db81e2c0b295ace54710f5f2fa1015ed84230 (diff)
downloadports-306fed238a2b56a269e601892afbd05a309c21dd.tar.gz
ports-306fed238a2b56a269e601892afbd05a309c21dd.zip
Do not coredump when viewing files larger that 8Mb.
Bump PORTREVISION Minor cosmetic fixes in the Makefile. Submitted by: Pavel Biryukov <pavel@svegapro.ru>
Notes
Notes: svn path=/head/; revision=46330
Diffstat (limited to 'misc/deco')
-rw-r--r--misc/deco/Makefile23
-rw-r--r--misc/deco/files/patch-af11
2 files changed, 23 insertions, 11 deletions
diff --git a/misc/deco/Makefile b/misc/deco/Makefile
index 6ef7a20193e8..129ffba78919 100644
--- a/misc/deco/Makefile
+++ b/misc/deco/Makefile
@@ -5,19 +5,20 @@
# $FreeBSD$
#
-PORTNAME= deco
-PORTVERSION= 3.8.3
-CATEGORIES= misc
-MASTER_SITES= ftp://ftp.cronyx.ru/cronyx/deco/
-DISTNAME= deco383
-EXTRACT_SUFX= .tgz
+PORTNAME= deco
+PORTVERSION= 3.8.3
+PORTREVISION= 1
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.cronyx.ru/cronyx/deco/
+DISTNAME= deco383
+EXTRACT_SUFX= .tgz
MAINTAINER= demon@FreeBSD.org
-WRKSRC= ${WRKDIR}/deco383
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --libdir=${PREFIX}/share
-CONFIGURE_ENV= ac_cv_lib_ncurses_tgetent=no
-MAN1= deco.1 deco-r.1
+WRKSRC= ${WRKDIR}/deco383
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --libdir=${PREFIX}/share
+CONFIGURE_ENV= ac_cv_lib_ncurses_tgetent=no
+MAN1= deco.1 deco-r.1
.include <bsd.port.mk>
diff --git a/misc/deco/files/patch-af b/misc/deco/files/patch-af
new file mode 100644
index 000000000000..dc1b20e0308c
--- /dev/null
+++ b/misc/deco/files/patch-af
@@ -0,0 +1,11 @@
+--- rec.c.orig Thu Aug 16 17:29:07 2001
++++ rec.c Thu Aug 16 17:29:35 2001
+@@ -61,7 +61,7 @@
+ static char *scanbuf, *pbuf;
+ static char *tfilename;
+ static int eoln;
+-static int MAXLEN = ((unsigned int) (int) -1 >> 1) / sizeof (struct index);
++static int MAXLEN = 32767;
+
+ static int ffcopy (int from, int to)
+ {