aboutsummaryrefslogtreecommitdiff
path: root/misc/deco
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-09 13:17:59 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-12-09 13:17:59 +0000
commiteaa4dd82d47cef770a83367b70848d8cc7ef9e20 (patch)
tree254992a511301ca2fdc5d90e88b76fc026d69f6d /misc/deco
parentc14d26a17ec47397fdd961c44418703915fa9559 (diff)
downloadports-eaa4dd82d47cef770a83367b70848d8cc7ef9e20.tar.gz
ports-eaa4dd82d47cef770a83367b70848d8cc7ef9e20.zip
- Add stage support
Notes
Notes: svn path=/head/; revision=335980
Diffstat (limited to 'misc/deco')
-rw-r--r--misc/deco/Makefile3
-rw-r--r--misc/deco/files/patch-Makefile.in37
-rw-r--r--misc/deco/pkg-plist2
3 files changed, 32 insertions, 10 deletions
diff --git a/misc/deco/Makefile b/misc/deco/Makefile
index 478a0c869585..f34269643790 100644
--- a/misc/deco/Makefile
+++ b/misc/deco/Makefile
@@ -16,8 +16,5 @@ COMMENT= Demos Commander, a free Norton Commander clone
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/share
CONFIGURE_ENV= ac_cv_lib_ncurses_tgetent=no
-MAN1= deco.1
-MANLANG= "" ru.KOI8-R
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/misc/deco/files/patch-Makefile.in b/misc/deco/files/patch-Makefile.in
index 126969e87575..f59a130fd60b 100644
--- a/misc/deco/files/patch-Makefile.in
+++ b/misc/deco/files/patch-Makefile.in
@@ -1,11 +1,34 @@
---- Makefile.in Tue Jan 4 09:38:18 2000
-+++ Makefile.in Sun Mar 23 23:05:33 2003
-@@ -44,7 +44,7 @@
+--- ./Makefile.in.orig 2000-01-04 05:38:18.000000000 -0200
++++ ./Makefile.in 2013-12-09 11:13:40.000000000 -0200
+@@ -40,23 +40,23 @@
+
+ install: deco $(libdir)/deco $(libdir)/deco/help\
+ $(libdir)/deco/menu $(libdir)/deco/profile
+- $(INSTALL_PROGRAM) deco $(bindir)
++ $(INSTALL_PROGRAM) deco ${DESTDIR}$(bindir)
cd help; for f in *.general *.edit *.view *.hexview; do\
- $(INSTALL_DATA) $$f $(libdir)/deco/help/$$f; done
- $(INSTALL_DATA) ref.man $(mandir)/man1/deco.1
+- $(INSTALL_DATA) $$f $(libdir)/deco/help/$$f; done
+- $(INSTALL_DATA) ref.man $(mandir)/man1/deco.1
- $(INSTALL_DATA) cyrref.man $(mandir)/man1/deco-r.1
-+ $(INSTALL_DATA) cyrref.man $(mandir)/ru.KOI8-R/man1/deco.1
++ $(INSTALL_DATA) $$f ${DESTDIR}$(libdir)/deco/help/$$f; done
++ $(INSTALL_DATA) ref.man ${DESTDIR}$(mandir)/man1/deco.1
++ $(INSTALL_DATA) cyrref.man ${DESTDIR}$(mandir)/ru.KOI8-R/man1/deco.1
$(libdir)/deco:
- mkdir $(libdir)/deco
+- mkdir $(libdir)/deco
++ mkdir ${DESTDIR}$(libdir)/deco
+
+ $(libdir)/deco/help:
+- mkdir $(libdir)/deco/help
++ mkdir ${DESTDIR}$(libdir)/deco/help
+
+ $(libdir)/deco/menu:
+- $(INSTALL_DATA) menu $(libdir)/deco/menu
++ $(INSTALL_DATA) menu ${DESTDIR}$(libdir)/deco/menu
+
+ $(libdir)/deco/profile:
+- $(INSTALL_DATA) profile $(libdir)/deco/profile
++ $(INSTALL_DATA) profile ${DESTDIR}$(libdir)/deco/profile
+
+ uninstall:
+
diff --git a/misc/deco/pkg-plist b/misc/deco/pkg-plist
index d8c6d6393d29..e5a0ca3d2152 100644
--- a/misc/deco/pkg-plist
+++ b/misc/deco/pkg-plist
@@ -1,4 +1,6 @@
bin/deco
+man/man1/deco.1.gz
+man/ru.KOI8-R/man1/deco.1.gz
%%DATADIR%%/help/d.edit
%%DATADIR%%/help/d.general
%%DATADIR%%/help/d.hexview