aboutsummaryrefslogtreecommitdiff
path: root/misc/delay
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>1999-12-31 06:49:03 +0000
committerBill Fumerola <billf@FreeBSD.org>1999-12-31 06:49:03 +0000
commit6068f95dc6b547b2d946173ed16797c1b0bfe759 (patch)
treebf1fb4afeb43e1cfc838fc46629e8f60546d2ffe /misc/delay
parent3bdc5895fb784022dd8b023759953ef14a0fa604 (diff)
downloadports-6068f95dc6b547b2d946173ed16797c1b0bfe759.tar.gz
ports-6068f95dc6b547b2d946173ed16797c1b0bfe759.zip
Upgrade to 1.4
patch-aa: fix an incorrect usage of exit(), while I'm here use correct headers.
Notes
Notes: svn path=/head/; revision=24306
Diffstat (limited to 'misc/delay')
-rw-r--r--misc/delay/distinfo2
-rw-r--r--misc/delay/files/patch-aa19
2 files changed, 20 insertions, 1 deletions
diff --git a/misc/delay/distinfo b/misc/delay/distinfo
index b6453a4450ea..32ec3203d88c 100644
--- a/misc/delay/distinfo
+++ b/misc/delay/distinfo
@@ -1 +1 @@
-MD5 (delay-1.3.tar.gz) = 401962a1e76e4fc4672c687e71a6e0fa
+MD5 (delay-1.4.tar.gz) = c7ca665bca31eb80a72b5ff24ebc3d27
diff --git a/misc/delay/files/patch-aa b/misc/delay/files/patch-aa
new file mode 100644
index 000000000000..cd41bf84d0e9
--- /dev/null
+++ b/misc/delay/files/patch-aa
@@ -0,0 +1,19 @@
+--- delay.c.old Fri Dec 31 00:04:28 1999
++++ delay.c Fri Dec 31 00:05:02 1999
+@@ -17,6 +17,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <time.h>
+ #include <sys/time.h>
+ #include <unistd.h>
+@@ -351,7 +352,7 @@
+ if (cmd) {
+ execvp(cmd[0], cmd);
+ perror(argv[0]); /* If it worked, we won't get here. */
+- exit -1;
++ exit(-1);
+ }
+
+ exit(0);