aboutsummaryrefslogtreecommitdiff
path: root/misc/delay
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>1999-03-05 17:07:28 +0000
committerJacques Vidrine <nectar@FreeBSD.org>1999-03-05 17:07:28 +0000
commitc65f460fdc5a4fa442a1889f3832f61cc73e641c (patch)
treee9f58ec50f4e82d2672ec536393ce11ecaba8ef8 /misc/delay
parent208d7634e62462b26711ad3681ed7fa696449cbe (diff)
downloadports-c65f460fdc5a4fa442a1889f3832f61cc73e641c.tar.gz
ports-c65f460fdc5a4fa442a1889f3832f61cc73e641c.zip
Delay is a program that counts down the number of seconds specified
on its command line. PR: ports/10382 Submitted by: Gianmarco Giovannelli <gmarco@giovannelli.it>
Notes
Notes: svn path=/head/; revision=17008
Diffstat (limited to 'misc/delay')
-rw-r--r--misc/delay/Makefile24
-rw-r--r--misc/delay/distinfo1
-rw-r--r--misc/delay/pkg-comment1
-rw-r--r--misc/delay/pkg-descr24
-rw-r--r--misc/delay/pkg-plist1
5 files changed, 51 insertions, 0 deletions
diff --git a/misc/delay/Makefile b/misc/delay/Makefile
new file mode 100644
index 000000000000..e5316cb9beed
--- /dev/null
+++ b/misc/delay/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: misc/delay
+# Version required: delay-1.2a
+# Date created: 03 Mar 1999
+# Whom: gmarco@scotty.masternet.it
+#
+# $Id$
+#
+
+DISTNAME= delay-1.2a
+CATEGORIES= misc
+MASTER_SITES= http://onegeek.org/~tom/software/delay/dl/
+
+MAINTAINER= freebsd@scotty.masternet.it
+
+HAS_CONFIGURE= yes
+
+MAN1= delay.1
+
+do-install:
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/delay ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/delay.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/misc/delay/distinfo b/misc/delay/distinfo
new file mode 100644
index 000000000000..4bfee7b60faa
--- /dev/null
+++ b/misc/delay/distinfo
@@ -0,0 +1 @@
+MD5 (delay-1.2a.tar.gz) = 77295ee1b23910d6fbf0f549713bc51b
diff --git a/misc/delay/pkg-comment b/misc/delay/pkg-comment
new file mode 100644
index 000000000000..5c5128a9dac9
--- /dev/null
+++ b/misc/delay/pkg-comment
@@ -0,0 +1 @@
+a delay program with feedback to the user
diff --git a/misc/delay/pkg-descr b/misc/delay/pkg-descr
new file mode 100644
index 000000000000..d715bc761393
--- /dev/null
+++ b/misc/delay/pkg-descr
@@ -0,0 +1,24 @@
+Delay is a program that counts down the number of seconds specified
+on its command line.
+In this way, it's sort of like the standard sleep(1) command, except
+for the fact that it provides feedback of the time remaining.
+
+With version 1.2 you can also 'delay' until a given time specification.
+Here some usage example:
+
+delay 1d 2:03:04.5
+delay 1d 2h 3m 4.5s
+delay 93785.5
+delay until 4 pm
+delay until noon tomorrow
+delay until midnight 13 september 2000
+delay until now + 5 minutes
+
+It allows for short, long, and customized messages for the display of
+the time remaining.
+
+- author: Tom Rothamel <tom@onegeek.org>
+- distfile: delay-1.2.tar.gz (63 kb)
+- example of output : delay -v until 4 pm tomorrow
+ Time Remaining: 1 days, 07:51:39.
+- ported to FreeBSD by Gianmarco (gmarco@giovannelli.it)
diff --git a/misc/delay/pkg-plist b/misc/delay/pkg-plist
new file mode 100644
index 000000000000..ed4e5cd75faa
--- /dev/null
+++ b/misc/delay/pkg-plist
@@ -0,0 +1 @@
+bin/delay