aboutsummaryrefslogtreecommitdiff
path: root/misc/dnetc
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-30 07:39:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-30 07:39:54 +0000
commitafc9553a7879f7b40447c1bf8b47a3530dc0972f (patch)
tree5bec88d3d5046d57e39f2973c266933d426ce6fc /misc/dnetc
parenteccc9823a94fd8ac72cedff8f16db9bf856dae69 (diff)
downloadports-afc9553a7879f7b40447c1bf8b47a3530dc0972f.tar.gz
ports-afc9553a7879f7b40447c1bf8b47a3530dc0972f.zip
- Use fixed UID/GID
Notes
Notes: svn path=/head/; revision=110384
Diffstat (limited to 'misc/dnetc')
-rw-r--r--misc/dnetc/Makefile2
-rw-r--r--misc/dnetc/pkg-install6
2 files changed, 4 insertions, 4 deletions
diff --git a/misc/dnetc/Makefile b/misc/dnetc/Makefile
index f2fcb6302bb1..fb428d85c100 100644
--- a/misc/dnetc/Makefile
+++ b/misc/dnetc/Makefile
@@ -18,8 +18,6 @@ DISTFILES= dnetc${PORTVERSION:E}-freebsd-x86-elf.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Distributed.net distributed computing project client
-IGNORE= uses an unregistered uid/gid.
-
WRKSRC= ${WRKDIR}/dnetc${PORTVERSION:E}-freebsd-x86-elf
ONLY_FOR_ARCHS= i386
diff --git a/misc/dnetc/pkg-install b/misc/dnetc/pkg-install
index 4affdc2a568a..4c3f2c347d1f 100644
--- a/misc/dnetc/pkg-install
+++ b/misc/dnetc/pkg-install
@@ -6,9 +6,11 @@ fi
CLIENTUSER=$3
CLIENTGROUP=$4
+UID=105
+GID=$UID
if ! pw groupshow "$CLIENTGROUP" 2>/dev/null 1>&2; then
- if pw groupadd $CLIENTGROUP; then
+ if pw groupadd $CLIENTGROUP -g $GID; then
echo "=> Added group \"$CLIENTGROUP\"."
else
echo "=> Adding group \"$CLIENTGROUP\" failed..."
@@ -17,7 +19,7 @@ if ! pw groupshow "$CLIENTGROUP" 2>/dev/null 1>&2; then
fi
if ! pw usershow "$CLIENTUSER" 2>/dev/null 1>&2; then
- if pw useradd $CLIENTUSER -g $CLIENTGROUP -h - \
+ if pw useradd $CLIENTUSER -u $UID -g $CLIENTGROUP -h - \
-s "/sbin/nologin" -d "/nonexistent" \
-c "distributed.net client and proxy pseudo-user"; \
then