aboutsummaryrefslogtreecommitdiff
path: root/misc/dtach
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-27 11:53:00 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-12-27 11:53:00 +0000
commit5688b94b4034aac493ac2081d4fa64d8e823f17d (patch)
tree54ba51c2f7b5f4380824e353733ed80e3bc52ded /misc/dtach
parent43350f39d0faf38c15132806842f832d09173ead (diff)
downloadports-5688b94b4034aac493ac2081d4fa64d8e823f17d.tar.gz
ports-5688b94b4034aac493ac2081d4fa64d8e823f17d.zip
- Switch to options helpers
- Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=404561
Diffstat (limited to 'misc/dtach')
-rw-r--r--misc/dtach/Makefile4
-rw-r--r--misc/dtach/files/patch-master.c14
2 files changed, 10 insertions, 8 deletions
diff --git a/misc/dtach/Makefile b/misc/dtach/Makefile
index ec379714edcd..679f28a6793c 100644
--- a/misc/dtach/Makefile
+++ b/misc/dtach/Makefile
@@ -24,7 +24,9 @@ OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/dtach ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/dtach.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/misc/dtach/files/patch-master.c b/misc/dtach/files/patch-master.c
index 046c1b4134c2..a1674c607d92 100644
--- a/misc/dtach/files/patch-master.c
+++ b/misc/dtach/files/patch-master.c
@@ -1,6 +1,6 @@
---- master.c.orig 2008-01-30 21:59:54.000000000 -0800
-+++ master.c 2010-01-12 10:30:56.000000000 -0800
-@@ -53,6 +53,8 @@
+--- master.c.orig 2008-01-31 05:59:54 UTC
++++ master.c
+@@ -53,6 +53,8 @@ struct client
static struct client *clients;
/* The pseudo-terminal created for the child process. */
static struct pty the_pty;
@@ -9,7 +9,7 @@
#ifndef HAVE_FORKPTY
pid_t forkpty(int *amaster, char *name, struct termios *termp,
-@@ -66,6 +68,19 @@
+@@ -66,6 +68,19 @@ unlink_socket(void)
unlink(sockname);
}
@@ -29,7 +29,7 @@
/* Signal */
static RETSIGTYPE
die(int sig)
-@@ -206,7 +221,8 @@
+@@ -206,7 +221,8 @@ create_socket(char *name)
return -1;
}
/* chmod it to prevent any suprises */
@@ -39,7 +39,7 @@
{
close(s);
return -1;
-@@ -454,6 +470,8 @@
+@@ -454,6 +470,8 @@ master_process(int s, char **argv, int w
/* Loop forever. */
while (1)
{
@@ -48,7 +48,7 @@
/* Re-initialize the file descriptor set for select. */
FD_ZERO(&readfds);
FD_SET(s, &readfds);
-@@ -480,8 +498,14 @@
+@@ -480,8 +498,14 @@ master_process(int s, char **argv, int w
FD_SET(p->fd, &readfds);
if (p->fd > highest_fd)
highest_fd = p->fd;