aboutsummaryrefslogtreecommitdiff
path: root/misc/elscreen
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2018-02-01 18:03:09 +0000
commita3cc513bfc69ef10d52ed310dd9a6e6bb8c57491 (patch)
tree4a6b8513515fb032f2183d945863a1d39dbcd0c1 /misc/elscreen
parent7a6d87cd185d39c7023ee32da472cca4f391e7f2 (diff)
downloadports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.tar.gz
ports-a3cc513bfc69ef10d52ed310dd9a6e6bb8c57491.zip
Flavorize and modernize Emacs ports
- Convert USE_EMACS to USES=emacs - Remove editors/emacs-nox11 (refer to nox flavors of editors/emacs and editors/emacs-devel) - Permit default Emacs flavor to be specified in make.conf - Rename japanese/migemo-emacs23 to japanese/migemo-emacs - Update and simplify audio/emms and fix build on FreeBSD 10 [1] - Update databases/bbdd and fix build on FreeBSD 10 [1] - Update editors/emacs-devel - Ensure Makefile shell commands that change directory are executed in a subshell - Silence some portlint warnings [1] By not depending on base texinfo PR: 225404 Reviewed by: antoine Approved by: portmgr (mat) ashish (maintainer) Differential Revision: https://reviews.freebsd.org/D13506
Notes
Notes: svn path=/head/; revision=460621
Diffstat (limited to 'misc/elscreen')
-rw-r--r--misc/elscreen/Makefile21
-rw-r--r--misc/elscreen/pkg-plist3
2 files changed, 14 insertions, 10 deletions
diff --git a/misc/elscreen/Makefile b/misc/elscreen/Makefile
index 8a91aba294a2..100fad9eca54 100644
--- a/misc/elscreen/Makefile
+++ b/misc/elscreen/Makefile
@@ -3,27 +3,34 @@
PORTNAME= elscreen
PORTVERSION= 1.4.6
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= misc elisp
MASTER_SITES= ftp://ftp.morishima.net/pub/morishima.net/naoto/ElScreen/%SUBDIR%/
MASTER_SITE_SUBDIR= . old
+PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX}
MAINTAINER= kuriyama@FreeBSD.org
-COMMENT= GNU screen like utility on Emacsen
+COMMENT= Emacs utility similar to GNU Screen
-RUN_DEPENDS= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/emu/emu.el:editors/apel
+RUN_DEPENDS= apel${EMACS_PKGNAMESUFFIX}>0:editors/apel@${EMACS_FLAVOR}
-USE_EMACS= yes
+USES= emacs
-EMACS_NO_BUILD_DEPENDS= YES
+NO_ARCH= yes
NO_BUILD= YES
+PLIST_FILES= ${EMACS_SITE_LISPDIR}/elscreen.el
+PORTDOCS= ChangeLog README
+
OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_DATA} ${WRKSRC}/elscreen.el ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}
+ ${INSTALL_DATA} ${WRKSRC}/elscreen.el \
+ ${STAGEDIR}${PREFIX}/${EMACS_SITE_LISPDIR}
${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for i in ChangeLog README
+
+do-install-DOCS-on:
+.for i in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
diff --git a/misc/elscreen/pkg-plist b/misc/elscreen/pkg-plist
deleted file mode 100644
index b1617868ad02..000000000000
--- a/misc/elscreen/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-share/emacs/site-lisp/elscreen.el
-%%PORTDOCS%%share/doc/elscreen/ChangeLog
-%%PORTDOCS%%share/doc/elscreen/README