aboutsummaryrefslogtreecommitdiff
path: root/misc/estic
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2014-11-14 08:36:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2014-11-14 08:36:07 +0000
commit0f9de2df15cfd85420294d139833f3710b833bab (patch)
tree41f3b1fdfbe784188a3d6b0830cdc825a4f4913d /misc/estic
parent9caabf5217f6879d1d2686c4fb63ffda8320a92e (diff)
downloadports-0f9de2df15cfd85420294d139833f3710b833bab.tar.gz
ports-0f9de2df15cfd85420294d139833f3710b833bab.zip
- fix build on FreeBSD-10
Notes
Notes: svn path=/head/; revision=372553
Diffstat (limited to 'misc/estic')
-rw-r--r--misc/estic/Makefile9
-rw-r--r--misc/estic/files/patch-coll.cc11
-rw-r--r--misc/estic/files/patch-coll.h13
-rw-r--r--misc/estic/files/patch-stream.h40
-rw-r--r--misc/estic/pkg-plist5
5 files changed, 61 insertions, 17 deletions
diff --git a/misc/estic/Makefile b/misc/estic/Makefile
index e40470f65a40..f56560288ea8 100644
--- a/misc/estic/Makefile
+++ b/misc/estic/Makefile
@@ -15,7 +15,8 @@ COMMENT= Controller for ISDN TK-Anlage (PBX) made by Istec
USES= zip
USE_CSTD= gnu89
-
+USE_CXXSTD= gnu++98
+USE_GCC= any
NO_WRKSUBDIR= yes
# Personal Preferences, Where to install.
@@ -39,12 +40,6 @@ FIXME= areacode estic spunk
.include <bsd.port.options.mk>
-.if ${OSVERSION} > 1000000
-.if ${CC} != gcc42
-BROKEN= needs gcc4.2 to compile
-.endif
-.endif
-
.if ${PORT_OPTIONS:MX11}
X_OR_NOT=-x
PLIST_SUB+= WITHOUT_X="@comment "
diff --git a/misc/estic/files/patch-coll.cc b/misc/estic/files/patch-coll.cc
new file mode 100644
index 000000000000..a9c8a56a7b98
--- /dev/null
+++ b/misc/estic/files/patch-coll.cc
@@ -0,0 +1,11 @@
+--- spunk/coll.cc.orig 1996-11-30 00:40:58.000000000 +0100
++++ spunk/coll.cc 2014-11-14 08:11:36.000000000 +0100
+@@ -21,7 +21,7 @@
+
+ #include <stdlib.h>
+ #include <string.h>
+-#include <iostream.h>
++#include <iostream>
+
+ #include "machine.h"
+ #include "check.h"
diff --git a/misc/estic/files/patch-coll.h b/misc/estic/files/patch-coll.h
index 8df0637c1d65..30a201a37963 100644
--- a/misc/estic/files/patch-coll.h
+++ b/misc/estic/files/patch-coll.h
@@ -1,5 +1,5 @@
---- spunk/coll.h.orig Wed Dec 18 23:42:14 1996
-+++ spunk/coll.h Sun Oct 8 10:19:16 2006
+--- spunk/coll.h.orig 1996-12-18 23:42:14.000000000 +0100
++++ spunk/coll.h 2014-11-14 08:12:06.000000000 +0100
@@ -24,7 +24,7 @@
@@ -39,6 +39,15 @@
// Item not found
return -1;
+@@ -512,7 +512,7 @@
+ }
+
+ // Index points to the correct position, insert item
+- AtInsert (Index, Item);
++ this->AtInsert (Index, Item);
+ }
+
+
@@ -522,7 +522,7 @@
{
// do a binary search
diff --git a/misc/estic/files/patch-stream.h b/misc/estic/files/patch-stream.h
index 343901f1b707..614bdb8a7277 100644
--- a/misc/estic/files/patch-stream.h
+++ b/misc/estic/files/patch-stream.h
@@ -1,6 +1,39 @@
---- spunk/stream.h.orig Thu Nov 7 18:06:52 1996
-+++ spunk/stream.h Tue Sep 6 09:54:21 2005
-@@ -50,19 +50,19 @@
+--- spunk/stream.h.orig 1996-11-07 18:06:52.000000000 +0100
++++ spunk/stream.h 2014-11-14 08:10:27.000000000 +0100
+@@ -44,25 +44,53 @@
+ #include <stdio.h>
+ #include <string.h>
+
++#include "machine.h"
++
++class Stream;
++
++Stream& operator << (Stream&, char);
++Stream& operator << (Stream&, unsigned char);
++Stream& operator << (Stream&, signed char);
++Stream& operator << (Stream&, i16);
++Stream& operator << (Stream&, u16);
++Stream& operator << (Stream&, i32);
++Stream& operator << (Stream&, u32);
++Stream& operator << (Stream&, float);
++Stream& operator << (Stream&, double);
++Stream& operator << (Stream&, char*);
++
++Stream& operator >> (Stream&, char&);
++Stream& operator >> (Stream&, unsigned char&);
++Stream& operator >> (Stream&, signed char&);
++Stream& operator >> (Stream&, i16&);
++Stream& operator >> (Stream&, u16&);
++Stream& operator >> (Stream&, i32&);
++Stream& operator >> (Stream&, u32&);
++Stream& operator >> (Stream&, float&);
++Stream& operator >> (Stream&, double&);
++Stream& operator >> (Stream&, char*);
++
++
+ #include "strmable.h"
+ #include "coll.h"
+ #include "str.h"
@@ -17,6 +50,7 @@
-static const stSeekError = 10; // error using Seek, GetPos etc.
-static const stReadTimeout = 11; // Timeout on read (CharacterStream only)
-static const stWriteTimeout = 12; // Timeout on write (CharcterStream only)
++
+static const int stOk = 0; // things are allright
+static const int stInitError = 1; // error initializing the stream
+static const int stReadError = 2; // error reading from the stream
diff --git a/misc/estic/pkg-plist b/misc/estic/pkg-plist
index bb98f0e6c3f3..716ad93e7634 100644
--- a/misc/estic/pkg-plist
+++ b/misc/estic/pkg-plist
@@ -8,8 +8,3 @@ etc/pbx/estic.ini.generic_example
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/estic.doc
var/log/pbx/debug
-@dirrm etc/pbx
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm var/log/pbx
-@dirrm var/log
-@dirrm var