aboutsummaryrefslogtreecommitdiff
path: root/misc/estic
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2017-01-29 14:47:22 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2017-01-29 14:47:22 +0000
commitb111b35ebf940a8dacf18d08add3c126a5425d42 (patch)
tree01ef7161d77f12b7fe03b8a1413aa5bd14457ef7 /misc/estic
parentd3d7f4406895939145e810bcb806ddc6c976afd9 (diff)
downloadports-b111b35ebf940a8dacf18d08add3c126a5425d42.tar.gz
ports-b111b35ebf940a8dacf18d08add3c126a5425d42.zip
- add LICENSE
- use distribution patch - extend pkg-message - protect config file - cleanup staged install - make portlint happier
Notes
Notes: svn path=/head/; revision=432752
Diffstat (limited to 'misc/estic')
-rw-r--r--misc/estic/Makefile28
-rw-r--r--misc/estic/files/patch-areacode-freebsd-x.mak (renamed from misc/estic/files/patch-areacode-make)4
-rw-r--r--misc/estic/files/patch-areacode-freebsd.mak (renamed from misc/estic/files/patch-areacode-make-x)4
-rw-r--r--misc/estic/files/patch-areacode.c6
-rw-r--r--misc/estic/files/patch-check.cc8
-rw-r--r--misc/estic/files/patch-check.h8
-rw-r--r--misc/estic/files/patch-coll.cc4
-rw-r--r--misc/estic/files/patch-coll.h14
-rw-r--r--misc/estic/files/patch-delay.cc6
-rw-r--r--misc/estic/files/patch-estic-freebsd.mak12
-rw-r--r--misc/estic/files/patch-estic.cc4
-rw-r--r--misc/estic/files/patch-filepath.h8
-rw-r--r--misc/estic/files/patch-filesys.cc4
-rw-r--r--misc/estic/files/patch-filesys.h4
-rw-r--r--misc/estic/files/patch-icbaseed.cc6
-rw-r--r--misc/estic/files/patch-icdevs.cc10
-rw-r--r--misc/estic/files/patch-icshort.cc6
-rw-r--r--misc/estic/files/patch-imon.cc4
-rw-r--r--misc/estic/files/patch-itemwin.h4
-rw-r--r--misc/estic/files/patch-kbd.cc10
-rw-r--r--misc/estic/files/patch-machine.h6
-rw-r--r--misc/estic/files/patch-menue.cc6
-rw-r--r--misc/estic/files/patch-palette.h6
-rw-r--r--misc/estic/files/patch-password.cc6
-rw-r--r--misc/estic/files/patch-resed.h6
-rw-r--r--misc/estic/files/patch-resitem.cc8
-rw-r--r--misc/estic/files/patch-screen.cc4
-rw-r--r--misc/estic/files/patch-sercom.h4
-rw-r--r--misc/estic/files/patch-spunk-freebsd-x.mak12
-rw-r--r--misc/estic/files/patch-spunk-freebsd.mak12
-rw-r--r--misc/estic/files/patch-str.h4
-rw-r--r--misc/estic/files/patch-stream.cc6
-rw-r--r--misc/estic/files/patch-stream.h4
-rw-r--r--misc/estic/files/patch-textstrm.cc6
-rw-r--r--misc/estic/files/patch-window.cc8
-rw-r--r--misc/estic/pkg-message5
-rw-r--r--misc/estic/pkg-plist7
37 files changed, 128 insertions, 136 deletions
diff --git a/misc/estic/Makefile b/misc/estic/Makefile
index b847f20aff0f..0f6e3fda67ed 100644
--- a/misc/estic/Makefile
+++ b/misc/estic/Makefile
@@ -3,7 +3,7 @@
PORTNAME= estic
PORTVERSION= 1.61
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= misc comms
MASTER_SITES= LOCAL/dinoex
PKGNAMESUFFIX?= ${NOX11_SUFFIX}${PKGNAMESUFFIX2}
@@ -12,6 +12,8 @@ DISTFILES= estic-1.60-sources.zip estic-1.61-patch-from-1.60.zip
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Controller for ISDN TK-Anlage (PBX) made by Istec
+LICENSE= BSD2CLAUSE
+
USES= ncurses zip
USE_CSTD= gnu89
USE_CXXSTD= gnu++98
@@ -27,7 +29,6 @@ PBX_DOC=${STAGEDIR}${DOCSDIR}
ESTIC=${WRKSRC}/estic
AREACODE_DATAFILE=${PREFIX}/etc/pbx/areacodes
MAKEFILE=make/freebsd${X_OR_NOT}.mak
-AUTHOR= "Ullrich von Bassewitz" <uz@ibb.schwaben.com>
OPTIONS_DEFINE= X11 DTR_OFF DOCS
OPTIONS_DEFAULT=X11
@@ -56,7 +57,7 @@ EXTRA_PATCHES+= ${FILESDIR}/dtr-off.patch
pre-patch:
@${ECHO_MSG} "===> Applying distribution patches for ${PKGNAME}"
-# @${PATCH} -d ${PATCH_WRKSRC}/estic --forward --quiet -E -p0 --batch < ${WRKDIR}/estic.diff
+ ${PATCH} -d ${PATCH_WRKSRC}/estic --forward --quiet -E -p0 --batch < ${WRKSRC}/estic.diff
do-configure:
.for i in ${FIXME}
@@ -84,8 +85,7 @@ do-install:
@# estic doc says estic.res must be in bin path or current directory
${MKDIR} ${PBX_DOC}
${INSTALL_MAN} ${ESTIC}/estic.doc ${PBX_DOC}/
- @# estic.doc is not nroff format, & is in German, volunteers to create
- @# _and maintain_ nroff formatted English should contact ${AUTHOR}
+ @# estic.doc is not nroff format, & is in German
${INSTALL_MAN} ${FILESDIR}/README ${PBX_DOC}/
.endif
@# ${FILESDIR}/README is not in nroff, but is a temporary document.
@@ -93,23 +93,7 @@ do-install:
${INSTALL_DATA} ${ESTIC}/samples/estic.ini ${PBX_ETC}/estic.ini.generic_example
${INSTALL_DATA} ${FILESDIR}/estic.ini ${PBX_ETC}/estic.ini.freebsd_example
${INSTALL_DATA} ${ESTIC}/samples/alias.dat ${PBX_ETC}/aliases.example
- @# create config & debug so we can change mode to private
- ${TOUCH} ${PBX_ETC}/config ${PBX_VAR}/debug
- ${CHMOD} 600 ${PBX_VAR}/debug ${PBX_ETC}/config
- ${CHMOD} 700 ${PBX_VAR} # estic will create ./1996.11 etc
- @${ECHO_MSG} ""
- @${ECHO_MSG} " Suggestion, try: make demo"
-
-demo:
- @${ECHO_MSG} "If you want to try this under X-Windows, do this:"
- @${ECHO_MSG} " ${SETENV} SPUNK_LANGUAGE 001"
- @${ECHO_MSG} " ${SETENV} SPUNK_XFONT 8x13"
- @${ECHO_MSG} " cd ${PBX_ETC}"
- @${ECHO_MSG} " vi estic.ini"
- @${ECHO_MSG} " ${CHMOD} 666 /dev/cuaaX, or su"
- @${ECHO_MSG} " ${ESTIC}/xestic -display :0"
- @${ECHO_MSG} " (If you have no Istec 100[38] connected, append -n )"
- @${ECHO_MSG} " A BUGS & PROBLEMS section exists in ${FILESDIR}/README == man estic_freebsd"
+ ${TOUCH} ${PBX_ETC}/config.example
# Ref. NO_CDROM= & NO_PACKAGE=
# It is not necessary to prevent inclusion of source or binary on FreeBSD
diff --git a/misc/estic/files/patch-areacode-make b/misc/estic/files/patch-areacode-freebsd-x.mak
index e9e453195748..ab6ccea40a29 100644
--- a/misc/estic/files/patch-areacode-make
+++ b/misc/estic/files/patch-areacode-freebsd-x.mak
@@ -1,5 +1,5 @@
---- areacode/make/freebsd.mak.orig 2014-03-28 16:39:11.000000000 +0100
-+++ areacode/make/freebsd.mak 2014-03-28 16:39:50.000000000 +0100
+--- areacode/make/freebsd-x.mak.orig 2014-03-28 15:39:11 UTC
++++ areacode/make/freebsd-x.mak
@@ -0,0 +1,115 @@
+# *****************************************************************************
+# * *
diff --git a/misc/estic/files/patch-areacode-make-x b/misc/estic/files/patch-areacode-freebsd.mak
index 23be595aa07f..b38f8103dce0 100644
--- a/misc/estic/files/patch-areacode-make-x
+++ b/misc/estic/files/patch-areacode-freebsd.mak
@@ -1,5 +1,5 @@
---- areacode/make/freebsd-x.mak.orig 2014-03-28 16:39:11.000000000 +0100
-+++ areacode/make/freebsd-x.mak 2014-03-28 16:42:03.000000000 +0100
+--- areacode/make/freebsd.mak.orig 2014-03-28 15:39:11 UTC
++++ areacode/make/freebsd.mak
@@ -0,0 +1,115 @@
+# *****************************************************************************
+# * *
diff --git a/misc/estic/files/patch-areacode.c b/misc/estic/files/patch-areacode.c
index e9d55a57ee17..a7cd1bcdd705 100644
--- a/misc/estic/files/patch-areacode.c
+++ b/misc/estic/files/patch-areacode.c
@@ -1,6 +1,6 @@
---- areacode/areacode.c.orig 1997-02-16 11:24:50.000000000 +0100
-+++ areacode/areacode.c 2014-03-31 19:07:27.000000000 +0200
-@@ -352,7 +352,7 @@
+--- areacode/areacode.c.orig 1997-02-16 10:24:50 UTC
++++ areacode/areacode.c
+@@ -352,7 +352,7 @@ static void LoadTable (AreaCodeDesc* Des
/* Load a part of the table into memory */
{
u32 SpaceNeeded = (Desc->Last - Desc->First + 1) * sizeof (u32);
diff --git a/misc/estic/files/patch-check.cc b/misc/estic/files/patch-check.cc
index c62be9001a20..ba1c91794290 100644
--- a/misc/estic/files/patch-check.cc
+++ b/misc/estic/files/patch-check.cc
@@ -1,6 +1,6 @@
---- spunk/check.cc.orig Tue Jul 30 20:10:24 1996
-+++ spunk/check.cc Thu Dec 23 20:52:21 2004
-@@ -50,9 +50,6 @@
+--- spunk/check.cc.orig 1996-11-07 17:06:46 UTC
++++ spunk/check.cc
+@@ -50,9 +50,6 @@ static void _CheckFailed (const char* Ms
// The fail vector
@@ -8,5 +8,5 @@
-volatile
-#endif
void (*CheckFailed) (const char*, const char* Cond,
- int Code, const char* File, int Line) = _CheckFailed;
+ int Code, const char* File, int Line) = _CheckFailed;
diff --git a/misc/estic/files/patch-check.h b/misc/estic/files/patch-check.h
index 4db36dc5d45b..c378b33f5152 100644
--- a/misc/estic/files/patch-check.h
+++ b/misc/estic/files/patch-check.h
@@ -1,6 +1,6 @@
---- spunk/check.h.orig Tue Jul 30 20:10:26 1996
-+++ spunk/check.h Thu Dec 23 20:54:22 2004
-@@ -38,9 +38,6 @@
+--- spunk/check.h.orig 1996-11-07 17:06:46 UTC
++++ spunk/check.h
+@@ -38,9 +38,6 @@ extern const char* _MsgCheckFailed;
extern
@@ -8,5 +8,5 @@
-volatile
-#endif
void (*CheckFailed) (const char* Msg, const char* Cond, int Code,
- const char* File, int Line);
+ const char* File, int Line);
// Function pointer that is called from Check if the condition code is true.
diff --git a/misc/estic/files/patch-coll.cc b/misc/estic/files/patch-coll.cc
index a9c8a56a7b98..b578ea1c5f88 100644
--- a/misc/estic/files/patch-coll.cc
+++ b/misc/estic/files/patch-coll.cc
@@ -1,5 +1,5 @@
---- spunk/coll.cc.orig 1996-11-30 00:40:58.000000000 +0100
-+++ spunk/coll.cc 2014-11-14 08:11:36.000000000 +0100
+--- spunk/coll.cc.orig 1996-11-29 23:40:58 UTC
++++ spunk/coll.cc
@@ -21,7 +21,7 @@
#include <stdlib.h>
diff --git a/misc/estic/files/patch-coll.h b/misc/estic/files/patch-coll.h
index 30a201a37963..87ef58596b28 100644
--- a/misc/estic/files/patch-coll.h
+++ b/misc/estic/files/patch-coll.h
@@ -1,5 +1,5 @@
---- spunk/coll.h.orig 1996-12-18 23:42:14.000000000 +0100
-+++ spunk/coll.h 2014-11-14 08:12:06.000000000 +0100
+--- spunk/coll.h.orig 1996-12-18 22:42:14 UTC
++++ spunk/coll.h
@@ -24,7 +24,7 @@
@@ -20,7 +20,7 @@
-@@ -479,15 +479,15 @@
+@@ -479,15 +479,15 @@ int SortedCollection<T, U>::IndexOf (con
// Duplicates allowed. Do a linear search.
// (Hint: Search returns the first of all entrys with the same key)
@@ -39,7 +39,7 @@
// Item not found
return -1;
-@@ -512,7 +512,7 @@
+@@ -512,7 +512,7 @@ void SortedCollection<T, U>::Insert (T*
}
// Index points to the correct position, insert item
@@ -48,7 +48,7 @@
}
-@@ -522,7 +522,7 @@
+@@ -522,7 +522,7 @@ int SortedCollection<T, U>::Search (cons
{
// do a binary search
int First = 0;
@@ -57,7 +57,7 @@
int Current;
int Result;
int S = 0;
-@@ -533,7 +533,7 @@
+@@ -533,7 +533,7 @@ int SortedCollection<T, U>::Search (cons
Current = (Last + First) / 2;
// Do a compare
@@ -66,7 +66,7 @@
if (Result < 0) {
First = Current + 1;
} else {
-@@ -577,7 +577,7 @@
+@@ -577,7 +577,7 @@ T* SortedCollection<T, U>::Find (const U
int I;
if (Search (Key, I) != 0) {
// We found the key, I is the index
diff --git a/misc/estic/files/patch-delay.cc b/misc/estic/files/patch-delay.cc
index acdbfb29b3fe..1abcf28491e9 100644
--- a/misc/estic/files/patch-delay.cc
+++ b/misc/estic/files/patch-delay.cc
@@ -1,6 +1,6 @@
---- spunk/unixsrc/delay.cc.orig Sat Feb 26 17:50:13 2000
-+++ spunk/unixsrc/delay.cc Sat Feb 26 17:50:24 2000
-@@ -73,7 +73,7 @@
+--- spunk/unixsrc/delay.cc.orig 1996-11-07 17:06:58 UTC
++++ spunk/unixsrc/delay.cc
+@@ -73,7 +73,7 @@ u32 Delay (u32 ms)
//
// The function returns the real time passed or just ms.
{
diff --git a/misc/estic/files/patch-estic-freebsd.mak b/misc/estic/files/patch-estic-freebsd.mak
index 2a7e90b72c05..79af2fc31066 100644
--- a/misc/estic/files/patch-estic-freebsd.mak
+++ b/misc/estic/files/patch-estic-freebsd.mak
@@ -1,6 +1,6 @@
---- estic/make/freebsd.mak.orig 1997-01-31 03:57:24.000000000 +0100
-+++ estic/make/freebsd.mak 2014-03-28 17:03:18.000000000 +0100
-@@ -27,11 +27,11 @@
+--- estic/make/freebsd.mak.orig 1997-01-31 02:57:24 UTC
++++ estic/make/freebsd.mak
+@@ -27,11 +27,11 @@ AS = gas
AR = ar
LD = ld
ZIP = zip
@@ -14,7 +14,7 @@
# ------------------------------------------------------------------------------
-@@ -70,10 +70,10 @@
+@@ -70,10 +70,10 @@ OBJS = callwin.o \
icintcon.o \
iclog.o \
icmsgwin.o \
@@ -27,7 +27,7 @@
# ------------------------------------------------------------------------------
#
-@@ -81,14 +81,14 @@
+@@ -81,14 +81,14 @@ OBJS = callwin.o \
all: estic
estic: $(LIB) $(OBJS)
@@ -44,7 +44,7 @@
# ------------------------------------------------------------------------------
# Create a ZIP file
-@@ -112,9 +112,10 @@
+@@ -112,9 +112,10 @@ bin-dist: estic icload strip
clean:
-rm -f *.bak *~
diff --git a/misc/estic/files/patch-estic.cc b/misc/estic/files/patch-estic.cc
index 26c0582bcec0..cf341a3fee77 100644
--- a/misc/estic/files/patch-estic.cc
+++ b/misc/estic/files/patch-estic.cc
@@ -1,5 +1,5 @@
---- estic/estic.cc.orig Wed Mar 5 21:20:42 1997
-+++ estic/estic.cc Tue Sep 6 09:54:21 2005
+--- estic/estic.cc.orig 1997-03-05 20:20:42 UTC
++++ estic/estic.cc
@@ -80,9 +80,9 @@
diff --git a/misc/estic/files/patch-filepath.h b/misc/estic/files/patch-filepath.h
index afe9739d61f9..3064b0792e27 100644
--- a/misc/estic/files/patch-filepath.h
+++ b/misc/estic/files/patch-filepath.h
@@ -1,6 +1,6 @@
---- spunk/filepath.h.orig Sat Feb 26 17:54:52 2000
-+++ spunk/filepath.h Sat Feb 26 17:56:32 2000
-@@ -88,6 +88,7 @@
+--- spunk/filepath.h.orig 1996-11-13 23:12:02 UTC
++++ spunk/filepath.h
+@@ -88,6 +88,7 @@ int FHasWildcards (const String& Pathnam
// Return 1 if the given path contains one of the wildcard characters '*', '?'
// or '[]', return zero otherwise.
@@ -8,7 +8,7 @@
int FMatch (const String& Source, const String& Pattern);
// Match the string in Source against Pattern. Pattern may contain the
// wildcards '*', '?', '[abcd]' '[ab-d]', '[!abcd]', '[!ab-d]'
-@@ -95,6 +96,7 @@
+@@ -95,6 +96,7 @@ int FMatch (const String& Source, const
// otherwise a non zero value is returned.
// If Pattern contains an invalid wildcard pattern (e.g. 'A[x'), the function
// returns zero.
diff --git a/misc/estic/files/patch-filesys.cc b/misc/estic/files/patch-filesys.cc
index a131bd552eb1..1ea957c102db 100644
--- a/misc/estic/files/patch-filesys.cc
+++ b/misc/estic/files/patch-filesys.cc
@@ -1,5 +1,5 @@
---- spunk/unixsrc/filesys.cc.orig Sat Feb 26 17:57:13 2000
-+++ spunk/unixsrc/filesys.cc Sat Feb 26 17:57:39 2000
+--- spunk/unixsrc/filesys.cc.orig 1996-11-07 17:06:58 UTC
++++ spunk/unixsrc/filesys.cc
@@ -42,10 +42,10 @@
extern const char FileSysPathSep = '/'; // Path separator
diff --git a/misc/estic/files/patch-filesys.h b/misc/estic/files/patch-filesys.h
index 92dd800ebfb1..9290370a248a 100644
--- a/misc/estic/files/patch-filesys.h
+++ b/misc/estic/files/patch-filesys.h
@@ -1,5 +1,5 @@
---- spunk/filesys.h.orig Sat Feb 26 17:51:00 2000
-+++ spunk/filesys.h Sat Feb 26 17:51:27 2000
+--- spunk/filesys.h.orig 1996-11-07 17:06:48 UTC
++++ spunk/filesys.h
@@ -44,10 +44,10 @@
extern const char FileSysPathSep; // Path separator
diff --git a/misc/estic/files/patch-icbaseed.cc b/misc/estic/files/patch-icbaseed.cc
index 9bc45601e019..a1f4b5f765cd 100644
--- a/misc/estic/files/patch-icbaseed.cc
+++ b/misc/estic/files/patch-icbaseed.cc
@@ -1,6 +1,6 @@
---- estic/icbaseed.cc.orig Sat Nov 30 01:00:44 1996
-+++ estic/icbaseed.cc Tue Sep 6 09:54:21 2005
-@@ -451,26 +451,26 @@
+--- estic/icbaseed.cc.orig 1996-11-30 00:00:44 UTC
++++ estic/icbaseed.cc
+@@ -451,26 +451,26 @@ void EditBaseConfig (IstecConfig& Config
// otherwise, Changed is left untouched.
{
// ID's of menue items for EditBaseConfig
diff --git a/misc/estic/files/patch-icdevs.cc b/misc/estic/files/patch-icdevs.cc
index 62141a73283c..f964baf7ff71 100644
--- a/misc/estic/files/patch-icdevs.cc
+++ b/misc/estic/files/patch-icdevs.cc
@@ -1,6 +1,6 @@
---- estic/icdevs.cc.orig Wed Mar 5 21:48:44 1997
-+++ estic/icdevs.cc Tue Sep 6 09:54:21 2005
-@@ -157,8 +157,8 @@
+--- estic/icdevs.cc.orig 1997-03-05 20:48:44 UTC
++++ estic/icdevs.cc
+@@ -157,8 +157,8 @@ const String& DevListBox::ServiceName (u
String DevListBox::RerouteName (const String& Num)
// Map the reroute capability to a string with fixed length
{
@@ -11,7 +11,7 @@
String Res (PadLength);
if (Num.IsEmpty ()) {
-@@ -269,9 +269,9 @@
+@@ -269,9 +269,9 @@ static int ExtRerouteOk (const String& P
static void EditExtReroute (const Point& Pos, IstecDevConfig& Config)
// Edit the extended reroute capabilities of FW 2.0 in a separate menu
{
@@ -24,7 +24,7 @@
// Load the menu
Menue* M = (Menue*) LoadResource ("@ICDEVS.RerouteMenue");
-@@ -407,38 +407,38 @@
+@@ -407,38 +407,38 @@ static void EditDevConfig (IstecDevConfi
static const String StgPosName = "EditDevConfig.ConfigMenue.Position";
// Menue constants
diff --git a/misc/estic/files/patch-icshort.cc b/misc/estic/files/patch-icshort.cc
index 27837cf9a92a..5f77031ac03c 100644
--- a/misc/estic/files/patch-icshort.cc
+++ b/misc/estic/files/patch-icshort.cc
@@ -1,6 +1,6 @@
---- estic/icshort.cc.orig Tue Sep 6 09:54:20 2005
-+++ estic/icshort.cc Tue Sep 6 09:54:21 2005
-@@ -578,17 +578,17 @@
+--- estic/icshort.cc.orig 1997-01-31 03:29:12 UTC
++++ estic/icshort.cc
+@@ -574,17 +574,17 @@ void ShortNumberListBox::Print (int Inde
// Item numbers for the short number edit menu
diff --git a/misc/estic/files/patch-imon.cc b/misc/estic/files/patch-imon.cc
index 8d0552ee962c..7ec3af9f6a23 100644
--- a/misc/estic/files/patch-imon.cc
+++ b/misc/estic/files/patch-imon.cc
@@ -1,5 +1,5 @@
---- estic/imon.cc.orig Sat Feb 26 18:33:03 2000
-+++ estic/imon.cc Sat Feb 26 18:33:29 2000
+--- estic/imon.cc.orig 1996-11-08 16:41:46 UTC
++++ estic/imon.cc
@@ -22,6 +22,7 @@
#include <stdio.h>
#include <errno.h>
diff --git a/misc/estic/files/patch-itemwin.h b/misc/estic/files/patch-itemwin.h
index f0ea83a8bbe9..bcdf9861a984 100644
--- a/misc/estic/files/patch-itemwin.h
+++ b/misc/estic/files/patch-itemwin.h
@@ -1,6 +1,6 @@
---- estic-1.61.orig/spunk/itemwin.h
+--- spunk/itemwin.h.orig 1996-11-07 17:06:48 UTC
+++ spunk/itemwin.h
-@@ -54,7 +54,7 @@
+@@ -54,7 +54,7 @@ const u16 ifNoSub = 0x0010
/* class WindowItem */
/*****************************************************************************/
diff --git a/misc/estic/files/patch-kbd.cc b/misc/estic/files/patch-kbd.cc
index e1cbc7cb4e4d..20a8bfea3faf 100644
--- a/misc/estic/files/patch-kbd.cc
+++ b/misc/estic/files/patch-kbd.cc
@@ -1,5 +1,5 @@
---- spunk/bsdsrc/kbd.cc.orig Tue Dec 10 14:41:06 1996
-+++ spunk/bsdsrc/kbd.cc Tue Sep 6 09:54:21 2005
+--- spunk/bsdsrc/kbd.cc.orig 1996-12-10 13:41:06 UTC
++++ spunk/bsdsrc/kbd.cc
@@ -27,7 +27,7 @@
#include <sys/time.h>
#include <sys/ioctl.h>
@@ -9,7 +9,7 @@
#endif
#include "../machine.h"
-@@ -64,7 +64,7 @@
+@@ -64,7 +64,7 @@ static CharSet AvailExtKeys;
// An array for mapping extended to virtual keys
@@ -18,7 +18,7 @@
struct { Key EK; Key VK; } VirtualMap [VirtualMapSize];
static unsigned VirtualMapCount = 0;
-@@ -192,7 +192,11 @@
+@@ -192,7 +192,11 @@ static char* KbdGetCap (const char* Cap)
{
static char CapBuf [128];
char* CapPtr = CapBuf;
@@ -30,7 +30,7 @@
}
-@@ -649,10 +653,22 @@
+@@ -649,10 +653,22 @@ void Keyboard::GetMappedKey (int Wait)
}
// Now read in a new chunk of chars.
diff --git a/misc/estic/files/patch-machine.h b/misc/estic/files/patch-machine.h
index 698bfef81070..25ab2440dd8b 100644
--- a/misc/estic/files/patch-machine.h
+++ b/misc/estic/files/patch-machine.h
@@ -1,6 +1,6 @@
---- spunk/machine.h.orig 1997-02-18 14:41:50.000000000 +0100
-+++ spunk/machine.h 2014-03-28 16:58:13.000000000 +0100
-@@ -238,7 +238,7 @@
+--- spunk/machine.h.orig 1997-02-18 13:41:50 UTC
++++ spunk/machine.h
+@@ -238,7 +238,7 @@ typedef unsigned u32;
# define CPU_LITTLE_ENDIAN
#elif (BYTE_ORDER == BIG_ENDIAN)
# define CPU_BIG_ENDIAN
diff --git a/misc/estic/files/patch-menue.cc b/misc/estic/files/patch-menue.cc
index a3243e2cb5b7..2c317c3c3c49 100644
--- a/misc/estic/files/patch-menue.cc
+++ b/misc/estic/files/patch-menue.cc
@@ -1,6 +1,6 @@
---- spunk/menue.cc.orig Sat Feb 26 17:58:13 2000
-+++ spunk/menue.cc Sat Feb 26 17:58:32 2000
-@@ -495,8 +495,8 @@
+--- spunk/menue.cc.orig 1997-01-26 17:17:32 UTC
++++ spunk/menue.cc
+@@ -495,8 +495,8 @@ void GenericMenue::DynamicRight ()
i16 GenericMenue::GetChoice ()
{
diff --git a/misc/estic/files/patch-palette.h b/misc/estic/files/patch-palette.h
index 27efe1f6cf66..694928f0b04c 100644
--- a/misc/estic/files/patch-palette.h
+++ b/misc/estic/files/patch-palette.h
@@ -1,6 +1,6 @@
---- spunk/palette.h.orig Sat Feb 26 17:52:03 2000
-+++ spunk/palette.h Sat Feb 26 17:52:34 2000
-@@ -40,19 +40,19 @@
+--- spunk/palette.h.orig 1996-11-07 17:06:48 UTC
++++ spunk/palette.h
+@@ -40,19 +40,19 @@ extern class Palette* Pal;
// Indices into the palette arrays
diff --git a/misc/estic/files/patch-password.cc b/misc/estic/files/patch-password.cc
index 77354ad3aaa9..731e5816c242 100644
--- a/misc/estic/files/patch-password.cc
+++ b/misc/estic/files/patch-password.cc
@@ -1,6 +1,6 @@
---- spunk/password.cc.orig Sat Feb 26 17:59:02 2000
-+++ spunk/password.cc Sat Feb 26 18:01:24 2000
-@@ -525,14 +525,14 @@
+--- spunk/password.cc.orig 1996-11-07 17:06:48 UTC
++++ spunk/password.cc
+@@ -525,14 +525,14 @@ LINK (PasswordColl, ID_PasswordColl);
diff --git a/misc/estic/files/patch-resed.h b/misc/estic/files/patch-resed.h
index 07a617f33411..a879a6b38007 100644
--- a/misc/estic/files/patch-resed.h
+++ b/misc/estic/files/patch-resed.h
@@ -1,6 +1,6 @@
---- spunk/resed.h.orig Fri Feb 21 12:05:28 1997
-+++ spunk/resed.h Mon Oct 9 12:07:54 2006
-@@ -184,7 +184,7 @@
+--- spunk/resed.h.orig 1997-02-21 11:05:28 UTC
++++ spunk/resed.h
+@@ -184,7 +184,7 @@ protected:
void IDPrompt (i16& ID, int& Abort);
void EditIDPrompt (i16& ID, int& Abort);
void MinMaxPrompt (i32& Min, i32& Max, i32 MinVal, i32 MaxVal, int& Abort);
diff --git a/misc/estic/files/patch-resitem.cc b/misc/estic/files/patch-resitem.cc
index 087de120ca56..de56c1b3f554 100644
--- a/misc/estic/files/patch-resitem.cc
+++ b/misc/estic/files/patch-resitem.cc
@@ -1,6 +1,6 @@
---- spunk/resitem.cc.orig Sat Feb 26 18:07:02 2000
-+++ spunk/resitem.cc Sat Feb 26 18:07:39 2000
-@@ -1403,16 +1403,16 @@
+--- spunk/resitem.cc.orig 1997-02-21 11:05:30 UTC
++++ spunk/resitem.cc
+@@ -1539,16 +1539,16 @@ void ResEditApp::ItemMenue (WindowItem*
// Data edit menue
{
// Menue IDs
@@ -27,7 +27,7 @@
// Load the menue from the resource
Menue* M = (Menue*) LoadResource ("@RESITEM.ItemDataMenue");
-@@ -1639,13 +1639,13 @@
+@@ -1785,13 +1785,13 @@ void ResEditApp::ChangeLimits (WindowIte
void ResEditApp::ChangeCharset (WindowItem* Item)
{
diff --git a/misc/estic/files/patch-screen.cc b/misc/estic/files/patch-screen.cc
index f04279abce78..e639ea96ad27 100644
--- a/misc/estic/files/patch-screen.cc
+++ b/misc/estic/files/patch-screen.cc
@@ -1,5 +1,5 @@
---- spunk/bsdsrc/screen.cc.orig Thu Nov 7 18:06:54 1996
-+++ spunk/bsdsrc/screen.cc Tue Sep 6 09:54:21 2005
+--- spunk/bsdsrc/screen.cc.orig 1996-11-07 17:06:54 UTC
++++ spunk/bsdsrc/screen.cc
@@ -22,7 +22,8 @@
#include <stdlib.h>
#include <sys/ioctl.h>
diff --git a/misc/estic/files/patch-sercom.h b/misc/estic/files/patch-sercom.h
index 2d4234795389..d236394ebba3 100644
--- a/misc/estic/files/patch-sercom.h
+++ b/misc/estic/files/patch-sercom.h
@@ -1,5 +1,5 @@
---- spunk/sercom.h.orig Thu Nov 7 18:06:52 1996
-+++ spunk/sercom.h Tue Sep 6 09:54:21 2005
+--- spunk/sercom.h.orig 1996-11-07 17:06:52 UTC
++++ spunk/sercom.h
@@ -43,29 +43,29 @@
diff --git a/misc/estic/files/patch-spunk-freebsd-x.mak b/misc/estic/files/patch-spunk-freebsd-x.mak
index 32081e0b74d4..0582c5dc4a0e 100644
--- a/misc/estic/files/patch-spunk-freebsd-x.mak
+++ b/misc/estic/files/patch-spunk-freebsd-x.mak
@@ -1,6 +1,6 @@
---- spunk/make/freebsd-x.mak.orig 1996-11-24 22:33:26.000000000 +0100
-+++ spunk/make/freebsd-x.mak 2014-03-28 16:29:37.000000000 +0100
-@@ -27,10 +27,10 @@
+--- spunk/make/freebsd-x.mak.orig 1996-11-24 21:33:26 UTC
++++ spunk/make/freebsd-x.mak
+@@ -27,10 +27,10 @@ AS = gas
AR = ar
LD = ld
ZIP = zip
@@ -13,7 +13,7 @@
LIB = spunk.a
ZIPFILE = spunk.zip
-@@ -135,8 +135,8 @@
+@@ -135,8 +135,8 @@ RESEDITOBJS = resed.o \
# ------------------------------------------------------------------------------
# Dummy targets
@@ -24,7 +24,7 @@
lib: $(LIB)
-@@ -149,7 +149,7 @@
+@@ -149,7 +149,7 @@ $(LIB): $(OBJS)
depend dep:
@echo "Creating dependency information"
@@ -33,7 +33,7 @@
# ------------------------------------------------------------------------------
# Target specific files
-@@ -192,9 +192,10 @@
+@@ -192,9 +192,10 @@ zip:
clean:
-rm -f *~ linuxsrc/*~ bsdsrc/*~ unixsrc/*~
diff --git a/misc/estic/files/patch-spunk-freebsd.mak b/misc/estic/files/patch-spunk-freebsd.mak
index 070a3ea9b30c..dec6e31df764 100644
--- a/misc/estic/files/patch-spunk-freebsd.mak
+++ b/misc/estic/files/patch-spunk-freebsd.mak
@@ -1,6 +1,6 @@
---- spunk/make/freebsd.mak.orig 1996-11-24 22:33:26.000000000 +0100
-+++ spunk/make/freebsd.mak 2014-03-28 16:25:12.000000000 +0100
-@@ -27,10 +27,10 @@
+--- spunk/make/freebsd.mak.orig 1996-11-24 21:33:26 UTC
++++ spunk/make/freebsd.mak
+@@ -27,10 +27,10 @@ AS = gas
AR = ar
LD = ld
ZIP = zip
@@ -13,7 +13,7 @@
LIB = spunk.a
ZIPFILE = spunk.zip
-@@ -137,7 +137,7 @@
+@@ -137,7 +137,7 @@ RESEDITOBJS = resed.o \
# Dummy targets
resed: $(LIB) $(RESEDITOBJS)
@@ -22,7 +22,7 @@
lib: $(LIB)
-@@ -150,7 +150,7 @@
+@@ -150,7 +150,7 @@ $(LIB): $(OBJS)
depend dep:
@echo "Creating dependency information"
@@ -31,7 +31,7 @@
# ------------------------------------------------------------------------------
# Target specific files
-@@ -196,9 +196,10 @@
+@@ -196,9 +196,10 @@ zip:
clean:
-rm -f *~ linuxsrc/*~ bsdsrc/*~ unixsrc/*~
diff --git a/misc/estic/files/patch-str.h b/misc/estic/files/patch-str.h
index 8f43cc32e08a..23a3f8dd69b1 100644
--- a/misc/estic/files/patch-str.h
+++ b/misc/estic/files/patch-str.h
@@ -1,6 +1,6 @@
---- estic-1.61.orig/spunk/str.h
+--- spunk/str.h.orig 1996-12-18 12:18:50 UTC
+++ spunk/str.h
-@@ -91,6 +91,46 @@
+@@ -91,6 +91,46 @@ extern const class String EmptyString;
// Note: This string class may not work with strings greater than INT_MAX or
// 0xFFFF, whichever is less
diff --git a/misc/estic/files/patch-stream.cc b/misc/estic/files/patch-stream.cc
index 61060394a628..a65a8f534902 100644
--- a/misc/estic/files/patch-stream.cc
+++ b/misc/estic/files/patch-stream.cc
@@ -1,6 +1,6 @@
---- spunk/stream.cc.orig Sat Feb 26 18:03:19 2000
-+++ spunk/stream.cc Sat Feb 26 18:03:35 2000
-@@ -245,7 +245,7 @@
+--- spunk/stream.cc.orig 1996-12-18 12:09:02 UTC
++++ spunk/stream.cc
+@@ -347,7 +347,7 @@ void Stream::Write (const void*, size_t)
void Stream::CopyFrom (Stream& S, size_t Count)
{
diff --git a/misc/estic/files/patch-stream.h b/misc/estic/files/patch-stream.h
index 614bdb8a7277..89ed06f0fd44 100644
--- a/misc/estic/files/patch-stream.h
+++ b/misc/estic/files/patch-stream.h
@@ -1,5 +1,5 @@
---- spunk/stream.h.orig 1996-11-07 18:06:52.000000000 +0100
-+++ spunk/stream.h 2014-11-14 08:10:27.000000000 +0100
+--- spunk/stream.h.orig 1996-11-07 17:06:52 UTC
++++ spunk/stream.h
@@ -44,25 +44,53 @@
#include <stdio.h>
#include <string.h>
diff --git a/misc/estic/files/patch-textstrm.cc b/misc/estic/files/patch-textstrm.cc
index 71d1464a4424..e8a968aa11f4 100644
--- a/misc/estic/files/patch-textstrm.cc
+++ b/misc/estic/files/patch-textstrm.cc
@@ -1,6 +1,6 @@
---- spunk/textstrm.cc.orig Sat Feb 26 18:05:06 2000
-+++ spunk/textstrm.cc Sat Feb 26 18:05:17 2000
-@@ -66,8 +66,8 @@
+--- spunk/textstrm.cc.orig 1996-11-07 17:06:52 UTC
++++ spunk/textstrm.cc
+@@ -66,8 +66,8 @@ void TextFileStream::MakeLineIndex (int
// LineLen is the estimated length of a line in the file used for
// estimating the size of the buffer.
{
diff --git a/misc/estic/files/patch-window.cc b/misc/estic/files/patch-window.cc
index e422f6f8cb1a..ec22cee772aa 100644
--- a/misc/estic/files/patch-window.cc
+++ b/misc/estic/files/patch-window.cc
@@ -1,6 +1,6 @@
---- spunk/window.cc.orig Sat Feb 26 18:05:58 2000
-+++ spunk/window.cc Sat Feb 26 18:06:16 2000
-@@ -1395,7 +1395,7 @@
+--- spunk/window.cc.orig 1997-01-26 17:17:38 UTC
++++ spunk/window.cc
+@@ -1432,7 +1432,7 @@ void Window::Write (int X, int Y, const
// Write a string to the inner window. Note: Attr is an index, not a real
// attribute !
{
@@ -9,7 +9,7 @@
u16 Buf [256];
// Check if the given string is empty
-@@ -1517,7 +1517,7 @@
+@@ -1554,7 +1554,7 @@ void Window::CWrite (int X, int Y, const
// Write a string to the inner window. Note: Attr is an index, not a real
// attribute !
{
diff --git a/misc/estic/pkg-message b/misc/estic/pkg-message
index 17876a475304..0ad8c2f1b271 100644
--- a/misc/estic/pkg-message
+++ b/misc/estic/pkg-message
@@ -1,2 +1,7 @@
To support more than ASCII, please set in your enviroment:
SPUNK_CTYPE=iso_8859_1
+
+If you want to try this under X-Windows, do this:
+env SPUNK_LANGUAGE=001 SPUNK_XFONT=8x13 xestic
+If you have no Istec 100[38] connected, append "-n"
+A BUGS & PROBLEMS section exists, see README.
diff --git a/misc/estic/pkg-plist b/misc/estic/pkg-plist
index 716ad93e7634..7f3de6704008 100644
--- a/misc/estic/pkg-plist
+++ b/misc/estic/pkg-plist
@@ -2,9 +2,12 @@ bin/estic.res
%%WITHOUT_X%%bin/estic
%%WITH_X%%bin/xestic
etc/pbx/aliases.example
-etc/pbx/config
+@(root,wheel,600) etc/pbx/config.example
etc/pbx/estic.ini.freebsd_example
etc/pbx/estic.ini.generic_example
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/estic.doc
-var/log/pbx/debug
+@preunexec [ -e %D/var/log/pbx/debug ] && rm -f %D/var/log/pbx/debug || true
+@dir(root,wheel,700) var/log/pbx
+@postexec touch %D/var/log/pbx/debug
+@postexec chmod 600 %D/var/log/pbx/debug