aboutsummaryrefslogtreecommitdiff
path: root/misc/explosions
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-08-08 17:56:08 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-08-08 17:56:08 +0000
commitd79868927d24c8557666cbb8cc2d4781981ef98d (patch)
treef244db904b1d3d7b9c5ab18d89b79595e1130f08 /misc/explosions
parent39bd08f6a6157b09775a2a70230575ca594f68ad (diff)
downloadports-d79868927d24c8557666cbb8cc2d4781981ef98d.tar.gz
ports-d79868927d24c8557666cbb8cc2d4781981ef98d.zip
New port explosions version 0.2001.08.05: 3D objects flying around
resembling explosions with various effects. Submitted by: Pete Fritchman <petef@databits.net>
Notes
Notes: svn path=/head/; revision=45980
Diffstat (limited to 'misc/explosions')
-rw-r--r--misc/explosions/Makefile42
-rw-r--r--misc/explosions/distinfo1
-rw-r--r--misc/explosions/pkg-comment1
-rw-r--r--misc/explosions/pkg-descr12
-rw-r--r--misc/explosions/pkg-plist12
5 files changed, 68 insertions, 0 deletions
diff --git a/misc/explosions/Makefile b/misc/explosions/Makefile
new file mode 100644
index 000000000000..835811836c42
--- /dev/null
+++ b/misc/explosions/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: explosions
+# Date created: 8 August 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= explosions
+PORTVERSION= 0.2001.08.05
+CATEGORIES= misc
+MASTER_SITES= ftp://ftp.sonic.net/pub/users/nbs/unix/x/explosions/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^0.//}
+
+MAINTAINER= petef@databits.net
+
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12 \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+post-patch:
+ @${PERL} -pi -e 's!CFLAGS=-Wall -O2!CFLAGS+=-Wall!; \
+ s!sdl-config!${SDL_CONFIG}!' \
+ ${WRKSRC}/Makefile
+ @${PERL} -pi -e 's!spark%d.png!${DATADIR}/spark%d.png!' \
+ ${WRKSRC}/explosions.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/explosions ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/spark?.png ${DATADIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in BUGS.txt CHANGES.txt README.txt
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/misc/explosions/distinfo b/misc/explosions/distinfo
new file mode 100644
index 000000000000..1029a403ff4d
--- /dev/null
+++ b/misc/explosions/distinfo
@@ -0,0 +1 @@
+MD5 (explosions-2001.08.05.tar.gz) = 420312f551a4c2a6dd0b88a06b7dcefa
diff --git a/misc/explosions/pkg-comment b/misc/explosions/pkg-comment
new file mode 100644
index 000000000000..d1d9d065bfbc
--- /dev/null
+++ b/misc/explosions/pkg-comment
@@ -0,0 +1 @@
+3D objects flying around resembling explosions with various effects
diff --git a/misc/explosions/pkg-descr b/misc/explosions/pkg-descr
new file mode 100644
index 000000000000..b83cbc835e92
--- /dev/null
+++ b/misc/explosions/pkg-descr
@@ -0,0 +1,12 @@
+This is a simplified 3D world with alpha-blended objects that look
+kind of like fireworks or sparks. It also has a number of effects
+built in, such as fading, blurring, fire ("heat"), and zooming.
+
+It serves no purpose except to look pretty. The source-code is also
+well-documented, so someone might find it useful in learning SDL
+routines.
+
+WWW: http://www.newbreedsoftware.com/explosions/
+
+- Pete
+petef@databits.net
diff --git a/misc/explosions/pkg-plist b/misc/explosions/pkg-plist
new file mode 100644
index 000000000000..eab4264538b0
--- /dev/null
+++ b/misc/explosions/pkg-plist
@@ -0,0 +1,12 @@
+bin/explosions
+share/doc/explosions/BUGS.txt
+share/doc/explosions/CHANGES.txt
+share/doc/explosions/README.txt
+share/explosions/spark1.png
+share/explosions/spark2.png
+share/explosions/spark3.png
+share/explosions/spark4.png
+share/explosions/spark5.png
+share/explosions/spark6.png
+share/explosions/spark7.png
+@dirrm share/explosions