aboutsummaryrefslogtreecommitdiff
path: root/misc/fortune-mod-bofh
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-14 05:16:28 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-14 05:16:28 +0000
commit8cf4ab0d4a2145c40a56eff4d59c7365f480e768 (patch)
treefe000b397ea7038661e5583e7f81cf3cf4b60a40 /misc/fortune-mod-bofh
parent706750303f594aed6416c3d04bb065ef4ddd0a15 (diff)
downloadports-8cf4ab0d4a2145c40a56eff4d59c7365f480e768.tar.gz
ports-8cf4ab0d4a2145c40a56eff4d59c7365f480e768.zip
misc/fortune-mod-bofh: Use fortune_strfile instead of strfile(8)
This removes the dependency on the games distribution. Approved by: general blanket
Notes
Notes: svn path=/head/; revision=422108
Diffstat (limited to 'misc/fortune-mod-bofh')
-rw-r--r--misc/fortune-mod-bofh/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/misc/fortune-mod-bofh/Makefile b/misc/fortune-mod-bofh/Makefile
index 76d642870d10..772f20e671e4 100644
--- a/misc/fortune-mod-bofh/Makefile
+++ b/misc/fortune-mod-bofh/Makefile
@@ -12,24 +12,20 @@ DISTFILES= bofh-fortune-mod${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= onatan@gmail.com
COMMENT= Compilation of excuses from the "Bastard Operator From Hell"
+BUILD_DEPENDS= fortune_strfile:misc/fortune_strfile
+STRFILE= ${LOCALBASE}/bin/fortune_strfile
+
WRKSRC= ${WRKDIR}/bofh-fortune-mod2.0
PKGMESSAGE= ${WRKDIR}/pkg-message
SUB_FILES= pkg-message
-.if exists(/usr/games/strfile)
-STRFILE= /usr/games/strfile
-.elif exists(/usr/bin/strfile)
-STRFILE= /usr/bin/strfile
-.else
-IGNORE= needs strfile command. Please install games distribution of base system
-.endif
-
do-build:
- @${STRFILE} ${WRKSRC}/bofh
+ ${STRFILE} ${WRKSRC}/bofh
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/share/games/fortune
- ${INSTALL_DATA} ${WRKSRC}/bofh* ${STAGEDIR}${PREFIX}/share/games/fortune
+ ${INSTALL_DATA} ${WRKSRC}/bofh* \
+ ${STAGEDIR}${PREFIX}/share/games/fortune
.include <bsd.port.mk>