aboutsummaryrefslogtreecommitdiff
path: root/misc/geekcode
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>1999-08-30 07:48:45 +0000
committerChris Piazza <cpiazza@FreeBSD.org>1999-08-30 07:48:45 +0000
commitc34042a75b68f25305935e36ea4bb0c34a450b58 (patch)
tree3387df67c0da2c070612590ebcff46a5dcfa38a5 /misc/geekcode
parent3817587abeab5c7cb446b5ff3fa24d69642db30e (diff)
downloadports-c34042a75b68f25305935e36ea4bb0c34a450b58.tar.gz
ports-c34042a75b68f25305935e36ea4bb0c34a450b58.zip
Import of geekcode.
The Geek Code Generator. It simply generates your geek code by asking questions about all aspects of your geekiness
Notes
Notes: svn path=/head/; revision=21113
Diffstat (limited to 'misc/geekcode')
-rw-r--r--misc/geekcode/Makefile18
-rw-r--r--misc/geekcode/distinfo1
-rw-r--r--misc/geekcode/files/patch-aa34
-rw-r--r--misc/geekcode/pkg-comment1
-rw-r--r--misc/geekcode/pkg-descr4
-rw-r--r--misc/geekcode/pkg-plist1
6 files changed, 59 insertions, 0 deletions
diff --git a/misc/geekcode/Makefile b/misc/geekcode/Makefile
new file mode 100644
index 000000000000..84135bf4ac71
--- /dev/null
+++ b/misc/geekcode/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: geekcode generator
+# Version required: 1.1
+# Date created: 30 Aug 1999
+# Whom: Chris Piazza <cpiazza@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= geekcode-1.1
+CATEGORIES= misc
+MASTER_SITES= http://seymour.napalm.net/
+
+MAINTAINER= cpiazza@FreeBSD.org
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/geekcode ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/misc/geekcode/distinfo b/misc/geekcode/distinfo
new file mode 100644
index 000000000000..01c17bea9511
--- /dev/null
+++ b/misc/geekcode/distinfo
@@ -0,0 +1 @@
+MD5 (geekcode-1.1.tar.gz) = 38e550117689f04c0803ccce5e0b1f84
diff --git a/misc/geekcode/files/patch-aa b/misc/geekcode/files/patch-aa
new file mode 100644
index 000000000000..4959d50c5f47
--- /dev/null
+++ b/misc/geekcode/files/patch-aa
@@ -0,0 +1,34 @@
+--- Makefile.orig Sun Aug 29 11:02:52 1999
++++ Makefile Mon Aug 30 00:42:38 1999
+@@ -1,6 +1,6 @@
+-CFLAGS=-O3 -Wall -s
++CFLAGS?=-O3 -Wall -s
+ TARGET=geekcode
+-CC=gcc
++CC?=gcc
+
+ SRCFILES = gc_appearance.c \
+ gc_computers.c \
+@@ -24,14 +24,14 @@
+ rm -f $(TARGET) $(LIBFILES)
+
+ geekcode:
+- gcc $(CFLAGS) -c gc_appearance.c
+- gcc $(CFLAGS) -c gc_computers.c
+- gcc $(CFLAGS) -c gc_entertainment.c
+- gcc $(CFLAGS) -c gc_lifestyle.c
+- gcc $(CFLAGS) -c gc_politics.c
+- gcc $(CFLAGS) -c gc_type.c
+- gcc $(CFLAGS) -c geekcode.c
+- gcc $(CFLAGS) -o $(TARGET) $(LIBFILES)
++ ${CC} $(CFLAGS) -c gc_appearance.c
++ ${CC} $(CFLAGS) -c gc_computers.c
++ ${CC} $(CFLAGS) -c gc_entertainment.c
++ ${CC} $(CFLAGS) -c gc_lifestyle.c
++ ${CC} $(CFLAGS) -c gc_politics.c
++ ${CC} $(CFLAGS) -c gc_type.c
++ ${CC} $(CFLAGS) -c geekcode.c
++ ${CC} $(CFLAGS) -o $(TARGET) $(LIBFILES)
+
+ install:
+ install -m 755 geekcode /usr/local/bin
diff --git a/misc/geekcode/pkg-comment b/misc/geekcode/pkg-comment
new file mode 100644
index 000000000000..822d9be62d87
--- /dev/null
+++ b/misc/geekcode/pkg-comment
@@ -0,0 +1 @@
+A Geek Code Generator
diff --git a/misc/geekcode/pkg-descr b/misc/geekcode/pkg-descr
new file mode 100644
index 000000000000..9374705a5937
--- /dev/null
+++ b/misc/geekcode/pkg-descr
@@ -0,0 +1,4 @@
+The Geek Code Generator. It simply generates your geek code
+by asking questions about all aspects of your geek life.
+
+WWW: http://seymour.napalm.net/geekcode.html
diff --git a/misc/geekcode/pkg-plist b/misc/geekcode/pkg-plist
new file mode 100644
index 000000000000..56dc6cce6d3b
--- /dev/null
+++ b/misc/geekcode/pkg-plist
@@ -0,0 +1 @@
+bin/geekcode