aboutsummaryrefslogtreecommitdiff
path: root/misc/gplink
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-08 16:00:52 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-08 16:00:52 +0000
commitd073c19d2db18eda1a83b061c4e673e116b38a13 (patch)
tree180e8aa3df8846c366d45712d025baa585616412 /misc/gplink
parent72e7f0cfc18768fa9f5de041bf2534ab48129c90 (diff)
downloadports-d073c19d2db18eda1a83b061c4e673e116b38a13.tar.gz
ports-d073c19d2db18eda1a83b061c4e673e116b38a13.zip
- Add LICENSE
- Add MAKE_JOBS_SAFE - Fix WWW: line PR: 159485 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=279250
Diffstat (limited to 'misc/gplink')
-rw-r--r--misc/gplink/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/misc/gplink/Makefile b/misc/gplink/Makefile
index ea5c6b3c6379..73377a0e5bd2 100644
--- a/misc/gplink/Makefile
+++ b/misc/gplink/Makefile
@@ -14,23 +14,28 @@ MASTER_SITES= http://gp2x.org/gp32/gplink/ \
MAINTAINER= ports@FreeBSD.org
COMMENT= A GP32 USB linker tool
-USE_GMAKE= yes
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
WRKSRC= ${WRKDIR}/${DISTNAME}/src
+USE_GMAKE= yes
+MAKE_ARGS= CC="${CC}" \
+ CFLAGS="${CFLAGS} ${USB_CFLAGS}" \
+ LDFLAGS="${USB_LDFLAGS}"
+MAKE_JOBS_SAFE= yes
+
PLIST_FILES= bin/gplink
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's/^\(CC[^g]*\)gcc$$/\1${CC}/' ${WRKSRC}/Makefile
-.if ${OSVERSION} >= 800069
- @${REINPLACE_CMD} -E -e 's,`libusb-config --cflags`,,g' \
- -e 's,`libusb-config --libs`,-lusb,g' \
- ${WRKSRC}/Makefile
+USB_CFLAGS= `libusb-config --cflags`
+USB_LDFLAGS= `libusb-config --libs`
+.else
+USB_CFLAGS= # none
+USB_LDFLAGS= -lusb
.endif
do-install: