aboutsummaryrefslogtreecommitdiff
path: root/misc/hashdb
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-18 23:38:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-18 23:38:10 +0000
commitd08b1ca068a1b037de0b1fa16bcd7675690557e2 (patch)
treeeae6542a2335333e6ada3e6f92e8bfe8ce307ee5 /misc/hashdb
parent2639e4812107f461629668a9ce0d53c0eff00d75 (diff)
downloadports-d08b1ca068a1b037de0b1fa16bcd7675690557e2.tar.gz
ports-d08b1ca068a1b037de0b1fa16bcd7675690557e2.zip
Re-add misc/hashdb
configure script is broken because it looks for the SSL_library_init function when it is a macro in some OpenSSL versions. Thanks to tobik@ for the suggested fix.
Notes
Notes: svn path=/head/; revision=501994
Diffstat (limited to 'misc/hashdb')
-rw-r--r--misc/hashdb/Makefile38
-rw-r--r--misc/hashdb/distinfo3
-rw-r--r--misc/hashdb/pkg-descr11
-rw-r--r--misc/hashdb/pkg-plist10
4 files changed, 62 insertions, 0 deletions
diff --git a/misc/hashdb/Makefile b/misc/hashdb/Makefile
new file mode 100644
index 000000000000..729e8e48d241
--- /dev/null
+++ b/misc/hashdb/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= hashdb
+DISTVERSIONPREFIX= v
+DISTVERSION= 3.1.0-8
+DISTVERSIONSUFFIX= -g1da1b9f
+CATEGORIES= misc
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Block hash database tool and API
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= swig3.0:devel/swig30
+LIB_DEPENDS= libewf.so:devel/libewf
+
+USES= autoreconf gmake libtool localbase:ldflags python ssl
+GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= NPS-DEEP
+CONFIGURE_ARGS= ac_cv_lib_ssl_SSL_library_init=yes \
+ --disable-static --enable-shared # enable-shared fails: https://github.com/NPS-DEEP/hashdb/issues/9
+
+INSTALL_TARGET= install-strip
+
+CONFIGURE_ENV= PYTHON=${PYTHON_CMD}
+BINARY_ALIAS= swig=${LOCALBASE}/bin/swig3.0
+
+CFLAGS+= -fPIC
+CXXFLAGS+= -fPIC
+
+PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHONPREFIX_SITELIBDIR:S;${PREFIX}/;;}
+
+post-configure:
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} 's| -lstdc++ | |'
+
+.include <bsd.port.mk>
diff --git a/misc/hashdb/distinfo b/misc/hashdb/distinfo
new file mode 100644
index 000000000000..2f50e7859ab2
--- /dev/null
+++ b/misc/hashdb/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1558192369
+SHA256 (NPS-DEEP-hashdb-v3.1.0-8-g1da1b9f_GH0.tar.gz) = 14e1043c62269e577b1b417a9913b7f8abfb76aad0b7c5977b938449912eecec
+SIZE (NPS-DEEP-hashdb-v3.1.0-8-g1da1b9f_GH0.tar.gz) = 747811
diff --git a/misc/hashdb/pkg-descr b/misc/hashdb/pkg-descr
new file mode 100644
index 000000000000..8b8c4cab8d06
--- /dev/null
+++ b/misc/hashdb/pkg-descr
@@ -0,0 +1,11 @@
+hashdb is used for finding blacklist data in raw media by using cryptographic
+hashes calculated from hash blocks.
+
+The hashdb tool provides commands for creating hash databases of MD5 hashes on
+files aligned along hash block boundaries as well as querying hash databases,
+merging hash databases, and performing hash lookups.
+
+hashdb provides C++ and Python interfaces for working with and scanning hashdb
+databases.
+
+WWW: https://github.com/NPS-DEEP/hashdb
diff --git a/misc/hashdb/pkg-plist b/misc/hashdb/pkg-plist
new file mode 100644
index 000000000000..007c24104672
--- /dev/null
+++ b/misc/hashdb/pkg-plist
@@ -0,0 +1,10 @@
+bin/hashdb
+include/hashdb.hpp
+lib/libhashdb.a
+%%PYTHON_SITELIBDIR%%/__pycache__/hashdb.cpython-36.opt-1.pyc
+%%PYTHON_SITELIBDIR%%/__pycache__/hashdb.cpython-36.pyc
+%%PYTHON_SITELIBDIR%%/_hashdb.so
+%%PYTHON_SITELIBDIR%%/_hashdb.so.0
+%%PYTHON_SITELIBDIR%%/_hashdb.so.0.0.0
+%%PYTHON_SITELIBDIR%%/hashdb.py
+man/man1/hashdb.1.gz