aboutsummaryrefslogtreecommitdiff
path: root/misc/hello
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-12-30 04:04:11 +0000
committerSteve Price <steve@FreeBSD.org>1999-12-30 04:04:11 +0000
commit43bf4367849701ee2c81879ccfe106651947a9be (patch)
treebdd838e0ff21c1905fbaac798ef2cd545a3d4aef /misc/hello
parent77c6b25d6a14ef4f842578987c99c15df1118aa1 (diff)
downloadports-43bf4367849701ee2c81879ccfe106651947a9be.tar.gz
ports-43bf4367849701ee2c81879ccfe106651947a9be.zip
Honor CFLAGS and get the install-info incantation correct in both the
package and the Makefile. Noticed by: asami
Notes
Notes: svn path=/head/; revision=24281
Diffstat (limited to 'misc/hello')
-rw-r--r--misc/hello/Makefile5
-rw-r--r--misc/hello/files/patch-aa11
-rw-r--r--misc/hello/pkg-plist2
3 files changed, 17 insertions, 1 deletions
diff --git a/misc/hello/Makefile b/misc/hello/Makefile
index ec0a943a0298..6bb6d6c80e9d 100644
--- a/misc/hello/Makefile
+++ b/misc/hello/Makefile
@@ -18,4 +18,9 @@ WRKSRC= ${WRKDIR}/hello-1.3
GNU_CONFIGURE= YES
+post-install:
+ @install-info --dir-file=${PREFIX}/info/dir \
+ --entry="* Hello: (hello). Hello Reference Manual." \
+ ${PREFIX}/info/hello.info
+
.include <bsd.port.mk>
diff --git a/misc/hello/files/patch-aa b/misc/hello/files/patch-aa
new file mode 100644
index 000000000000..820251a8cacb
--- /dev/null
+++ b/misc/hello/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Wed Dec 29 21:53:22 1999
++++ Makefile.in Wed Dec 29 21:53:39 1999
+@@ -31,7 +31,7 @@
+ DEFS = @DEFS@
+ LIBS = @LIBS@
+
+-CFLAGS = -g
++CFLAGS ?= -g
+ LDFLAGS = -g
+
+ prefix = /usr/local
diff --git a/misc/hello/pkg-plist b/misc/hello/pkg-plist
index bd9c3d844f82..14ec0727fce2 100644
--- a/misc/hello/pkg-plist
+++ b/misc/hello/pkg-plist
@@ -1,4 +1,4 @@
bin/hello
@unexec install-info --delete %D/info/hello.info %D/info/dir
info/hello.info
-@exec install-info %D/info/hello.info %D/info/dir
+@exec install-info --dir-file=%D/info/dir --entry="* Hello: (hello). Hello Reference Manual." %D/info/hello.info