aboutsummaryrefslogtreecommitdiff
path: root/misc/heyu2
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-06-03 07:40:32 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-06-03 07:40:32 +0000
commit549d97656808cd33641c54bb228b4ed8a2252bad (patch)
tree139d78708e5d13f261be3266ece27a42dbf5fdaf /misc/heyu2
parent4aed171d2817123b9dd1edc5c480ed96d1a62a77 (diff)
downloadports-549d97656808cd33641c54bb228b4ed8a2252bad.tar.gz
ports-549d97656808cd33641c54bb228b4ed8a2252bad.zip
- adoption of optionsNG
- trim historical headers Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=319758
Diffstat (limited to 'misc/heyu2')
-rw-r--r--misc/heyu2/Makefile33
1 files changed, 16 insertions, 17 deletions
diff --git a/misc/heyu2/Makefile b/misc/heyu2/Makefile
index cf182083d789..659b7652dc78 100644
--- a/misc/heyu2/Makefile
+++ b/misc/heyu2/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: heyu2
-# Date created: 29 March 2004
-# Whom: mstowe@chicago.us.mensa.org
-#
+# Created by: mstowe@chicago.us.mensa.org
# $FreeBSD$
-#
PORTNAME= heyu2
PORTVERSION= 2.10
@@ -33,36 +29,39 @@ MAN5= x10aux.5 \
x10rfxmeters.5 \
x10rfxsensors.5
-OPTIONS= CM17A "X10 CM17A \"Firecracker\" Support" on \
- EXTENDED "Extended Type 0 (Shutter/Shade) Support" on \
- RFXSENS "RFXSensors (RF) Support" on \
- RFXMETER "RFXMeter (RF) Support" on \
- DMX "Digimax Thermostat Support" on \
- OREGON "Oregon Support" on
+OPTIONS_DEFINE= CM17A EXTENDED RFXSENS RFXMETER DMX OREGON
+CM17A_DESC= X10 CM17A "Firecracker" Support
+EXTENDED_DESC= Extended Type 0 (Shutter/Shade) Support
+RFXSENS_DESC= RFXSensors (RF) Support
+RFXMETER_DESC= RFXMeter (RF) Support
+DMX_DESC= Digimax Thermostat Support
+OREGON_DESC= Oregon Support
+
+OPTIONS_DEFAULT= CM17A EXTENDED RFXSENS RFXMETER DMX OREGON
.include <bsd.port.options.mk>
-.if !defined(WITH_CM17A)
+.if ! ${PORT_OPTIONS:MCM17A}
CONFIGURE_ARGS+= nocm17a
.endif
-.if !defined(WITH_EXTENDED)
+.if ! ${PORT_OPTIONS:MEXTENDED}
CONFIGURE_ARGS+= noext0
.endif
-.if !defined(WITH_RFXSENS)
+.if ! ${PORT_OPTIONS:MRFXSENS}
CONFIGURE_ARGS+= norfxs
.endif
-.if !defined(WITH_RFXMETER)
+.if ! ${PORT_OPTIONS:MRFXMETER}
CONFIGURE_ARGS+= norfxm
.endif
-.if !defined(WITH_DMX)
+.if ! ${PORT_OPTIONS:MDMX}
CONFIGURE_ARGS+= nodmx
.endif
-.if !defined(WITH_OREGON)
+.if ! ${PORT_OPTIONS:MOREGON}
CONFIGURE_ARGS+= noore
.endif