aboutsummaryrefslogtreecommitdiff
path: root/misc/hotkeys/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-03-06 07:49:55 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-03-06 07:49:55 +0000
commitdaf9e3e20f386a0f05b03bd53a70adc19ad7e191 (patch)
treefb6f024dfe562e679ba37f81748eec782f375119 /misc/hotkeys/Makefile
parentd5fa43bf4b9cb5657b46bea279040e69ebe6db8a (diff)
- More xosd fix
- Correctly handle configuration files - Add new features in example configuration Submitted by: Alexey Privalov <lubeg at rootshell.be> - Use USE_BDB, make it supports all supportted version in ports tree Tested by: Alexey Privalov <lubeg at rootshell.be>
Notes
Notes: svn path=/head/; revision=186654
Diffstat (limited to 'misc/hotkeys/Makefile')
-rw-r--r--misc/hotkeys/Makefile23
1 files changed, 15 insertions, 8 deletions
diff --git a/misc/hotkeys/Makefile b/misc/hotkeys/Makefile
index ce6ad2a8552d..8d8214dad960 100644
--- a/misc/hotkeys/Makefile
+++ b/misc/hotkeys/Makefile
@@ -6,7 +6,7 @@
PORTNAME= hotkeys
PORTVERSION= 0.5.7.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= misc
MASTER_SITES= http://ypwong.org/hotkeys/${PORTVERSION}/ \
${MASTER_SITE_XCONTRIB}
@@ -15,20 +15,20 @@ DISTNAME= hotkeys_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows usage of special keys on internet/multimedia keyboards
-LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
- db3.3:${PORTSDIR}/databases/db3
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-CONFIGURE_ARGS= --with-db3-inc=${LOCALBASE}/include/db3 \
- --with-db3-lib=${LOCALBASE}/lib \
+CONFIGURE_ARGS= --with-db3-inc=${BDB_INCLUDE_DIR} \
+ --with-db3-lib=${BDB_LIB_DIR} \
+ --with-db-name=${BDB_LIB_NAME} \
--x-includes=${X11BASE}/include \
--x-libraries=${X11BASE}/lib
GNU_CONFIGURE= yes
+USE_BDB= yes
USE_GMAKE= yes
+
MAN1= hotkeys.1
-ORIG_CONFIG= ${PREFIX}/etc/hotkeys.conf
-SAMPLE_CONFIG= ${PREFIX}/etc/hotkeys.conf.sample
OPTIONS= XOSD "Enable On-Screen-Display support" on
@@ -44,8 +44,15 @@ post-extract:
@${CP} ${PATCHDIR}/eliteduo.def ${WRKSRC}/def
@${CP} ${PATCHDIR}/logitech-ultrax.def ${WRKSRC}/def
+post-patch:
+ @${REINPLACE_CMD} -e '/^install-exec-am/s/install-sysconfDATA//' \
+ ${WRKSRC}/src/Makefile.in
+
post-install:
- @${MV} ${ORIG_CONFIG} ${SAMPLE_CONFIG}
+ @${INSTALL_DATA} ${WRKSRC}/src/hotkeys.conf ${PREFIX}/etc/hotkeys.conf.sample
+ @if [ ! -f ${PREFIX}/etc/hotkeys.conf ]; then \
+ ${CP} -p ${PREFIX}/etc/hotkeys.conf.sample ${PREFIX}/etc/hotkeys.conf ; \
+ fi
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>