aboutsummaryrefslogtreecommitdiff
path: root/misc/iselect
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-10-12 12:09:34 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-10-12 12:09:34 +0000
commita9901c75717c4bd60e958177e7c8946167f22f23 (patch)
tree1a0b9c5d4ce09d607656fabc9dae28096795f396 /misc/iselect
parent781bc45c78cefee0e80bf502daf31f48540bb5e2 (diff)
downloadports-a9901c75717c4bd60e958177e7c8946167f22f23.tar.gz
ports-a9901c75717c4bd60e958177e7c8946167f22f23.zip
Update to version 1.3.0
PR: ports/72323 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=118970
Diffstat (limited to 'misc/iselect')
-rw-r--r--misc/iselect/Makefile28
-rw-r--r--misc/iselect/distinfo4
-rw-r--r--misc/iselect/pkg-descr20
-rw-r--r--misc/iselect/pkg-message10
-rw-r--r--misc/iselect/pkg-plist27
5 files changed, 58 insertions, 31 deletions
diff --git a/misc/iselect/Makefile b/misc/iselect/Makefile
index b83f411fe6cd..e94f4523a237 100644
--- a/misc/iselect/Makefile
+++ b/misc/iselect/Makefile
@@ -6,17 +6,35 @@
#
PORTNAME= iselect
-PORTVERSION= 1.2.0
+PORTVERSION= 1.3.0
CATEGORIES= misc
-MASTER_SITES= http://www.engelschall.com/sw/iselect/distrib/ \
- ftp://ftp.engelschall.com/sw/iselect/
+MASTER_SITES= ftp://ftp.ossp.org/pkg/tool/iselect/
MAINTAINER= ports@FreeBSD.org
COMMENT= Interactive Selection Tool
-HAS_CONFIGURE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
MAN1= iselect.1
-PLIST_FILES= bin/iselect
+
+.if defined(WITH_SLANG)
+LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang
+CONFIGURE_ARGS+= --with-incdir=${LOCALBASE}/include \
+ --with-libdir=${LOCALBASE}/lib
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g' ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/iselect ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/iselect.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ cd ${WRKSRC}/example && ${FIND} . | \
+ ${CPIO} -pdm -L -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.endif
.include <bsd.port.mk>
diff --git a/misc/iselect/distinfo b/misc/iselect/distinfo
index 8c430f370fcc..d79a3ff6d7de 100644
--- a/misc/iselect/distinfo
+++ b/misc/iselect/distinfo
@@ -1,2 +1,2 @@
-MD5 (iselect-1.2.0.tar.gz) = e2421e7b883171eb8082239c44bcd872
-SIZE (iselect-1.2.0.tar.gz) = 74244
+MD5 (iselect-1.3.0.tar.gz) = 3771a3c5133ad8d5896760dd7badc48e
+SIZE (iselect-1.3.0.tar.gz) = 107233
diff --git a/misc/iselect/pkg-descr b/misc/iselect/pkg-descr
index 82943a1e65df..02411613b282 100644
--- a/misc/iselect/pkg-descr
+++ b/misc/iselect/pkg-descr
@@ -1,15 +1,7 @@
- _ ____ _ _
- (_) ___| ___| | ___ ___| |_
- / /\___ \ / _ \ |/ _ \/ __| __|
- / / ___) | __/ | __/ (__| |_
- (_( |____/ \___|_|\___|\___|\__|
+iSelect is an interactive line selection tool for ASCII files, operating
+via a full-screen Curses-based terminal session. It can be used either as
+an user interface frontend controlled by a Bourne-Shell/Perl/Tcl backend
+as its control script or in batch mode as a pipeline filter (usually
+between grep and the final executing command).
- iSelect -- Interactive Selection Tool
-
- iSelect is an interactive line selection tool for ASCII files, operating
- via a full-screen Curses-based terminal session. It can be used either as
- an user interface frontend controlled by a Bourne-Shell/Perl/Tcl backend
- as its control script or in batch mode as a pipeline filter (usually
- between grep and the final executing command).
-
-WWW: http://www.engelschall.com/sw/iselect/
+WWW: http://www.ossp.org/pkg/tool/iselect/
diff --git a/misc/iselect/pkg-message b/misc/iselect/pkg-message
deleted file mode 100644
index 93d868e210b8..000000000000
--- a/misc/iselect/pkg-message
+++ /dev/null
@@ -1,10 +0,0 @@
- Copyright (c) 1996-1999 Ralf S. Engelschall.
-
- This program is free software; it may be redistributed and/or modified only
- under the terms of the GNU General Public License, which may be found in the
- iSelect source distribution. Look at the file COPYING for details.
-
- This program is distributed in the hope that it will be useful, but WITHOUT
- ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
- for more details.
diff --git a/misc/iselect/pkg-plist b/misc/iselect/pkg-plist
new file mode 100644
index 000000000000..b4b44df5e277
--- /dev/null
+++ b/misc/iselect/pkg-plist
@@ -0,0 +1,27 @@
+bin/iselect
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/chdir/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/chdir/dot.bashrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/gotourl/dot.gotourlrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/gotourl/dot.vimrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/gotourl/gotourl
+%%PORTDOCS%%%%EXAMPLESDIR%%/ilogin/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/ilogin/dot.bashrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/ilogin/dot.ilogin
+%%PORTDOCS%%%%EXAMPLESDIR%%/ilogin/ilogin
+%%PORTDOCS%%%%EXAMPLESDIR%%/melm/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/melm/melm
+%%PORTDOCS%%%%EXAMPLESDIR%%/melm/xmelm
+%%PORTDOCS%%%%EXAMPLESDIR%%/mtin/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/mtin/mtin
+%%PORTDOCS%%%%EXAMPLESDIR%%/mtin/xmtin
+%%PORTDOCS%%%%EXAMPLESDIR%%/scvs/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/scvs/dot.scvsrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/scvs/scvs
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/scvs
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/mtin
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/melm
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/ilogin
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/gotourl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/chdir
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%