aboutsummaryrefslogtreecommitdiff
path: root/misc/kcd
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2006-03-11 01:19:17 +0000
committerKris Kennaway <kris@FreeBSD.org>2006-03-11 01:19:17 +0000
commitfc82e6afa9bed0163be31d687486e136443c7b24 (patch)
tree56d496b52f1bc4913c633c81259e64824a211443 /misc/kcd
parent5c88c0f7a517345471057b17878b03bf2a7a1c27 (diff)
downloadports-fc82e6afa9bed0163be31d687486e136443c7b24.tar.gz
ports-fc82e6afa9bed0163be31d687486e136443c7b24.zip
Mark IGNORE on 7.x: the configure script attempts to force a memory
allocation failure by using setrlimit(RLIMIT_DATA, ...) and doing malloc, except malloc no longer uses sbrk() to allocate memory so this ends up running the entire machine out of swap. Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=157055
Diffstat (limited to 'misc/kcd')
-rw-r--r--misc/kcd/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/misc/kcd/Makefile b/misc/kcd/Makefile
index 9c891cebeadd..729f332d988e 100644
--- a/misc/kcd/Makefile
+++ b/misc/kcd/Makefile
@@ -24,6 +24,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= kcd.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 700013
+IGNORE= allocates an infinite amount of memory in configure script
+.endif
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/kcd-inst ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/kcdscr ${PREFIX}/bin
@@ -42,4 +48,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/kcd.sh.init ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>